[background] wallpapers in grid are too small, take long time to load

Bug #1205562 reported by Jeremy Bicha on 2013-07-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+3.0 (Ubuntu)
Medium
Unassigned

Bug Description

1. From GNOME Shell, right-click on the desktop and select Change Background…
(If not running GNOME Shell, run XDG_CURRENT_DESKTOP=GNOME gnome-control-center background )
2. Click on the big wallpaper button

What should happen
================
The default wallpapers show up within about a second or two. There's room for about 9 wallpapers that fully fill the white part of the window (3 rows and 3 columns although the bottom row only shows the top half of the wallpapers).

What happens
===========
Recently in Saucy, the wallpapers started showing up much smaller than they should. There's room for about 16 in a single row. Also the wallpapers take much, much longer to load than previously. On my laptop, it took about 37 seconds for the first row of wallpapers to finish showing up. Screenshot attached.

Notably this does not affect Ubuntu 13.04 with the GNOME3 PPA which includes quite a bit of GNOME 3.8 backported including GTK+ 3.8.2. The GNOME3 PPA does not currently include an updated gnome-control-center and gnome-settings-daemon (Ubuntu 13.04 ships 1:3.6.3-0ubuntu24.1).

https://launchpad.net/~gnome3-team/+archive/gnome3/+packages?field.series_filter=raring

This has not yet been reported in gnome-control-center's bugzilla nor have any relevant commits been made to the background panel in trunk: https://git.gnome.org/browse/gnome-control-center/log/panels/background

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: gnome-control-center 1:3.6.3-0ubuntu30
ProcVersionSignature: Ubuntu 3.10.0-5.15-generic 3.10.2
Uname: Linux 3.10.0-5-generic x86_64
ApportVersion: 2.11-0ubuntu1
Architecture: amd64
Date: Fri Jul 26 22:48:29 2013
InstallationDate: Installed on 2013-06-14 (42 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64 (20130613)
MarkForUpload: True
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 activity-log-manager 0.9.7-0ubuntu4
 deja-dup 27.3.1-0ubuntu1
 gnome-control-center-signon 0.1.7~+13.10.20130724.1-0ubuntu1
 gnome-control-center-unity 1.3daily13.06.14.1-0ubuntu1
 indicator-datetime 12.10.3+13.10.20130725-0ubuntu1

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) on 2013-07-27
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1205562

tags: added: iso-testing
Jeremy Bicha (jbicha) wrote :

This bug is caused by https://launchpad.net/ubuntu/+source/gdk-pixbuf/2.28.1-1ubuntu2

I no longer experience this bug after downgrading gdk-pixbuf to 2.28.1-1ubuntu1.

affects: gnome-control-center (Ubuntu) → gdk-pixbuf (Ubuntu)
Changed in gdk-pixbuf (Ubuntu):
assignee: nobody → William Hua (attente)
William Hua (attente) on 2013-07-29
Changed in gdk-pixbuf (Ubuntu):
status: New → Confirmed
desrt (desrt) wrote :

Gtk bug. Gtk puts loadable icons ahead of pixbufs in its icon loading code, and now that GdkPixbuf is a gloadable icon, it'll take the slow path. The order of the cases in gtkicontheme.c:gtk_icon_theme_lookup_by_gicon_for_scale() needs to be changed.

desrt (desrt) wrote :
William Hua (attente) on 2013-08-01
Changed in gdk-pixbuf (Ubuntu):
status: Confirmed → Invalid
Jeremy Bicha (jbicha) on 2013-08-01
affects: gdk-pixbuf (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
assignee: William Hua (attente) → nobody
status: Invalid → Triaged
Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
Changed in gtk:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.8.2-3ubuntu5

---------------
gtk+3.0 (3.8.2-3ubuntu5) saucy; urgency=low

  * debian/patches/git_check_for_gdkpixbuf_first.patch:
    - Backport patch to fix slow icon loading in GNOME's Background Setttings
      panel. Thanks Ryan Lortie for the fix! (LP: #1205562)
 -- Jeremy Bicha <email address hidden> Thu, 01 Aug 2013 20:37:08 -0400

Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.