mouse scroll wheel not working in gedit & System Monitor

Bug #1171342 reported by kylea on 2013-04-22
228
This bug affects 56 people
Affects Status Importance Assigned to Milestone
Compiz
High
Christopher Townsend
GTK+
Fix Released
Medium
X.Org X server
Confirmed
Medium
compiz (Ubuntu)
High
Christopher Townsend
gtk+3.0 (Ubuntu)
High
Unassigned
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

Open System Monitor

Using mouse wheel button - scroll up or down - list does not move. If Press the wheel button and then scroll up or down the list will move.

This also occurs in Gedit. Firefox and Terminal work as expected. IE do not need to press the wheel and then scroll

Linux kylea-hpxt 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Description: Ubuntu 13.04
Release: 13.04

Related branches

jrr (johnruble) wrote :

I had these symptoms under xfce after an update today, but they went away after a restart.

kylea (kylea) wrote :

Did an Update - still the same - in some forms have to press the wheel and then scroll.

kylea (kylea) wrote :

Bluetooth connected device works as expected - seems to only affect a direct USB connected device

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Helio Neto (remiariro) wrote :

Same here, but it only affects gedit, everything else is ok.
Tested with USB mouse only.

Helio Neto (remiariro) wrote :

After updates from today's raring release, gedit's got back to normal behave.
I think this bug was related to https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1171156

Same issue here. Scrollwheel does not work in gedit and document viewer, but it works perfectly in Firefox, Mousepad. I use Ubuntu 13.10 with XFCE-Desktop. I have a Logitech-Mouse with Nano-Reciever.

3.11.0-11-generic #17-Ubuntu SMP Tue Oct 1 19:42:04 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Wheel works fine in System-Monitor, but not in Document-Viewer and not in Gedit.

Chris Malton (chrism-u) wrote :

I'm seeing the same issue as Christian in Ubuntu 13.10 (Saucy) updated as of last night.

Issue seems to be Document Viewer (evince?) and gedit only so far....

Chris Malton (chrism-u) wrote :

I should probably add that I'm running xfce4 as a desktop environment. => Not entirely a Unity problem.

I'm pretty sure this is a issue in Gtk+3.0 due to a fix put in affecting mouse wheel scrolling. I have a potential fix in my PPA at ppa:townsend/gtk-testing. Could someone affected by this bug please try my PPA and let me know? If it does fix it, then I'll continue to try to upstream this to get it fixed.

Chris Malton (chrism-u) wrote :

Christopher: Perfect, thanks! That PPA's got a fix for it.

@Chris,

Thanks for confirming. I'll see what I can do about getting Gtk+3 fixed (I'm not a Gtk dev).

affects: unity (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk:
importance: Unknown → Medium
status: Unknown → Confirmed
Hồng Quân (ng-hong-quan) wrote :

PPA works for me. Thank you so much.

Marc Lanctot (lanctot) wrote :

@Chris, your PPA also worked for me. Thanks!

Note: I had this problem after a distribution upgrade (to Xubuntu 13.10) on my work machine.. however, my home machine I did a fresh install of Xubuntu 13.10 and did not have this problem.

Marc Lanctot (lanctot) wrote :

Oops, forgot to mention: scroll wheel did not work in both evince and gedit, both of which have been fixed by the PPA.

Sergio Callegari (callegar) wrote :

Seeing this on a kubuntu machine after upgrade from raring to saucy.

Another application showing the issue is synaptic.

Holger Mauermann (mauermann) wrote :

I upgraded today from raring to saucy and was affected by this bug too. However, Christopher Townsend's PPA worked for me. Thanks!

Are people affected by this bug using any special mouse wheel bindings such as switching workspaces using the Viewport Switcher plugin in Compiz? I'm trying to understand what could be triggering this for different users.

Thanks!

Chris Malton (chrism-u) wrote :

My setup has no Compiz, as far as I'm aware.

I originally installed Ubuntu, forgetting how badly I get on with GNOME Shell/GNOME 3 etc, and then did an apt-get install xfce4.

Perhaps not the right way to install XFCE, but the only thing my scroll wheel is now used for (other than scrolling up/down documents) is changing workspaces when over the workspace switcher and/or the desktop.

Hi Chris,

Thanks for your info. How exactly are you binding the scroll wheel to switch workspaces?

Chris Malton (chrism-u) wrote :

Hi Christopher,

It was pre-bound as part of installing XFCE4. I haven't added/removed any mouse bindings that I know about.
Standard behaviour in XFCE4's workspace switcher is that scroll-wheel switches workspace, and scrolling on the desktop has the same effect.

Chris

Hi Chris,

Ok, thanks!

kylea (kylea) wrote :

i use the mouse wheel eith Compiz to rotate thru my virtual desktops

kevin.cao (nivek-cao) wrote :

Christopher's PPA saved me, one more thing

after apply the fix, I have to restart Firefox, and then "Smooth Scrolling" will be normal.

John Stultz (jstultz) wrote :

PPA fix resovled it for me as well using xfce.

rabbit83 (mail-to-me) wrote :

Same Problem here (Unity, Compiz) after upgrading to saucy. Disabling the "Destkop-based viewport switching" makes scrolling in gedit, nautilus... work. Enabling -> scrolling stops working.

Firefox, Thunerbird, Libre Office.. are uneffected and working in both cases.

Chris Malton (chrism-u) wrote :

Since an update this morning, this broke again (despite having Chris' PPA turned on....)

Chris - could you bump the PPA again?

Chris Malton (chrism-u) wrote :

I should add that a downgrade of the 3 packages to Chris' PPA versions fixes things again for me.

Changed in gtk+3.0 (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Doug Brunner (madengineer10) wrote :

Issue appeared for me with upgrade of Xubuntu from Raring to Saucy. Compiled gtk+3.0-3.8.6-0ubuntu2 with Chris Townsend's patch added, installed, fixed the problem.

@Chris Malton I'm still slightly a newbie. I am asking how did you downgrade the packages, because the same issue has resurfaced and is irritatiing.

Changed in gtk:
status: Confirmed → Fix Released
Chris Malton (chrism-u) wrote :

@sanja-simmonds - I recommend http://www.howtogeek.com/117929/ as a guide on how to do this.

If a client (normally a reparenting WM) sets a passive button grab and it is triggered when the pointer is above another client's window (eg. a WM-managed window), crossing events will be rightfully generated, however XI2 crossing events in the second client don't contain the expected mode, XINotifyPassiveGrab/Ungrab would be appropriate here, but XINotifyGrab/Ungrab are used instead.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.8.7-0ubuntu1

---------------
gtk+3.0 (3.8.7-0ubuntu1) trusty; urgency=low

  * New upstream version:
    - should make scroll working again in gedit under xfce (lp: #1171342),
      there is an xserver side change that is going to be required for other
      environments though (e.g under compiz)
  * debian/patches/git_frame_disconnect.patch,
    debian/patches/git_frame_update.patch,
    debian/patches/git_submenus_leak.patch:
    - dropped, the fixes are in the new version
 -- Sebastien Bacher <email address hidden> Fri, 22 Nov 2013 16:41:24 +0100

Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Released

Adding xorg-server since that is the missing piece. There are some patches proposed for upstream xorg-server that does fix this issue in my testing. Hopefully they will be accepted soon and then we can get them into Ubuntu.

Changed in xorg-server (Ubuntu):
status: New → Triaged
importance: Undecided → Medium

Hi Carlos,

I tried these patches. Coupled with the Gtk+ fix, this does indeed fix the various scrolling issues! Hopefully the patches will be reviewed/accepted soon.

Thanks a million for addressing this!

Changed in xorg-server:
importance: Unknown → Medium
status: Unknown → Confirmed
Timo Aaltonen (tjaalton) on 2013-11-26
tags: added: trusty

Well... as stated in #34 status us set to Fix released for gtk+3.0, but what about Saucy users? Do we have to move on using Trusty to get this bug fixed?

Sebastien Bacher (seb128) wrote :

> Well... as stated in #34 status us set to Fix released for gtk+3.0,

that's how launchpad works, the status concerns the current serie. We can target saucy if we want, which would add another line in the bug table

> but what about Saucy users? Do we have to move on using Trusty to get this bug fixed?

That's one option. We first need xserver fixed though. Once the fix is in and confirmed to work, without creating regressions, we can discuss backporting to saucy

Do you have a test case for this? I knocked up a simple one with two XI2 clients, one creating a window with enter/leave on a window, one with enter/leave on the button grab on the root window. Neither client gets an event and a printf in the server shows nothing is written onto the wire either (only the button event to activate the grab).

If I change to an active grab + ungrab, I get the events correctly.

Christian González (droetker) wrote :

As affected saucy (stable!) user, I think this should get high priority on saucy too. Gedit is THE main text editor in Ubuntu (any release), and this bug renders Gedit nearly unusable.

Sebastien Bacher (seb128) wrote :

gedit is perfectly usable, just don't use whell scrolling to change workspace (which is not a default configuration)

erik (zierka) wrote :

Christopher's PPA solved the scrolling issue with Gedit and Document Viewer but now the brightness keys stopped working (Fn + F10-12). Xubuntu 13.10, original Xfce, Asus Laptop

erik (zierka) wrote :

It actually killed all my keyboard shortcuts, none of them work except the brightness keys.

Is there an ETA on when the patches are going to be merged into master?

Arno (idfafp) wrote :

Same issue, only in gedit.

Christian González (droetker) wrote :

@Sebastien Bacher: gedit is NOT perfectly usable - i never changed the compiz settings of switching workspaces, it's the default setting here. Even when I install CCSM and deactivate viewport switching alltogether, the scroll issue in gedit remains (and only there!) - gnome-system-monitor is not affected here. maybe this is another bug?

Fredde (fredde-iki) wrote :

For me, this also affects Bluefish Editor.

This happens for me in gedit and Document Viewer.

Salvation (jjmatt) wrote :

This happens for me as well. The issue shows up in Nautilus, Synaptic, Transmission, gedit, document viewer, and I'm sure more than a few other applications. It doesn't happen in gnome-terminal, chrome, firefox, clementine.

I can't find the package in synaptic to downgrade it to (I'm looking for gtk+3.0 correct?), so I cannot test the PPA just yet. Any suggestions?

I am however using the scrollwheel to switch workspaces. Turning this off does allow me to scroll within the above applications, but I need to be focused on that application. If it's a background app, I still cannot scroll. This functionality in applications where it previously worked, did not change,

Kris (kristian-holsheimer) wrote :

I'm having the same problem and adding the PPA "ppa:townsend/gtk-testing" doesn't help. After I add it and run "apt-get update" there's nothing to upgrade.

Also, the title of the bug suggests that there might also be a problem with System Monitor, but I only experience the issue in gedit. All other applications are scrolling just fine.

Any ideas? Would this be a separate bug?

I've tried disabling workspace scrolling and switching between overlay/legacy scrollbars, but that made no difference.

Since the proposed patches to X have been rejected, what can be done here to fix this properly?

Kris (kristian-holsheimer) wrote :

It seemed that my problem was related to Bug #1200829. For those of you who experience the same problem I had, the fix is given in the PPA:

ppa:mc3man/test-scroll

IMHO, this is quite an annoying regression.

Just in case it's not obvious what the effect is, there are steps to reproduce it at https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1240957: you just have to run two apps like gnome-terminal and nautilus and try using the mouse wheel to scroll them. nautilus no longer scrolls with the mouse wheel unless it has focus, whereas gnome-terminal always scrolls. Scrolling without requiring focus has always been one of the nice things about X desktops, and now it's inconsistent and broken.

Willy (domenico-rizzo) wrote :

I have same bug, but when I "push" the wheel and at the same time I "scroll" it then the scrolling works.

Sandro Rettinger (perlhaqr) wrote :

I see the same issue after upgrading (yes, just recently, I'm a slacker) to 13.10 from 13.04, on evince and nautilus. I too am running XFCE. (Specifically 4.10)

Hovering over those applications and using the scroll wheel still raises them, just as if I'd clicked on them, but does not scroll them.

"click scrolling" (as described above by Willy) does cause the applications in question to scroll. The click functionality of my scrollwheel is normal unix middle button behaviour.

I will try the PPA listed above and report back.

Changed in compiz:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Christopher Townsend (townsend)
milestone: none → 0.9.11.0
Changed in compiz (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Christopher Townsend (townsend)
Changed in xorg-server (Ubuntu):
status: Triaged → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.04.20140404-0ubuntu1

---------------
compiz (1:0.9.11+14.04.20140404-0ubuntu1) trusty; urgency=low

  [ Chris Townsend ]
  * Fix issue where Compiz passively grabs all mouse buttons which
    severely affects scrolling in Gtk apps. Now only unconditionally
    grab buttons 1-3 for all windows except the desktop window and only
    grab other buttons when there is a modifier attached to it. (LP:
    #1171342)
  * Only fade in and fade out a window when it's hidden if it's not in
    Show Desktop mode. This allows for a good fade out effect in Unity
    when exiting Spread while in Show Desktop mode. (LP: #1104236)
 -- Ubuntu daily release <email address hidden> Fri, 04 Apr 2014 21:41:53 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Changed in compiz:
status: In Progress → Fix Committed
Aavo Tambur (aavotambur-3) wrote :

This fix just broke the way I have used Ubuntu for several years now!
I used my mouses buttons 8 and 9 to trigger Window Scale mode and Desktop Spread respectively.
Now they do not work anymore, unless the desktop is in focus.
Please provide a way to define which buttons this patch affects!

Bartmann (bartmix) wrote :

the Mouse wheel still not work in ubuntu 14.04 with the latest updates

where can i get the fix?

votdev (votdev) wrote :

Scroll wheel does not work in RapidSVN 0.12.1 Ubuntu 14.04 but works in Nautilus for example.

paul (paulse) on 2014-06-09
information type: Public → Public Security
information type: Public Security → Public
rodlaycock (rod-laycock) wrote :

I have been keeping the system updated but there still appears to be no fix for this through official updates.

Scroll wheel doesn't work properly in any application I've tried so far.

gedit, Chromium, FireFox, Libre Office even Nautalus is affected this.

Is there going to be an update / bug fix for this as this is seriously rendering an LTS unusable.

Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.