debian/patches/git_reset_scrolling.patch is adversely affecting scrolling, particularly in gedit

Bug #1171156 reported by Doug McMahon on 2013-04-21
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
Low
Unassigned

Bug Description

* Impact:
Up & down scrolling with a touchpad is now a bit jerky, seen best with gedit in large files though also seems to affect nautilus & in general.

* Testcase:
try scrolling in long documents in gedit using a touchpad, is scrolling "jerky"?

* Regression potential:
limited, we had the issue the patch tries to solve since before quantal and we are just reverting a patch added a week ago

Doug McMahon (mc3man) wrote :
summary: debian/patches/git_reset_scrolling.patch is adversely affecting
- scrolling, particulsry in gedit
+ scrolling, particularly in gedit
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

affects: gtk+3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Undecided → Low
affects: ubuntu → gtk+3.0 (Ubuntu)
Sebastien Bacher (seb128) wrote :

I can't confirm that, somebody seeing the issue will have to upstream to GNOME (https://bugzilla.gnome.org/enter_bug.cgi?product=gtk%2B)

Sebastien Bacher (seb128) wrote :

could you also try to describe "jerky", upstream wrote:

"jerky how? it is expected that the first scroll event is consumed in order to set an initial value to diff against"

Doug McMahon (mc3man) wrote :

Very hard to describe, sort of like while scrolling the window gets 'caught' at times. Overall a minor issue but at least here was quite evident that something had changed.
I initially thought maybe some recent update had caused some performance hit until I noticed the gtk3 update & reason behind.

The other area where again fairly obvious here is scrolling a long package list in synaptic, again the scroll gets caught at times, it feels like the system is struggling (which it's not.
Reverting the patch & all is back to 'normal'.

Would like to note this is on a laptop touchpad where it is quite impossible to duplicate the orig. bug

As far as this being a 'new' upstream bug', I guess one would need to try on a 3.8 build where the patch was committed, atm there is no available build, the one in the gnome3 ppa is prior to it. As far as here now this was a 3.8 commit applied to the 3.6.x source so don't see it as an upstream issue per se.
(tonight I'll patch & build the 3.8 source & try on a gnome 3.8 install to see though that's not what 13.04 is using

(ot - in the short time to release this bug should be addressed, if the current behavior is going to be changed by Thurs., great, otherwise I'd say it's a bit of an embarrassment as it currently stands
Bug 1170483

Matthieu Baerts (matttbe) wrote :

Here is a screencast without the patch (the scroll is smooth)

Matthieu Baerts (matttbe) wrote :

Another one with the patch (with the latest version of GTK). I scroll down and then up but as you can see, the scroll down is not smooth (but when scrolling up, it's ok)

Sebastien Bacher (seb128) wrote :

Thanks, it's a bit late for GTK changes before release and that's not really a stopper, but we can SRU fixes for that once we have some ready for upload

Doug McMahon (mc3man) wrote :

Only noting from here -
On a gnome3/gnome-shell only install with the gtk+3.0-3.8.0 source patched with git_reset_scrolling.patch - no issues, works fine
On a 13.04 install with gnome-shell (3.6.3.1-0ubuntu5) & gtk+3.0 (3.6.4-0ubuntu7) - no issues
On a 13.04 install with gtk+3.0 (3.6.4-0ubuntu7 in a unity session the issue exists
On a 13.04 install with the patch reverted in a unity session all is well.

Sebastien Bacher (seb128) wrote :

> On a gnome3/gnome-shell only install with the gtk+3.0-3.8.0 source patched with git_reset_scrolling.patch - no issues, works fine
> On a 13.04 install with gnome-shell (3.6.3.1-0ubuntu5) & gtk+3.0 (3.6.4-0ubuntu7) - no issues
> On a 13.04 install with gtk+3.0 (3.6.4-0ubuntu7 in a unity session the issue exists

so basically "works fine under gnome-shell, with whatever version of GTK in use", did you try GTK 3.8+patch under unity?

Matthieu Baerts (matttbe) wrote :

According to the tests made by Doug, it seems this patch introduces a more annoying problem than what we had with the previous version when using Compiz (and maybe others WM). This maybe means that it introduces unknown bugs or something is missing... Maybe more dangerous to use this version than using the previous?

> it's a bit late for GTK changes before release and that's not really a stopper

But why is it a bit too late? It's just a revert to the previous version (we don't want to include a new patch).
I agree that it's not stopper but it's not easy to scroll down when having a long list when using a touchpad (e.g. gedit, nautilus, etc. seem buggy and very slow). Why not a revert and then check why this new patch introduces this new bug?

Sebastien Bacher (seb128) wrote :

> Why not a revert and then check why this new patch introduces this new bug?

because hard freeze was last week, candidate isos are being spinned and tested and it's not sure the release team is wanting to go for rebuilding image and resetting the testing matrix due to this bug

On 04/22/2013 11:51 AM, Sebastien Bacher wrote:
>> On a gnome3/gnome-shell only install with the gtk+3.0-3.8.0 source patched with git_reset_scrolling.patch - no issues, works fine
>> On a 13.04 install with gnome-shell (3.6.3.1-0ubuntu5) & gtk+3.0 (3.6.4-0ubuntu7) - no issues
>> On a 13.04 install with gtk+3.0 (3.6.4-0ubuntu7 in a unity session the issue exists
> so basically "works fine under gnome-shell, with whatever version of GTK
> in use", did you try GTK 3.8+patch under unity?
>
Just did in a manner of sorts (didn't rebuild gtk 3.8+patch on the 13.04
unity install, nor unity againt gtk 3.8 patched, re-used the packages
previously built), whether that matters don't know..

Anyway the same poor behavior is seen in a unity session with gtk 3.8
patched.
So the 'issue' seems to only happen in an unity session

If it's worth rebuilding unity against the newer, patched gtk can do
though that takes a little while as unity has become a fairly long build

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Committed
description: updated
Sebastien Bacher (seb128) wrote :

I've uploaded a revert of the patch and made the bug SRU compliant, as suggested by the release team, they might let it in if they go for respins and there is room for that, otherwise it will have to be a SRU

Doug McMahon (mc3man) wrote :

On 04/22/2013 01:39 PM, Sebastien Bacher wrote:
> I've uploaded a revert of the patch and made the bug SRU compliant, as
> suggested by the release team, they might let it in if they go for
> respins and there is room for that, otherwise it will have to be a SRU
>
> ** Changed in: gtk+3.0 (Ubuntu)
> Status: Confirmed => Fix Committed
>
> ** Description changed:
>
> + * Impact:
> Up & down scrolling with a touchpad is now a bit jerky, seen best with gedit in large files though also seems to affect nautilus & in general.
> - reverting back to previous gtk source all scrolling returns to being smooth & consistent
>
> - ProblemType: Bug
> - DistroRelease: Ubuntu 13.04
> - Package: libgtk-3-0 3.6.4-0ubuntu7
> - ProcVersionSignature: Ubuntu 3.8.0-18.28-generic 3.8.6
> - Uname: Linux 3.8.0-18-generic x86_64
> - ApportVersion: 2.9.2-0ubuntu8
> - Architecture: amd64
> - Date: Sun Apr 21 09:43:45 2013
> - InstallationDate: Installed on 2013-03-31 (20 days ago)
> - InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130318)
> - MarkForUpload: True
> - ProcEnviron:
> - TERM=xterm
> - PATH=(custom, no user)
> - XDG_RUNTIME_DIR=<set>
> - LANG=en_US.UTF-8
> - SHELL=/bin/bash
> - SourcePackage: gtk+3.0
> - UpgradeStatus: No upgrade log present (probably fresh install)
> + * Testcase:
> + try scrolling in long documents in gedit using a touchpad, is scrolling "jerky"?
> +
> + * Regression potential:
> + limited, we had the issue the patch tries to solve since before quantal and we are just reverting a patch added a week ago
>
Well pending some 'surprise' reversion the release team should consider
fixing the 13.04 release image(s) for Ubuntu to have the FM handle the
Desktop in a live session. If they do then maybe this can also be included.

Sebastien Bacher (seb128) wrote :

Le 22/04/2013 21:00, Doug McMahon a écrit :
> the release team should consider
> fixing the 13.04 release image(s) for Ubuntu to have the FM handle the
> Desktop in a live session.
Hum, what issue is that? do you have a bug reference ?

Cheers,
Sebastien Bacher

Doug McMahon (mc3man) wrote :

On 04/22/2013 04:23 PM, Sebastien Bacher wrote:
> Le 22/04/2013 21:00, Doug McMahon a écrit :
>> the release team should consider
>> fixing the 13.04 release image(s) for Ubuntu to have the FM handle the
>> Desktop in a live session.
> Hum, what issue is that? do you have a bug reference ?
>
> Cheers,
> Sebastien Bacher
>
It's here -
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1170483

I mentioned here in comment 6 only because Dmitrijs mentioned you'd May
be one to know if intentional or not

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.6.4-0ubuntu8

---------------
gtk+3.0 (3.6.4-0ubuntu8) raring; urgency=low

  * Revert previous revision, it creates scrolling "jerkiness" issues for
    some users (lp: #1171156)
 -- Sebastien Bacher <email address hidden> Mon, 22 Apr 2013 19:28:59 +0200

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Matthieu Baerts (matttbe) wrote :

@Sebastien, thank you for this new version :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers