After pressing my Print Screen button, screen turns white and stays white with GTK 3.8

Bug #1137907 reported by Michael Terry on 2013-03-01
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+3.0 (Ubuntu)
High
Unassigned

Bug Description

After pressing my Print Screen button, screen turns white and stays white. I hear the "snapshot" sound, and my whole screen turns white as if from a flash. But it stays white and unusable. I can only recover by pressing Alt-F4, Escape, or killing gnome-screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-screenshot 3.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-8.17-generic 3.8.0
Uname: Linux 3.8.0-8-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Fri Mar 1 09:33:55 2013
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-precise-amd64-20120703-2
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-01-09 (50 days ago)
InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120703-15:08
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-screenshot
UpgradeStatus: Upgraded to raring on 2013-01-31 (28 days ago)

Michael Terry (mterry) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-screenshot (Ubuntu):
status: New → Confirmed
Michael Terry (mterry) wrote :

This is due to how opacity handling has changed in GTK+ 3.7 (which I have from the desktop PPA).

Michael Terry (mterry) wrote :

This also affects cheese.

Changed in gnome-screenshot (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
affects: gnome-screenshot (Ubuntu) → gtk+3.0 (Ubuntu)
Adolfo Jayme (fitojb) wrote :

IMHO, this flasing effect is very problematic. It's really slow in low-end machines and blocks work in other applications. This is an example of useless fanciness.

Changed in gtk:
importance: Unknown → Medium
status: Unknown → New

Those who really wants this feature for now can try pressing ENTER while the WHITE SCREEN FLASH is still on. I tried and once you press ENTER the WHITE FLASH disappears and you can see your screenshot in PICTURES folder

Jeremy Bicha (jbicha) on 2013-04-27
summary: After pressing my Print Screen button, screen turns white and stays
- white
+ white with GTK 3.8
Changed in gtk:
status: New → Fix Released
Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Released
Jari Björne (jari-bjorne) wrote :

The same issue occasionally affects Ubuntu 14.04 (Unity). It seems that the effect is just really, really slow. Usually it simply delays taking the screenshot with about 10 seconds, but sometimes the white flash effect hangs completely.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.