Using Adwaita, many widgets are drawn with a solid black background

Bug #1059374 reported by Dylan McCall on 2012-10-01
320
This bug affects 75 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
overlay-scrollbar
Undecided
Unassigned
gnome-themes-standard (Ubuntu)
Low
Unassigned
gtk+3.0 (Ubuntu)
Low
Unassigned
overlay-scrollbar (Ubuntu)
Low
Unassigned

Bug Description

When I use the Adwaita theme, some widgets end up being drawn with a black background after particular interactions. Here are two examples:

If I open gedit, by default I see a new black document. The notebook widget is visible, and rendered correctly. As soon as I open another document (no matter if I close the existing one first), the entire widget starts being drawn with a black background.

If I open System Settings, then click the (Ubuntu) Online Accounts panel, the box with the "Remove account" button has a solid black background. If, instead, I open Online Accounts directly from its launcher (run gnome-control-center credentials), everything is rendered correctly: there are no solid black backgrounds until I click "All Settings" and select the Online Accounts panel again.

This has been happening consistently on two very different machines, both updated to Quantal from 12.04 using the upgrade tool.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: libgtk-3-0 3.6.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Uname: Linux 3.5.0-16-generic x86_64
ApportVersion: 2.5.3-0ubuntu1
Architecture: amd64
Date: Sun Sep 30 21:18:23 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110906)
SourcePackage: gtk+3.0
UpgradeStatus: Upgraded to quantal on 2012-08-26 (35 days ago)

Dylan McCall (dylanmccall) wrote :
Jeremy Bicha (jbicha) on 2012-10-02
Changed in gtk+3.0 (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in gtk:
importance: Unknown → Medium
status: Unknown → Fix Released
shuerhaaken (shkn) wrote :

This bug is still there with current Adwaita theme on Ubuntu 12.10 Quantal Quetzal.
On my test machine there is a installation of gnome-shell from standard packages.

Some GtkLabels, GtkDrawingAreas or Notebook backgrounds seem to be affected.
Please see attached screenshot.

shuerhaaken (shkn) wrote :

Attachment screenshot

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-themes-standard (Ubuntu):
status: New → Confirmed
buzz (buzz2) wrote :

Removing overlay-scrollbar fixes the issue for me.

Hashem Nasarat (hnasarat) wrote :

Removing overlay-scrollbar works for me too. I'm not sure if merely disabling (rather than removing) the overlay scrollbar also fixes this.

Changed in overlay-scrollbar (Ubuntu):
assignee: nobody → Andrea Cimitan (cimi)
importance: Undecided → Low
status: New → Triaged
Changed in gnome-themes-standard (Ubuntu):
importance: Undecided → Low
Changed in ayatana-scrollbar:
status: New → Confirmed
Hashem Nasarat (hnasarat) wrote :

Update: disabling it solves the issue too:
"gsettings set com.canonical.desktop.interface scrollbar-mode normal"
http://askubuntu.com/questions/34214/how-do-i-disable-overlay-scrollbars

Žygimantas Beručka (zygis) wrote :

Is there a way to have both Adwaita and overlay-scrollbars?

Grzegorz G. (grzesiek1e5) wrote :

Still not fixed in Ubuntu 12.10. Is patch not applied yet in Ubuntu or is it applied but it doesn't work?

Daniel (findux) on 2013-02-01
Changed in gtk+3.0 (Ubuntu):
assignee: nobody → danix (morgenstern-daniel)
Sebastien Bacher (seb128) wrote :

the gtk issue is fixed in the current version, closing that side of the bug

Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Released
assignee: danix (morgenstern-daniel) → nobody
Jos Geluk (t-jos) wrote :

I still have this bug (Ubuntu 13.04)
When I open gnome-control-center from the user menu (top right in Gnome Shell), and open any widget from it, the widget's background is black. When I open the same widget from the command line, all looks well.
When I disable overlay scrollbars with gsettings (as in #8 above), the widgets look fine as well. Setting the overlay scrollbar mode back go 'overlay-auto', the widgets have black backgrounds again.
Changing themes makes no difference. I don't use Adwaita anyway.

Should I report a new bug?

Grzegorz G. (grzesiek1e5) wrote :

Looks like this bug isn't fully fixed. Don't report a new bug. Better bring all of your friends and tell them to click "affects me too" ;)

Hasan Yavuz Özderya (hyozd) wrote :

Here is more scary one. This one happens with Marlin file browser. Removing overlay scrollbar fixes this issue too.

Also affects Ubuntu 13.10 (Saucy Salamander) development branch with gedit. I'm using the LXDE Desktop Environment.

Andrea Cimitan (cimi) on 2013-09-20
Changed in overlay-scrollbar (Ubuntu):
assignee: Andrea Cimitan (cimi) → nobody
Amedeo (amedeoiantorno) wrote :

I use ubuntu 13.04 whith gnome shell and adwaita theme and I affected with this problem. I resolve use this command in a terminal

gsettings set com.canonical.desktop.interface scrollbar-mode normal

for Disable overlay scrollbars in Ubuntu 13.04

mike (pannu89) wrote :

Hi guys, any update on this? I still have this issue in 13.10.

This problem happens not only with the adwaita theme. Almost every recent theme I get has this problem with the overlay scrollbar.
Also tested with Ubuntu 14.04.

M.Hanny Sabbagh (hannysabbagh) wrote :

Still here in Ubuntu 14.04.. all the themes i have are having this bug.
Any fix?

Pablo Zubieta (pabloferz+) wrote :

I am also seeing this bug in Ubuntu 14.04.

tags: added: trusty
removed: quantal
nebirhos (nebirhos) wrote :

I confirm this bug in Ubuntu 14.04. Disabling the hidden scrollbars still fixes the issue, but it's not a solution.

Rankovic (d-rankovic) wrote :

Adding this to gtk-widgets.css will "fix" it for Numix and whatever other themes are spawned from it:

GtkWindow {
    color: @fg_color;
    background-color: @bg_color;
}
GtkPaned {
    background-color: @bg_color;
}
GtkEventBox {
    background-color: @bg_color;
}

However, this workaround does not work for Zukitwo, for example. Disabling overlay scrollbars most certainly is not "a solution".

Swarnendu Biswas (swarna-cse) wrote :

Disabling scrollbars do not help, I face the issue with certain themes like Moka and Orchis.

Leonardo Nicolas (leonicolas) wrote :

I have a similar issue using Adwaita default theme in Gnome 3.14, but what is being drawn with a black solid background is the application system bar in some applications (firefox, pidgin, playonlinux, etc. See attached).
Is It the same bug?

Juliusz Gonera (jgonera) wrote :

Graybird shows this issue but its authors don't want to merge a workaround since it's not their theme's bug:
https://github.com/shimmerproject/Greybird/issues/64

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.