Update to 3.5.8

Bug #1025531 reported by Robert Ancell on 2012-07-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
Wishlist
Unassigned

Bug Description

Overview of Changes in GTK+ 3.5.8
=================================

* gtk-launch: A new commandline utility to launch an application
  from its desktop file

* GtkStrengthBar: A new widget for displaying the strength
  or level or some quantity

* Wayland: Updates for changes in the Wayland protocol

* Bugs fixed:
 667808 Accept -1 as the position where insert an element...
 671437 GtkStyle background color regression
 671817 GTK+ doesn't create ~/.local/share (path) and ~/.local...
 675990 gtk_tree_column_set_visible badly interact with the a1...
 677347 he accessible name of the 'Lock'/'Unlock' button is al...
 677491 'toolkit-accessibility' default value should be 'true'...
 678828 gtk_application_add_accelerator() (and remove) missing...
 678829 Bloatpad example application has "parse" action instea...
 679092 gtkstyle: add a gtkstyle-fallback style class for RC c...
 679166 modelmenu: set the accel group on the GtkMenu
 679228 signal parameter names are not valid C identifiers
 679409 docs: link against libgdk-3.la
 679449 menubutton: set DROPDOWN_MENU hint on the menu topleve...
 679454 modelmenu: listen for toplevel changes on the attach w...
 679537 Crash in GtkEntry gtk_entry_get_icon_pixbuf()
 679705 Using NULL with gtk_application_set_menubar causes seg...
 677892 Add a GtkStrengthBar widget
 679342 Add a gtk-launch utility

* Translation updates:
 Bulgarian
 Greek
 Norwegian nynorsk
 Telugu
 Vietnamese

Robert Ancell (robert-ancell) wrote :

Test cases fail like this for me:

TEST: accessibility-dump... (pid=12270)

** (/home/bob/bzr/ubuntu/build-area/gtk+3.0-3.5.8/debian/build/shared/tests/a11y/.libs/lt-accessibility-dump:12270): WARNING **: atk-bridge: Couldn't listen on dbus server: In D-Bus address, character '+' should have been escaped

FAIL: accessibility-dump

description: updated
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Sebastien Bacher (seb128) wrote :

uploaded to quantal-proposed, it builds fine here

Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.5.8-0ubuntu1

---------------
gtk+3.0 (3.5.8-0ubuntu1) quantal-proposed; urgency=low

  * New upstream version (lp: #1025531)
    * gtk-launch: A new commandline utility to launch an application from
      its desktop file
    * GtkStrengthBar: A new widget for displaying the strength or level
      or some quantity
    * Wayland: Updates for changes in the Wayland protocol
    * Bugs fixed
  * debian/control.in:
    - libgail-3-0 depends on at-spi2-core since a11y is an hard depends
  * debian/libgtk-3-0.symbols:
    - Updated
  * debian/libgtk-3-bin.install:
    - install gtk-launcher there
 -- Sebastien Bacher <email address hidden> Wed, 18 Jul 2012 16:15:26 +0200

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers