Cannot select gtk dropdown list value in multiple applications: ubiquity, landscape client

Bug #1015497 reported by Jean-Baptiste Lallement on 2012-06-20
72
This bug affects 12 people
Affects Status Importance Assigned to Milestone
GTK+
Expired
Medium
gtk+3.0 (Ubuntu)
High
Unassigned
Quantal
High
Unassigned
light-themes (Ubuntu)
High
Andrea Cimitan
Quantal
High
Andrea Cimitan

Bug Description

Ubuntu Desktop 20120619

TEST CASE:
1. On Quantal, install the package gtk-3-examples
$ sudo apt-get install gtk-3-examples
2. Launch 'gtk3-demo'
3. In the list double-click on 'Combo Box'
4. Try to change the value in the combo boxed 'Some stock icons' or 'Where are we'

ACTUAL RESULT:
The user cannot change the selection

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.11.5
ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
Uname: Linux 3.4.0-5-generic x86_64
ApportVersion: 2.2.3-0ubuntu4
Architecture: amd64
CasperVersion: 1.317
Date: Wed Jun 20 10:31:42 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120619)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
tags: added: testcase
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
tags: added: rls-q-incoming
Changed in ubiquity (Ubuntu Quantal):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
jerrylamos (jerrylamos) wrote :

Kinda strange, the refusal of the change selection bar to work is similar to the refusal to set up wireless WPA on the startup .iso disk. The wireless security bar doesn't allow wireless security to set WPA or anything else.

Dimitri John Ledkov (xnox) wrote :

The stanger thing, is that I experienced the same on quantal when trying to change a dropdown select list in landscapce client. The widget flickered and didn't let me change the value.

Changing the value using a down arrow key on my keyboard worked.

Maybe it's a gtk+ bug?

Changed in gtk+3.0 (Ubuntu Quantal):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
summary: - Cannot select partition type in advanced partitioner
+ Cannot select gtk dropdown list value in multiple applications:
+ ubiquity, landscape client
jerrylamos (jerrylamos) wrote :

Arrow keys, mouse selection, tab, space bar, alt, ctrl, nothing I tried worked. The menu bar would wiggle and that's it. On two pc's so far. This is a third pc but I've chewed up enough time on that today.

Jerry

Sebastien Bacher (seb128) wrote :

@Dmitrijs: if that's a gtk bug a testcase smaller than having to run ubiquity and do partitioning would be welcome ;-)

Jean-Baptiste Lallement (jibel) wrote :

I confirm it is not a bug in ubiquity and can be reproduced with plain gtk3 app.

Changed in ubiquity (Ubuntu Quantal):
status: Confirmed → Invalid
description: updated
Changed in gtk+3.0 (Ubuntu Quantal):
importance: Undecided → High
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Ok, the issue doesn't happen with the GNOME theme (Adwaita), it seems to be another issue between the unico theme engine (light-themes) and the new GTK... Cimi could you have a look?

Changed in gtk3-engines-unico (Ubuntu Quantal):
importance: Undecided → High
status: New → Confirmed
Changed in gtk+3.0 (Ubuntu Quantal):
status: Confirmed → Invalid
Changed in gtk3-engines-unico (Ubuntu Quantal):
assignee: nobody → Andrea Cimitan (cimi)
milestone: none → quantal-alpha-2
jerrylamos (jerrylamos) wrote :

The Quantal Quetzal forum is asking for tests of the daily build in preparation for Alpha 2. Anyone have any way to get around the missing "Change" drop down menu in order to set filesystem, format, root partition? This is on 21 June daily i386.iso. Haven't been successful on amd64.iso all week either.

Jerry

Sebastien Bacher (seb128) wrote :

light-themes (0.1.11-0ubuntu1) quantal; urgency=low

  * New upstream snapshot
    - work around GtkComboBox bug triggered by transition in the theme
      CSS (LP: #1015497)

Changed in gtk+3.0 (Ubuntu Quantal):
status: Invalid → Triaged
affects: gtk3-engines-unico (Ubuntu Quantal) → light-themes (Ubuntu Quantal)
Changed in light-themes (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
jerrylamos (jerrylamos) wrote :

22 June daily build, installed, can't even select Appearance > Pictures. Drop down menu function does not work.

Only way I was able to get installed was to

gsettings set org.gnome.desktop.interface gtk-theme Adwaita

because "Change" selection in Something Else refuses to do anything but quiver.

What is so screwed up about drop down menus in default gsettings?

Please do not change Adwalta. It works. Hard to read screen, but it works. Have to mouse over some selections to read them, but it works.

Cannot set up wireless security WPA because drop down menu refuses to work.

Appreciate any help or workarounds that anyone suggests.

Thanks, Jerry

Bowmore (bowmore) wrote :

light-themes ver 0.1.11-0ubuntu1 seems to have solved this issue.
Furthermore the high cpu-load (side effect?) for a running evolution is gone.

Dimitri John Ledkov (xnox) wrote :

@jerrylamos please see the linked bug in the gtk upstream. gtk has made some changes preventing themes to do things the old way that previously was possible.

Sebastien Bacher (seb128) wrote :

Note that we uploaded a theme update to not used the effects triggering the bug so the issue should be resolved already in quantal

jerrylamos (jerrylamos) wrote :

Dmitrijs and Sebastian, just did an update to the 22 June Daily Build installed and dropdowns worked.

As a test, I booted USB 22 June "Try Ubuntu" live, drop downs didn't work, so did an apt-get update and apt-get install on the live ubuntu just a few changes, and

drop downs now working.

Thanks much for your attention to this bug. I wonder if upstream has as many testers as ubuntu....

let me try a amd64.iso zsync and install on my wide screen notebook. Here's hoping.

Thanks again, Jerry

jerrylamos (jerrylamos) wrote :

amd64 22 June installed "something else" and running fine for an Alpha. Same thing, live drop downs wouldn't, update & upgrade then they would.

The install same thing, drop downs wouldn't, update & upgrade and they would. I can set Display resolution, select wallpaper from Pictures folder, set wireless WPA security, everything I've tried that wouldn't work before.

Kudo's! From my testing working fine. Alpha 2's coming...

Thanks much, Jerry

jerrylamos (jerrylamos) wrote :

23 June daily build drop down lists worked as they were supposed to both on the live and the install.

Thanks, Jerry

Changed in gtk+3.0 (Ubuntu Quantal):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
tags: removed: rls-q-incoming
Didier Roche (didrocks) wrote :

This is now fixed and working.

Changed in gtk+3.0 (Ubuntu Quantal):
status: Triaged → Fix Released
Mėnulis (menulio-svytuokle) wrote :

> This is now fixed and working.

False. It is not fixed and not working. Change the theme to another else and voila - bug appears again.

GTK3/GTK2 dropdown menu is flickering and can not be selectable.

Dimitri John Ledkov (xnox) wrote :

@menulio-svytuokle
each theme needs to be fixed individually, please open a new bug against broken theme. It is known that Adwaita, Radiance and Ambience themes are fixed. Other themes, might not be.

Adolfo Jayme (fitojb) on 2015-01-24
no longer affects: ubiquity (Ubuntu)
no longer affects: ubiquity (Ubuntu Quantal)
Changed in gtk:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.