wrong icon for the power indicator after last 12.04 update

Bug #1001229 reported by mlaverdiere on 2012-05-18
116
This bug affects 21 people
Affects Status Importance Assigned to Milestone
indicator-power
Invalid
Medium
Charles Kerr
gtk+3.0 (Ubuntu)
Low
Unassigned
Precise
High
Unassigned
Quantal
Low
Unassigned
ubuntu-mono (Ubuntu)
High
Lars Karlitski
Precise
Low
Unassigned
Quantal
High
Lars Karlitski

Bug Description

I'm on 12.04. Power-indicator icon in the upper/menu bar was fine until yesterday's update. Now, the icon (when battery is fully charged & AC connected) doesn't match the regular Ubuntu/unity/Ayatana indicators icon style (like if it was the gnome-shell style used instead). I'll try to put a screenshot later, if needed (I'm not on an Ubuntu machine right now).

Ken VanDine (ken-vandine) wrote :

Reassigning to gtk+3.0, this was introduced with gtk 3.4.2 which included a change for finding symbolic icons.

http://git.gnome.org/browse/gtk+/commit/gtk/gtkicontheme.c?id=271adacfadfdd81b27fb12356fe20cde3094de37

I have reproduced this with 3.4.2-0ubuntu0.1 in precise-proposed and 3.4.2-0ubuntu1 in quantal

affects: indicator-power (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in gtk+3.0 (Ubuntu Precise):
importance: Undecided → High
Changed in gtk+3.0 (Ubuntu):
importance: Medium → Low
Changed in gtk+3.0 (Ubuntu Precise):
status: New → Confirmed

I confirm this on my Samsung N310 with 12.04 up to date. Here is a screenshot.

summary: - wrong icon after last 12.04 update
+ wrong icon for the power indicator after last 12.04 update
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.4.2-0ubuntu2

---------------
gtk+3.0 (3.4.2-0ubuntu2) quantal; urgency=low

  * debian/patches/101_revert_symbolic_icon_search.patch
    - Revert symbolic icon search changes from 3.4.2 (LP: #1001229)
 -- Ken VanDine <email address hidden> Fri, 18 May 2012 10:01:55 -0400

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Released
Ken VanDine (ken-vandine) wrote :

Added an indicator-power task to make sure we aren't doing something wrong with the symbolic icons.

Changed in indicator-power:
assignee: nobody → Lars Uebernickel (larsu)
Lars Karlitski (larsu) on 2012-05-18
Changed in indicator-power:
assignee: Lars Uebernickel (larsu) → Charles Kerr (charlesk)
status: New → Confirmed
importance: Undecided → Medium
Lars Karlitski (larsu) wrote :

These icon names are coming from upower for a discharging battery:

  battery-full-symbolic gpm-battery-100 battery-full

Gtk looks for the first icon name in the current theme. If it doesn't find it, it proceeds to the next icon in the list, etc. Since ubuntu-mono doesn't have battery-full-symbolic, it advanced to gpm-battery-100, which it does have. If none of the icons in the list are found in the current theme, gtk proceeds to look for them in the parent icon theme.

The linked commit changes gtk to treat the -symbolic suffix a little differently, because it really isn't about specificity, but a visual property of the icon. So it looks for those in the parent theme *first*. Parent theme for ubuntu-mono seems to be the default gnome set, which contains a colorful rendition of battery-full-symbolic.

The real fix for this is to agree upon a naming scheme for symbolic icons. I suggest for ubuntu-mono to simply drop the old names and adapt the -symbolic ones.

In addition, indicator-power needs to look for the -symbolic icons first. I assume that it can even drop all the other names, as noone else is using them afaik.

Changed in gtk+3.0 (Ubuntu Precise):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gtk+3.0 (Ubuntu Precise):
assignee: Ken VanDine (ken-vandine) → nobody
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-mono (Ubuntu Precise):
status: New → Confirmed
Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed

Hello mlaverdiere, or anyone else affected,

Accepted gtk+3.0 into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gtk+3.0 (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

Ken, thanks for uploaded a fixed version! I'm not sure we should revert that patch in q though, why not fixing the indicators there?

Changed in ubuntu-mono (Ubuntu):
assignee: nobody → Andrea Cimitan (cimi)
Haw Loeung (hloeung) wrote :

Hi Martin Pitt,

Updated the following packages and it seemed to have fixed it:

Upgrade: gir1.2-gtk-3.0:amd64 (3.4.2-0ubuntu0.1, 3.4.2-0ubuntu0.2), libgtk-3-bin:amd64 (3.4.2-0ubuntu0.1, 3.4.2-0ubuntu0.2), libgtk-3-0:amd64 (3.4.2-0ubuntu0.1, 3.4.2-0ubuntu0.2), libgail-3-0:amd64 (3.4.2-0ubuntu0.1, 3.4.2-0ubuntu0.2), libgtk-3-common:amd64 (3.4.2-0ubuntu0.1, 3.4.2-0ubuntu0.2)

Thanks,

Haw

tags: added: verification-done
removed: verification-needed
Dario Zanotto (d.zanotto) wrote :

Hello all,
After updating the folowing packages, it seemed to be fixed:

gir1.2-gtk-3.0:amd64 (3.4.2-0ubuntu0.1, 3.4.2-0ubuntu0.2)
libgtk-3-bin:amd64 (3.4.2-0ubuntu0.1, 3.4.2-0ubuntu0.2)
libgtk-3-0:amd64 (3.4.2-0ubuntu0.1, 3.4.2-0ubuntu0.2)
libgail-3-0:amd64 (3.4.2-0ubuntu0.1, 3.4.2-0ubuntu0.2)
libgtk-3-common:amd64 (3.4.2-0ubuntu0.1, 3.4.2-0ubuntu0.2)

Thank you,
Dario

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.4.2-0ubuntu0.2

---------------
gtk+3.0 (3.4.2-0ubuntu0.2) precise-proposed; urgency=low

  * debian/patches/101_revert_symbolic_icon_search.patch
    - Revert symbolic icon search changes from 3.4.2, it breaks the icon
      displayed in indicator-power because of the order the icons are searched
      in. It looks like ubuntu-mono should drop the old icon names and
      use the new -symbolic icons. We need to carry this patch until
      ubuntu-mono fixes it's handling of symbolic icons. (LP: #1001229)

gtk+3.0 (3.4.2-0ubuntu0.1) precise-proposed; urgency=low

  * New upstream version
    - Evince 3.4: adding new annotation is not possible (lp: #984878)
    - "Delete confirmation" dialog has wrong padding (lp: #981375)
  * git patches backported
  * git_touchpad_no_leave_event.patch:
    - "gdk: do not send leave event on touchpad button release"
  * git_filechooser_wm_role.patch:
    - "Set the wm_role on GtkFileChooserDialog"
  * git_set_orientation.patch:
    - "box: set orientation style classes when setting orientation"
  * git_dnd_lock.patch:
    - "GDK X11 DND: Fix infinite loop" (lp: #880962)

  [ Jeremy Bicha ]
  * settings.ini:
    Set gnome-panel menu-bar icon size to 24 so that Ubuntu logo
    for the Applications menu isn't set too small (LP: #986969)
 -- Ken VanDine <email address hidden> Fri, 18 May 2012 13:38:04 -0400

Changed in gtk+3.0 (Ubuntu Precise):
status: Fix Committed → Fix Released

Fixed here too. Cheers!

Tim Lunn (darkxst) wrote :

The removal of this upstream patch will break symbolic icons in the latest gnome-shell (3.6 beta) once it gets uploaded to Quantal.

Tim Lunn (darkxst) wrote :

The correct fix for this issue is for ubuntu mono to provide battery icons with a -symbolic postfix. You can then included the upstream patch with out any issues! And really that patch is absolutely required for gnome-shell 3.6.

Sebastien Bacher (seb128) wrote :

Right, we should drop that revert hack, I've done that in the Vcs and it will be in quantal with the next upload, we are looking at fixing the icon theme as well

Changed in ubuntu-mono (Ubuntu):
importance: Undecided → High
Changed in ubuntu-mono (Ubuntu Precise):
importance: Undecided → Low
Lars Karlitski (larsu) on 2012-09-05
Changed in ubuntu-mono (Ubuntu Quantal):
assignee: Andrea Cimitan (cimi) → Lars Uebernickel (larsu)
Charles Kerr (charlesk) wrote :

These are the -symbolic icons referenced by i-power.

 "ac-adapter-symbolic"
 "gpm-monitor-symbolic"
 "battery-empty-symbolic"
 "battery-full-charged-symbolic" (and if not found, we also try"battery-full-charging-symbolic" as a fallback)
 "battery-caution-charging-symbolic"
 "battery-full-symbolic"
 "battery-good-symbolic"
 "battery-low-symbolic"
 "battery-good-symbolic"
 "battery-caution-symbolic"
 "battery-missing-symbolic"

John Swing (john-swing) wrote :

I'm in Quantal and i've got the same weird battery indicator since the last update.

Lars Karlitski (larsu) on 2012-09-20
Changed in indicator-power:
status: Confirmed → Invalid
Charles Kerr (charlesk) wrote :

This doesn't appear to need any code-level changes, so I'm closing the i-power component of this ticket.

Lars Karlitski (larsu) on 2012-09-20
Changed in ubuntu-mono (Ubuntu Quantal):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers