Ubuntu

Xorg uses lots of CPU when a Gtk2 widget has a background image

Reported by Christian Jodar on 2011-11-11
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
High
Unassigned

Bug Description

This problem was first reported against GCstar, but it's not specific to that application.

Since they upgraded to Ubuntu 11.10, many users reported that the application is really slow. After some investigations, it appeared that the problem occurs when the application uses a background image. It was only reported for Ubuntu and doesn't seem to affect other distributions.

I managed to create a small script that shows this problem. Its only dependency is libgtk2-perl. After it's started, Xorg is using a lots of CPU and the whole system is less responsive. This script is attached to this report.

Related branches

Christian Jodar (tian) wrote :
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
Perberos (perberos) wrote :

thanks for the script perl, it help me to understand the bug. I was hunting this bug for weeks.
I made a patch reverting the path 010_make_bg_changes_queue_repaint.patch,
it also fix the murrine high cpu usage.

greetings

Sebastien Bacher (seb128) wrote :

Ken, Cimi, that's an issue due to the overlay scrollbar which was added back in Oneiric (the one that upstream reverted because it created issues for some xfce applets and they didn't want to debug it), could you look at the issue?

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → High
assignee: nobody → Ken VanDine (ken-vandine)
Ken VanDine (ken-vandine) wrote :

Cimi, can you look at this again? It is nice to have a test case now, but the attached patch would reintroduce the bug you were trying to fix.

Changed in gtk+2.0 (Ubuntu):
assignee: Ken VanDine (ken-vandine) → Andrea Cimitan (cimi)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.24.8-0ubuntu1

---------------
gtk+2.0 (2.24.8-0ubuntu1) precise; urgency=low

  * New upstream release
    - gtkfilechooser should be more robust to malformed URIs
      in .gtk-bookmarks (LP: #189494)
  * debian/patches/010_make_bg_changes_queue_repaint.patch
    - dropped it introduces performance regressions in some gtk2
      apps (LP: #889019)
  * 101_filechooser.patch, 000git_file_chooser.patch: dropped, upstream
 -- Ken VanDine <email address hidden> Thu, 01 Dec 2011 11:40:06 -0500

Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Fix Released
Changed in gtk+2.0 (Ubuntu):
assignee: Andrea Cimitan (cimi) → nobody
darkween (darkween) wrote :

I frequently used GCstar, this bug could not use it more.
I just update to version gtk +2.0 gtk + -2.24.8. (With all depending: atk-2.2.0; cairo-1.10.2; gdk-pixbuf-2.21.7; pango-1.29.4)
But... This program still fails to work.
Before the update, opening GCstar consumed all the memory of the computer. Today, after the update, this does not happen, but GCstar not work.
Any solution?

Sorry for my bad English. And thanks for help!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers