package indicator-weather 11.05.31-0ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 127

Bug #810747 reported by Roland Dreier on 2011-07-14
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
High
Unassigned

Bug Description

Problem seems to be:
/var/lib/dpkg/info/indicator-weather.postinst: 42: gtk-update-icon-cache: not found
dpkg: error processing indicator-weather (--configure):
 subprocess installed post-installation script returned error exit status 127

The reason for the failure: /usr/bin/gtk-update-icon-cache symlink is not installed in the amd64 package, only in the i386 package.

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: indicator-weather 11.05.31-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic x86_64
AptOrdering:
 python-pywapi: Install
 indicator-weather: Install
 python-pywapi: Configure
 indicator-weather: Configure
Architecture: amd64
Date: Thu Jul 14 14:15:50 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 127
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101206)
PackageArchitecture: all
SourcePackage: indicator-weather
Title: package indicator-weather 11.05.31-0ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 127
UpgradeStatus: Upgraded to oneiric on 2011-07-09 (5 days ago)

Related branches

Roland Dreier (roland.dreier) wrote :
Changed in indicator-weather (Ubuntu):
assignee: nobody → Massimo Forti (maxforti)
Massimo Forti (slackwarelife) wrote :

Hi, have you try to do:

sudo apt-get update
sudo apt-get upgrade

after the error above you have posted? It seems the pkg have some problems to how it was done. Many thanks.

Changed in indicator-weather (Ubuntu):
assignee: Massimo Forti (maxforti) → nobody
Changed in indicator-weather (Ubuntu):
status: New → Incomplete
Andreas Moog (ampelbein) wrote :

Actually, this is a bug in gtk+2.0, which doesn't ship the /usr/bin/gtk-update-icon-cache symlink on architectures other than i386:

andreas@anubis:~/development/ubuntu$ dpkg-deb -c libgtk2.0-bin_2.24.5-0ubuntu4_amd64.deb
drwxr-xr-x root/root 0 2011-07-19 16:12 ./
drwxr-xr-x root/root 0 2011-07-19 16:12 ./usr/
drwxr-xr-x root/root 0 2011-07-19 16:12 ./usr/share/
drwxr-xr-x root/root 0 2011-07-19 16:12 ./usr/share/doc/
drwxr-xr-x root/root 0 2011-07-19 16:13 ./usr/share/doc/libgtk2.0-bin/
-rw-r--r-- root/root 12293 2011-07-19 15:59 ./usr/share/doc/libgtk2.0-bin/copyright
drwxr-xr-x root/root 0 2011-07-19 16:12 ./usr/share/man/
drwxr-xr-x root/root 0 2011-07-19 16:12 ./usr/share/man/man8/
-rw-r--r-- root/root 403 2011-07-19 16:12 ./usr/share/man/man8/update-icon-caches.8.gz
drwxr-xr-x root/root 0 2011-07-19 16:12 ./usr/share/man/man7/
-rw-r--r-- root/root 1148 2011-07-19 16:12 ./usr/share/man/man7/gtk-options.7.gz
lrwxrwxrwx root/root 0 2011-07-19 16:13 ./usr/share/doc/libgtk2.0-bin/changelog.Debian.gz -> ../libgtk2.0-0/changelog.Debian.gz
andreas@anubis:~/development/ubuntu$ dpkg-deb -c libgtk2.0-bin_2.24.5-0ubuntu4_i386.deb
drwxr-xr-x root/root 0 2011-07-19 16:15 ./
drwxr-xr-x root/root 0 2011-07-19 16:14 ./usr/
drwxr-xr-x root/root 0 2011-07-19 16:14 ./usr/bin/
drwxr-xr-x root/root 0 2011-07-19 16:14 ./usr/share/
drwxr-xr-x root/root 0 2011-07-19 16:14 ./usr/share/doc/
drwxr-xr-x root/root 0 2011-07-19 16:15 ./usr/share/doc/libgtk2.0-bin/
-rw-r--r-- root/root 12293 2011-07-19 15:59 ./usr/share/doc/libgtk2.0-bin/copyright
drwxr-xr-x root/root 0 2011-07-19 16:14 ./usr/share/man/
drwxr-xr-x root/root 0 2011-07-19 16:15 ./usr/share/man/man7/
-rw-r--r-- root/root 1148 2011-07-19 16:14 ./usr/share/man/man7/gtk-options.7.gz
drwxr-xr-x root/root 0 2011-07-19 16:15 ./usr/share/man/man1/
-rw-r--r-- root/root 799 2011-07-19 16:14 ./usr/share/man/man1/gtk-query-immodules-2.0.1.gz
-rw-r--r-- root/root 1211 2011-07-19 16:14 ./usr/share/man/man1/gtk-update-icon-cache.1.gz
drwxr-xr-x root/root 0 2011-07-19 16:15 ./usr/share/man/man8/
-rw-r--r-- root/root 403 2011-07-19 16:14 ./usr/share/man/man8/update-icon-caches.8.gz
drwxr-xr-x root/root 0 2011-07-19 16:14 ./usr/sbin/
-rwxr-xr-x root/root 596 2011-07-19 15:59 ./usr/sbin/update-icon-caches
lrwxrwxrwx root/root 0 2011-07-19 16:14 ./usr/bin/gtk-query-immodules-2.0 -> ../lib/i386-linux-gnu/libgtk2.0-0/gtk-query-immodules-2.0
lrwxrwxrwx root/root 0 2011-07-19 16:14 ./usr/bin/gtk-update-icon-cache -> ../lib/i386-linux-gnu/libgtk2.0-0/gtk-update-icon-cache
lrwxrwxrwx root/root 0 2011-07-19 16:14 ./usr/share/doc/libgtk2.0-bin/README.gz -> ../libgtk2.0-common/README.gz
lrwxrwxrwx root/root 0 2011-07-19 16:14 ./usr/share/doc/libgtk2.0-bin/NEWS.gz -> ../libgtk2.0-common/NEWS.gz
lrwxrwxrwx root/root 0 2011-07-19 16:15 ./usr/share/doc/libgtk2.0-bin/changelog.Debian.gz -> ../libgtk2.0-0/changelog.Debian.gz

affects: indicator-weather (Ubuntu) → gtk+2.0 (Ubuntu)
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → High
status: Incomplete → Triaged
description: updated

Thanks Andreas! I've been struggling to reproduce this. Of course it is because I'm on i386

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.24.5-0ubuntu5

---------------
gtk+2.0 (2.24.5-0ubuntu5) oneiric; urgency=low

  * debian/rules: ensure libgtk2.0-bin is also taken into account as an arch:any
    package now. (LP: #810747)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 19 Jul 2011 16:15:49 -0400

Changed in gtk+2.0 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers