Ubuntu

broken fallback icons in standard notification-area

Reported by Mathieu Trudel-Lapierre on 2011-03-31
160
This bug affects 34 people
Affects Status Importance Assigned to Milestone
libappindicator
High
Ted Gould
unity-2d
Undecided
Unassigned
gtk+2.0 (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Seems like fallback icons for any application using libappindicator when the indicator widgets are not loaded (and indicator-application-service is not running) show the standard no-icon-available icon fallback for their applet representation in the notification area.

Judging from my testing, this is because while libappindicator expects to use the "-panel" suffix as fallback for icons appearing in the notification area, most of the applications patched to support indicators do not provide such an icon (and it's also not provided by any theme).

The latest testing I've done was made with the GNOME icon set (turning up icons from the hicolor set AFAICT), but this also affects ubuntu-mono and Humanity; see the attached screenshot.

I think expecting the -panel suffix fallback for icons should be removed, and any applications actually using and expecting this to work should be fixed, to either drop the use of that suffix and ship icons without it in their name, or drop the duplicated icons with a "-panel" suffix. An especially critical case of this is when applications or themes ship both the -panel suffixed version of the icon and the version without in two separate identical files rather than using symlinks.

Applications confirmed to be affected:
 - nm-applet
 - gnome-bluetooth
 - ibus-daemon
 - gtg
 - tomboy

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libappindicator1 0.3.0-0ubuntu1
Uname: Linux 2.6.38-020638rc8-generic x86_64
Architecture: amd64
Date: Thu Mar 31 11:07:48 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=fr_CA:fr:en_CA:en
 PATH=(custom, user)
 LANG=fr_CA.UTF-8
 SHELL=/bin/zsh
SourcePackage: libappindicator
UpgradeStatus: Upgraded to natty on 2011-03-07 (24 days ago)

Also affects the accessibility icon in GDM.

Martin-Éric Racine (q-funk) wrote :

Here, the icons that are broken are:
keyboard-applet, bluetooth-applet, nm-applet, gnome-power-manager-applet, GDM's accessibility icon.

Ted Gould (ted) on 2011-03-31
Changed in libappindicator:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Ted Gould (ted)

Setting the bug against the ubuntu package to Confirmed/High just to be in sync with the upstream report.

Changed in libappindicator (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Pavlo Bohmat (bohm) wrote :

Lock version: OK
libappindicator1_0.2.99-0ubuntu1_amd64.deb
python-appindicator_0.2.99-0ubuntu1_amd64.deb

libappindicator1_0.3.0: FAIL

Ted Gould (ted) wrote :

Fixes the GTK use-fallback patch to save the value when it gets set so that libappindicate fallbacks work.

affects: libappindicator (Ubuntu) → gtk+2.0 (Ubuntu)
Changed in libappindicator:
status: Confirmed → Invalid

I was able to rebuild the package locally here and confirm this works...

Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Fix Committed
tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.24.4-0ubuntu2

---------------
gtk+2.0 (2.24.4-0ubuntu2) natty; urgency=low

  * debian/patches/093_gtk3_gtkimage_fallbacks_use.patch: Make sure to
    save the value of use_fallback when it's changed. (LP: #746495)
 -- Ted Gould <email address hidden> Wed, 13 Apr 2011 12:14:57 -0500

Changed in gtk+2.0 (Ubuntu Natty):
status: Fix Committed → Fix Released

I have moved back to Ubuntu 10.10 but thanks anyway :)

Regards,

Arun

<http://pickamovie.tk>http://pickamovie.tk

On Thu, Apr 14, 2011 at 22:36, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package gtk+2.0 - 2.24.4-0ubuntu2
>
> ---------------
> gtk+2.0 (2.24.4-0ubuntu2) natty; urgency=low
>
> * debian/patches/093_gtk3_gtkimage_fallbacks_use.patch: Make sure to
> save the value of use_fallback when it's changed. (LP: #746495)
> -- Ted Gould <email address hidden> Wed, 13 Apr 2011 12:14:57 -0500
>
> ** Changed in: gtk+2.0 (Ubuntu Natty)
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (751012).
> https://bugs.launchpad.net/bugs/746495
>
> Title:
> broken fallback icons in standard notification-area
>
> Status in Libappindicator:
> Invalid
> Status in “gtk+2.0” package in Ubuntu:
> Fix Released
> Status in “gtk+2.0” source package in Natty:
> Fix Released
>
> Bug description:
> Seems like fallback icons for any application using libappindicator
> when the indicator widgets are not loaded (and indicator-application-
> service is not running) show the standard no-icon-available icon
> fallback for their applet representation in the notification area.
>
> Judging from my testing, this is because while libappindicator expects
> to use the "-panel" suffix as fallback for icons appearing in the
> notification area, most of the applications patched to support
> indicators do not provide such an icon (and it's also not provided by
> any theme).
>
> The latest testing I've done was made with the GNOME icon set (turning
> up icons from the hicolor set AFAICT), but this also affects ubuntu-
> mono and Humanity; see the attached screenshot.
>
> I think expecting the -panel suffix fallback for icons should be
> removed, and any applications actually using and expecting this to
> work should be fixed, to either drop the use of that suffix and ship
> icons without it in their name, or drop the duplicated icons with a
> "-panel" suffix. An especially critical case of this is when
> applications or themes ship both the -panel suffixed version of the
> icon and the version without in two separate identical files rather
> than using symlinks.
>
> Applications confirmed to be affected:
> - nm-applet
> - gnome-bluetooth
> - ibus-daemon
> - gtg
> - tomboy
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: libappindicator1 0.3.0-0ubuntu1
> Uname: Linux 2.6.38-020638rc8-generic x86_64
> Architecture: amd64
> Date: Thu Mar 31 11:07:48 2011
> EcryptfsInUse: Yes
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
> (20101007)
> ProcEnviron:
> LANGUAGE=fr_CA:fr:en_CA:en
> PATH=(custom, user)
> LANG=fr_CA.UTF-8
> SHELL=/bin/zsh
> SourcePackage: libappindicator
> UpgradeStatus: Upgraded to natty on 2011-03-07 (24 days ago)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/libappindicator/+bug/746495/+subscribe
>

Pavlo Bohmat (bohm) wrote :

Ubuntu ~11.10
libappindicator1_0.3.0-0ubuntu1: FAIL
libappindicator3-1_0.3.0-0ubuntu1_amd64.deb: FAIL
network-manager_0.8.9997-1ubuntu2

nm-applet again no tray icons fluxbox

Marcin Juszkiewicz (hrw) wrote :

Reopening for oneiric - in XFCE session Bluetooth and NetworkManager lacks icons.

Changed in gtk+2.0 (Ubuntu):
status: Fix Released → Confirmed
Marcin Juszkiewicz (hrw) wrote :
tags: added: patch
igi (igor-cali) wrote :

Added unity-2d; it affects pidgin.

Well, I see the same in Xubuntu here, but this doesn't belong as a bug against unity-2d, something else down the path breaks the icons.

Marcin, can you please open a separate bug for this? It's a new issue, even if it was to be the same kind of problem: it's now a problem in Oneiric, and will need to be investigated separately. We'll also need to have the .xsession-errors from the session showing this so we can see into it.

For now, closing this bug back as Fix Released. I'll open a new one for this bug in xubuntu as soon as I can reproduce it and comment with the bug number (or if you do before I can get to it, we'll use your bug).

Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-2d:
status: New → Invalid

I opened bug 820080 about this for oneiric. Please refer to that if you get broken icons outside Unity on *Oneiric*.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers