nautilus puts a menu bar at the top of the desktop

Bug #717358 reported by Kees Cook on 2011-02-11
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Invalid
Undecided
Unassigned
gtk+2.0 (Ubuntu)
Low
Andrea Cimitan
Natty
Low
Andrea Cimitan

Bug Description

Binary package hint: nautilus

I run the Ubuntu Classic Desktop without a top panel. After upgrading yesterday, nautilus puts a menu bar across the top of my desktop. This should not be here.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: nautilus 1:2.32.2.1-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic x86_64
Architecture: amd64
Date: Fri Feb 11 11:19:27 2011
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: nautilus
usr_lib_nautilus: nautilus 1:2.32.2.1-0ubuntu5file-roller 2.32.1-0ubuntu2evince 2.32.0-0ubuntu9ubuntuone-client-gnome 1.5.3-0ubuntu3gnome-disk-utility 2.32.1-0ubuntu3nautilus-share 0.7.2-14ubuntu1nautilus-actions 3.0.5-1nautilus-sendto 2.32.0-0ubuntu1ubuntuone-client-gnome 1.5.3-0ubuntu3totem 2.32.0-0ubuntu8brasero 2.32.1-0ubuntu1nautilus-actions 3.0.5-1ubuntuone-client-gnome 1.5.3-0ubuntu3

Related branches

Kees Cook (kees) wrote :
Kees Cook (kees) wrote :
tags: added: regression-release
Marc Deslauriers (mdeslaur) wrote :

I see this also, but it's drawing it _underneath_ my top gnome-panel.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that seems normal with the indicator-appmenu applet being in use no? what is the issue exactly? can't you just remove the applet from your config if you don't want to use it?

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Changed in nautilus (Ubuntu):
status: Incomplete → New
Kees Cook (kees) wrote :

The indicator-appmenu thing is not active in classic desktop afaict.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Nautilus didn't change recently, trying to reassigning to indicator-appmenu

affects: nautilus (Ubuntu) → indicator-appmenu (Ubuntu)
Changed in indicator-appmenu (Ubuntu):
status: Confirmed → New
Sebastien Bacher (seb128) wrote :

The issue only happens if there is no indicator-appmenu in the classic session for some reason, it seems to happen in the unity session as well (if you switch workspace you can see the bar during the animation, you can also see a one pixel line bellow the unity-panel)

Sebastien Bacher (seb128) wrote :

Could be due to the nautilus patch to export the nautilus panel though, Ted, do you have any clue?

Changed in indicator-appmenu (Ubuntu Natty):
assignee: nobody → Ted Gould (ted)
milestone: none → natty-alpha-3
Sebastien Bacher (seb128) wrote :

ignore my comment about the unity session, I run with APPMENU_DISPLAY_BOTH for testing which explains why it doesn't get stripped

Michael Bienia (geser) wrote :

gnome-terminal got now also a menubar by default (even if it is disabled in the config), see bug 717332.

Sebastien Bacher (seb128) wrote :

bug #705112 indicates it's due to a recent gtk fix from the dx team, reassign the bug

affects: indicator-appmenu (Ubuntu Natty) → gtk+2.0 (Ubuntu Natty)
Changed in gtk+2.0 (Ubuntu Natty):
assignee: Ted Gould (ted) → Andrea Cimitan (cimi)
Changed in indicator-appmenu:
status: New → Invalid
Andrea Cimitan (cimi) wrote :

This could be a better patch, give me time to test it.
Basically I'm storing the presence (or not) of the menubar in its private structure, and on local-notify's signal callback I'm showing it only when it is meant to be shown

Andrea Cimitan (cimi) wrote :

patch still broken... investigating

Andrea Cimitan (cimi) wrote :

Please test it. I tested it and seems to work, but my head is blown away with other bugs to take care :) So if you have a chance, try it! otherwise, trust me!
I'm testing it right now... If I'll be silent, means that here works

tags: added: patch
Changed in gtk+2.0 (Ubuntu Natty):
status: New → Triaged
Santtu Lakkala (inz) wrote :

The updated patch doesn't fix cases which do _show() ... _hide() (where hide is called before local_notify). I wrote some findings in bug 705112, but in short the problem is that gtk_widget_hide() only calls GtkWidget::hide if the widget was visible.

Andrea Cimitan (cimi) wrote :

I don't have time to fix this before the feature freeze... could you (or someone) try to fix it? Basically we need to hide/show the menubar, but doing it right

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.24.0-0ubuntu3

---------------
gtk+2.0 (2.24.0-0ubuntu3) natty; urgency=low

  * debian/patches/043_ubuntu_menu_proxy.patch:
    - revert the previous upload since it's adding extra menubar when it
      should not, should fix the nautilus bar being displayed on configurations
      where appmenu is not in use
      (lp: #717358)
 -- Sebastien Bacher <email address hidden> Wed, 16 Feb 2011 19:05:38 +0100

Changed in gtk+2.0 (Ubuntu Natty):
status: Triaged → Fix Released
Santtu Lakkala (inz) wrote :

This rather obtrusive patch seems to fix the issue, not sure if it breaks something though; some applications may expect that ::show is not called multiple times without ::hide in between (or vice versa). This is the best/simplest solution I can think of right now.

Uploaded a package with this patch to my ppa if someone likes to test.

pvdeynse (vandeynse) wrote :

installed patch from your ppa and indeed menu bar is gone now.
small remark, one of the files on your ppa has extention ".udeb" it has to be ".deb"
  ==> libgtk2.0-0-udeb_2.24.0-0ubuntu3_i386.udeb

peddy (peddy22) wrote :

This is present again in Oneric. I'd be happy to post more information, but am unsure of what to include.

I see this in Oneiric too. Very annoying, can be worked around by disabling nautilus desktop with "gsettings set org.gnome.desktop.background show-desktop-icons false"

Mario Manno (manno) wrote :

Still a problem in Oneiric with the classic desktop. Just like gnome-terminal always showing a menu bar (860342).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers