GTK Printing Dialog: Duplex printing on HP inkjets does not work

Bug #657357 reported by Fred on 2010-10-09
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Common Print Dialog
Wishlist
Unassigned
gtk+2.0 (Ubuntu)
High
Unassigned
Maverick
Undecided
Unassigned
hplip (Ubuntu)
Undecided
Unassigned
Maverick
High
Unassigned
system-config-printer (Ubuntu)
Undecided
Unassigned
Maverick
High
Unassigned

Bug Description

Binary package hint: hplip

I am using a HP Photosmart Premium 309a with a duplex module in networked mode, under Maverick (fully updated)

After adding this printer through system-config-printer and telling it that I have a duplexer module installed, duplex printing doesn't work.

In evince for example, in the print dialog, in the "Page Setup" tab, I can only choose "One Sided" in the "Two-sided" options.

In Lucid, duplex printing was working out of the box...

Do not hesitate to ask me more information. Thanks in advance for your help.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: hplip 3.10.6-1ubuntu10
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
CupsErrorLog: E [09/Oct/2010:17:02:44 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
Date: Sat Oct 9 17:22:08 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
Lpstat: device for HP-Photosmart-C309a-series: hp:/net/Photosmart_C309a_series?ip=192.168.1.6
MachineType: Acer, inc. TravelMate 6292
Papersize: a4
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
PpdFiles: HP-Photosmart-C309a-series: HP Photosmart c309a Series, hpcups 3.10.6
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=/dev/sda2
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: hplip
dmi.bios.date: 03/03/2008
dmi.bios.vendor: Acer
dmi.bios.version: v1.3601
dmi.board.name: Victoria
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: Acer, Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrv1.3601:bd03/03/2008:svnAcer,inc.:pnTravelMate6292:pvrNotApplicable:rvnAcer,Inc.:rnVictoria:rvrNotApplicable:cvnAcer,Inc.:ct1:cvrN/A:
dmi.product.name: TravelMate 6292
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.

Fred (frederic-lespez) wrote :
Till Kamppeter (till-kamppeter) wrote :

Have you also chosen the "A4 Borderless" (or "Letter Borderless") page size?

Changed in hplip (Ubuntu):
status: New → Incomplete
Fred (frederic-lespez) wrote :

I tried with A4, A4 Borderless and A4 AutoDuplex. But every time I can only choose "One Sided" in the "Two-sided" options.
In lucid, there was 3 options One sided, Long Edge and Short Edge.

Note that in Maverick, these 3 options are still present in the printer properties as a system wide setting.

Martin Jensen (marjen) wrote :

I can confirm this bug. I have an HP OfficeJet 6500 with duplexer.

Till Kamppeter (till-kamppeter) wrote :

I have checked and the problem is in GTK's printing dialog:

To set duplex for an HP inkjet, two steps have to be performed, first the page size has to be set to "A4 Auto Duplex" and then the duplex option has to be set to "Long Edge". The page size setting "A4" conflicts with "Long Edge" (you see this very well if you try this out with system-config-printer). If you try this in GTK's printing dialog (like in evince) it does not work. By default (when the dialog is started) the page size is set to A4. This makes the dialog only listing "One-sided" under Duplex as "Long Edge" and "Short Edge" conflict with the "A4" page size. One could set the page size to "A4 Auto Duplex", but now we hit the bug: If one changes the setting of an option, the other options are not updated in terms of conflicts. So the "Long Edge" and "Short Edge" do not get added to the Duplex option.

Now one could think that if one sets all options with system-config-printer as default and after that one can print with these options from evince, it will also not work. It seems that evince does not take the default setting for the paper size from the printer/PPD file, as if one sets the page size to "A4 Auto Duplex" with system-config-printer, in the printing dialog appears "A4" as page size.

To reproduce, simply set up a print queue for a duplex-capable HP inkjet, like the PhotoSmart Premium C309a. Then try to print to this printer from evince.

This bug breaks important functionality and therefore I appreciate very much if it could be fixed also in Maverick, as an SRU.

affects: hplip (Ubuntu) → gtk+2.0 (Ubuntu)
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
summary: - HP Photosmart Premium C309a duplex printing doesn't work in Maverick
+ GTK Printing Dialog: Duplex printing on HP inkjets does not work

Printing from OpenOffice.org also results in single sided pages, regardless of any duplex options set

Leonidv (leonidv) wrote :

I also has this bug. My HP 1022 Laserjet support manual duplex mode, It's nice work in 10.04, but in 10.10 this options is disabled in Printing Dialogs.

Jerker Nordh (ajn) wrote :

I think I have the same bug, but for Samsung CLP-300N

PaterSigmund (b-schwilling) wrote :

HP Officejet Pro 8000: Duplex doesn't work.

Changed in gtk+2.0 (Ubuntu Maverick):
status: New → Invalid
Changed in hplip (Ubuntu):
status: New → Invalid
Changed in system-config-printer (Ubuntu):
status: New → Invalid
Changed in hplip (Ubuntu Maverick):
status: New → Triaged
Changed in system-config-printer (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → High
Changed in hplip (Ubuntu Maverick):
importance: Undecided → High

For Natty the bug should really get fixed, in GTK. For Maverick we should switch back to HPIJS (instead of hpcups) as default driver for HP's non-PostScript printers. Here the duplex option is simpler and works with all the applications which have all kinds of bugs in their printing dialogs. Added hplip and system-config-printer task for a Maverick SRU.

See also bug #428588.

Tim Waugh (twaugh) wrote :

I actually think it's an HPLIP bug: the PPD spec does say specifically that a given PageSize's ImageableArea should be the maximum area common across all options (5.15, Information About Media Sizes, "On some devices, ..."). See also bug #487695.

Tim Waugh (twaugh) wrote :

The exact wording is "In PPD files where the imageable area of a given page size can vary depending on other factors, the imageable area recorded for that page size will be the intersection of all possible imageable areas for that page size."

Prepared SRU for Maverick. The new HPLIP package installs hpijs and migrated hpcups-based print queues to hpijs. debdiff attached and package uploaded to the -proposed queue, waiting for approval.

Changed in hplip (Ubuntu Maverick):
status: Triaged → Fix Committed

Prepared SRU for Maverick. The new system-config-printer package prioritizes the hpijs driver against the hpcups driver when creating a new print queue. debdiff attached and package uploaded to the -proposed queue, waiting for approval.

Changed in system-config-printer (Ubuntu Maverick):
status: Triaged → Fix Committed

Accepted hplip into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted system-config-printer into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Confirmed that switching to HPIJS restores duplex printing from applications to my HP Photosmart Premium 309a on 10.10

The hplip package in -proposed has built now. Sorry for the delay, we had a problem with the package build.

Martin Jensen (marjen) wrote :

Thanks a lot for doing such a great job! After installing hplip/maverick-proposed duplex printing is now working perfectly. :-)

tags: added: cpd verification-done
removed: verification-needed
John Affleck (lists+launchpad) wrote :

I can also print duplex again after switching to hpijs

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.10.6-1ubuntu10.1

---------------
hplip (3.10.6-1ubuntu10.1) maverick-proposed; urgency=low

  * debian/hplip-cups.postinst, debian/hpijs.postinst: Switch back to HPIJS as
    default driver (migrate hpcups queues to HPIJS) as there are still problems
    with hpcups and duplex printing (LP: #428588, LP: #487695, LP: #657357).
  * debian/control: Let hplip depend on hpijs instead of on hplip-cups as
    printer driver.
 -- Till Kamppeter <email address hidden> Thu, 21 Oct 2010 14:35:03 +0200

Changed in hplip (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.2.3+20100723-0ubuntu8.1

---------------
system-config-printer (1.2.3+20100723-0ubuntu8.1) maverick-proposed; urgency=low

  * debian/patches/78_give-priority-to-hpijs.patch: Prioritize hpijs against
    hpcups again. With hpcups duplex printing does not work with most
    applications (LP: #428588, LP: #487695, LP: #657357).
 -- Till Kamppeter <email address hidden> Thu, 21 Oct 2010 14:58:06 +0200

Changed in system-config-printer (Ubuntu Maverick):
status: Fix Committed → Fix Released
Charles Curley (charlescurley) wrote :

OK, I am mystified. The versions indicated above are on my system via the usual apt-get upgrade process. Printer is an HP Office-Jet Pro 7780 via USB.

In printer setup, I have "Letter AutoDuplex 8.5x11 in" and "Long Edge (Standard)".

Evince shows only one option for duplex printing, "one sided".

OpenOffice.org, once you set the paper size to "Letter AutoDuplex 8.5x11 in", shows four options, "Off", "<ignore>", "Long Edge (Standard)", and "Short Edge (Flip)". Long Edge prints single sided. Ignore prints duplex.

jpka (jopka) wrote :

Hi!
1) I confirm #8, Samsung CLP-300N two-sided printing broken in Maverick, it was work well before.
2) There is no duplex unit for most laser printers; historically, instead of it, manual re-feeding of paper used when printer stops and flashes alarm light and wait for user button in middle of printing, as CLP-300N does. So i can't select some magic "duplex A4" paper or so; i can't find anything like it in any paper selection drop-down lists.
Thanks.

Charles, can you start system-config-printer, right-click your printer, choose Properties, click the Change button for make and model and in the selection for the driver choose the hpijs one? Then you should be able to choose duplex in all printing dialogs and your printout will come out double-sided.

jpka, note that there is only a Duplex option for your printer if you ude the SpliX driver. If needed, change to SpliX with system-config-printer.

jpka (jopka) wrote :

Hi Till, i try to follow your suggestion. I start 'system-config-printer' from commandline; well known printer setup GUI appears. I not find any 'driver' selector, but found 'Make and model -> Change' button, i use it, i hope it's right place. I also read your comment #1 for bug #378068, which says

  > ... Try also the SpliX driver. If it does not appear under the driver choices for your printer, try a similar printer model like the CLP-300 or CLP-310. ...

Sadly my CLP-300N (or CLP-300) not have splix associated. Nearest is CLP-500. I select it, it looks now 'Samsung CLP-500, SpliX V. 2.0.0', but printer instead of my document, print
'SPL-C error - Please use proper driver. .....'
I also read your

  > ... If these also do not list the SpliX driver, install the SpliX package from ...

But synaptic show me Splix already exist in my system.
Is there any instruction how to tie (associate) my CLP-300N with Splix? I not found anything via search. Thank you!

jpka, the SpliX driver from the OpenPrinting web site installs in parallel to any distribution's SpliX driver. It has a different package name ("openprinting-splix") and all files are at a different place (in /opt). So you can simply install the package and then your printer should get a SpliX choice in system-config-printer.

jpka (jopka) wrote :

Hi Till, thank you, two-sided printing now works well again. But any printing using SpliX works *only* when i set 600 dpi resolution. At 300 dpi, printer even not eat paper, but flashing 4 toner LEDs in very specific manner (it's a secret code? I can't decode this). At 1200 dpi, printouts is almost black, like 100 times printing random text on same sheet of paper. I can live well with 600 dpi; and i can give more info and help testing if it's a bug in SpliX. Thanks!

jpka, th problem with 300 dpi and 1200 dpi not working is a problem of the SpliX driver itself. Please report this problem on the upstream web site of SpliX: http://splix.sourceforge.net/.

jpka (jopka) wrote :

Still not fixed in Ubuntu 11.04 (at least for CLP-300 printer).
The solution is same: (may be helpful for new users)
1. system-config-printer
 set up your CLP-300 with default settings.
 make sure 600 dpi mode selected.
 close.
2. sudo gedit /etc/apt/sources.list
 add line
deb http://www.openprinting.org/download/printdriver/debian/ lsb3.2 main contrib main-nonfree
3. sudo apt-get update
4. sudo apt-get install openprinting-splix
5. system-config-printer
 Make and model -> Change
 select CLP-300 and you'll see two option at right pane, select SpliX.
Now duplex is work.

Lars, see comment #5 for the problem which we have to avoid in option conflict handling in the Common Print Dialog.

Changed in common-print-dialog-gtk:
importance: Undecided → Wishlist
Levy (michel-levy) wrote :

This bug affects libre-office. But it's possible to export a document to pdf and then to print it in recto-verso.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints