Ubuntu

Open file dialog malfunctions in lucid

Reported by Stephen on 2010-04-08
178
This bug affects 33 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+2.0 (Ubuntu)
Low
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: anjuta

The open file window in firefox or google chrome is selecting the wrong file. When I select the file I want to upload the correct filename appears in the location field. However when I click on the open tab the wrong file gets uploaded normally one that is a couple of places wither above or below the selected file in the directory listing. This seems to be fairly random. Somtimes the correct file gets uploaded, other times a file that is alphabetically close... I Hope this is understandable :)

Stephen (stephenfranciscogomez) wrote :

I believe the open file dialog is a part of gtk+2.0

affects: anjuta (Ubuntu) → gtk+2.0 (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Luke Plant (spookylukey) wrote :

I can reproduce this, it is a major bug, and IMO almost a security bug really - I very nearly uploaded a lot of personal information to a launchpad just now, attempting to upload a kernel log.

In Firefox or Google Chrome, when I attempt to upload a file, the behaviour is exactly as described - the file dialog behaves as if, behind the scenes, all the files listed are in a different order to the one seen.

So, if you double click a file, a different one ends up being selected (i.e. a different file appears on the file upload control on the web page). Or sometimes, you double click a file and it acts as if you double clicked a folder (i.e. it drills down into that folder). If you single click a file, the correct name appears at the top, but when you press 'Open' a different name appears on the web page.

If you need more information than this, please let me know.

Luke Plant (spookylukey) on 2010-05-01
Changed in gtk+2.0 (Ubuntu):
status: Incomplete → Confirmed

Confirmed on Ubuntu 10.04. Very annoying bug, and a bit ugly as one risks uploading sensitive files to the wrong place.

Arnau Alcázar (arnau) wrote :

I've got the same problem.

I can confirm this bug in Firefox and Chrome.
I have run Firefox in safe mode to be sure the problem is not related with any plugin.

Nuno José (nzalmeida) wrote :

Same problem and also with Pitivi

Nuno José (nzalmeida) wrote :

Screencast on firefox

http://nzalmeida.pedaserra.net/publico/out.ogv

You can see when I use keyb, the selected folder is going up by is own.

zetero (zetero) wrote :

Same bug here.

Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Jean-Peer Lorenz (peer.loz) wrote :

Has somebody already filed an upstream bug? If so, could he/she give a reference to it? Thanks.

Todd Morgan (tubatodd) wrote :

I am experiencing this very same bug. I can not properly upload anything to my department's Drupal website. Trying to select the proper file is next to impossible.

ketchers (richard-ketchersid) wrote :

I've been experiencing this for a while. It varies between having to select one or two files down from the one that I want attached. It does not always happen. I think it happens when files are added to the directory, almost as if gnome were keeping an old list in memory.

TimMadden (timmadden) wrote :

I have experience this as well. I have not done a controlled test yet, but it seems to be related to the number tabs opened in your browser. For instance, if I open a fresh chrome and attach something to be uploaded, it seems to work correctly, but if I use a chrome that was open already and has multiple tabs, then it seems to happen. Anyone else seeing this?

DrPotoroo (mcq-public) wrote :

I am having trouble with wrong files opening as well. For me I first noticed it in openoffice (writer and impress - when I try to insert files into documents), but I can confirm the same behaviour with file-open in firefox.

DrPotoroo (mcq-public) wrote :

Additional info: closing firefox (which had multiple tabs open) seemed like it fixed the problem in open office.

I have a similar problem in Evolution, and it might be the same bug.

I got an email with a number of attachment, clicked "Save all" and selected the folder in the bottom of the file chooser, and the folder gets highlighted. Clicking up arrow once keeps the selected line highlighted, but a new light-red highlighting bar starts traveling upwards slowly - very wierd :/

Pedro Villavicencio (pedro) wrote :

As Sebastien said this bug needs to be send upstream by someone facing it, please read his previous comment to know how to do it, thanks all.

Abhijit Navale (abhi-navale) wrote :

Hello.
I request to change the importance to critical since this may result in uploading sensible or private files.
Please consider my suggestion.

Abhijit Navale (abhi-navale) wrote :

In my case when I come her on launchpad to file a bug using firefox, then I need to upload debug.txt.
But it is not allowing me to click on that debug.txt which was in my /home/username. it keep opening another folder adn wrong file.
After that I shift my debug.txt from /home/username to /home/usernmae/Documents and then it worked, it selects the proper file.

Goury (madoo) wrote :

hey! wtf this bug is still low impotance?
it must be uber-major-critical!
ppl cant upload files they want!

Jean-Peer Lorenz (peer.loz) wrote :

@Goury: Please, watch your language. Comments like yours are not helpful at all. Do you see this issue? Can you list steps in order to reproduce this bug? Thanks.

Jon Packard (jonpackard) wrote :

I also recommend increasing the importance on this bug. I have been experiencing this problem for at least two months, on several computers running Ubuntu 10.04. At best, it's an inconvenience, having to try to pick the file correctly several times. At worst, it could lead to serious privacy concerns. Are there any knowledgeable people working on a fix for this? It's been over a month since there has been any activity on this bug.

Alan Moore (alanmoore78) wrote :

I am running a fresh install of Ubuntu 10.04 on my laptop, dual boot with 7HP64, and I have this same problem.

I didn't have this problem yesterday, but I have it today. Have not rebooted, have not changed anything. But I think I can outline the steps I took to produce this problem.

2 Chrome windows. One has 1 tab open (where I am submitting the file to a website using a Browse button). The other has 20 tabs open to different websites where I am saving pictures to my hard drive. I went to a tab, saved the picture I needed in /home/user_name/pictures/folder_name and then repeated this for each tab. I then went to the other window to submit one of the photos. When the file dialog window came up, there were 20 pictures to choose from so I sorted by name. I picked the one I wanted which was 7th down on the list. I clicked Open and the correct filename appeared next to the Browse button. After filling in the other form information (business name, address, etc) I submitted the form. The wrong file was uploaded. The file that was uploaded was 1st in the list, not 7th.

I tried what other users above have tried and it didn't change anything. That first file was the one uploaded.

So I tried using Firefox the same way. 20 tabs in one window, one tab in the other. It did the same thing. Uploaded whatever file had been saved last into that directory, which in this case was alphabetically first.

Here's the kicker. The website uses Ubuntu on their server as well with Apache 2.24 or something like that. So I went to the other end of my house and got on my wife's Windows computer. I opened the site with the picture I needed, opened another tab and went to the edit page for the form I submitted, and tried to change the picture, and it wouldn't change it. I have since booted into Windows on this computer and tried and it still won't work. I had to delete the form and start over to get it to go in right. Very annoying.

So now I'm having to do my work in the mornings in Windows and then I can boot into Ubuntu for the rest of the day.

I will try to reproduce this bug with smaller numbers of tabs because I can imagine how irritating it would be to open up 20 tabs just to reproduce a bug for debugging purposes. This is just my experience from early this morning.

Janto Dreijer (jantod) wrote :

Why does this bug have such a low importance? This is a serious issue. I submitted the wrong file to an academic conference today. If I didn't, out of curiosity, check what I sent them 5 minutes before the deadline...

Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
Changed in gtk:
status: New → Fix Released
steve.rueg (steve-rueg) wrote :

I am using Ubuntu Lucid 10.04 and also have this file dialog select problem. I see that the status is "Fix Released," but I don't understand what that means. I have been updating my Ubuntu Lucid distro. Doesn't that mean that I should have gotten this 'fix' and then I shouldn't have this problem? Or does "Fix Released" mean that the fix is only for Maverick? Or that this gtk+ fix is for Lucid, but just hasn't made it into the Ubuntu repositories yet?

Eithe way is there a way to manually install this 'fix?' It is an annoying bug and I would like to benefit from the fix.

Thanks.

Rene Bilodeau (rbil) wrote :

Where's this so-called fix?

mikef (mfarewell) wrote :

I have the same problem. I just updated to 10.04LTS from Karmic, when I want to upload a file to the web the wrong one is uploaded. The correct one appears in the file browser dialogue but the wrong one is actually selected on the web page. I can not believe that this is considered low importance. I would call the flaw critical to the functioning of any operating system, particularly an LTS one. I have used Ubuntu for the last 3 years and have never seen anything like this before, uploading files to the web is a critical operation, and should be treated seriously.

DrPotoroo (mcq-public) wrote :

I have experienced this bug 10.04 on my AMD64 desktop, but not on a couple of netbooks running 10.04. I thought it had stopped for a while, but today I'm having this problem in Firefox and OpenOffice file selection dialogues. For instance, if I use the "insert file" option in OpenOffice I simply CAN NOT select the right file. If I start typing the filename (which jumps the selection to a matching file) I can watch the correct file be selected, then the selection starts moving up one file at a time. If I stop typing and watch the selection just slowly drifts its way up through the directory. The only solution is to move the file I want into a directory that has nothing else in it.

Pausanias (pausanias) wrote :

Shame on you, Ubuntu, for leaving this bug unfixed nine months after it was (supposedly) fixed upstream. Is this supposed to be a rock-solid LTS operating system, where something as critical as the file open dialog doesn't even work properly? Leaving the importance "low" when there is the possibility of uploading the wrong file to a work-critical website? Are you kidding me?

Shame on you. Shame on you. The thing that really puzzles me is that there must be so many Canonical workers/Ubuntu volunteers packaging upstream fixes... I mean I must have installed at least 1000 updates to packages from upstream since October 10th. But a bug fixed upstream that affects one of the most basic, fundamental UI functions... low priority. Low priority!

I've been with you guys since the days of Warty. What has happened to you?

Pedro Villavicencio (pedro) wrote :

This is fixed now in Maverick Natty and Oneiric, please update your machine. Thanks.

Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Fix Released
Pausanias (pausanias) wrote :

You have got to be kidding me. What is the point of LTS then? I cannot simply "update my machine." I am running LTS in a production environment. I am supposed to be relying on the vaunted rock-solid stability of LTS. Lucid has several years to go in its life span.

It speaks volumes about Ubuntu's commitment to LTS that you would even post that. If Canonical does not have the resources to support LTS properly---especially for a bug where something as basic as the file open dialog is malfunctioning in an insidious and potentially harmful way---then do not support it at all. Do not make the claim of LTS.

Madars Vitolins (pointer-a) wrote :

When can we expect this to be fixed in LTS 10.04? It is very annoying bug!

JaumeFigueras (jaume-figueras) wrote :

I agree with user Pausanias. The bug is still present in LTS 10.04 and there are 3 and 1/2 more years of life cicle for this LTS. If you wont fix the bug, at least upgrade to gtk2.22 where the bug is solved.

The answer 'please update your machine' in a LTS environment is not admissible. This answer is like a 'problems winth vista?, buy win7' absolutely useless.

sorry for my bad english.

JaumeFigueras and Pausanias, please take a look at:

https://wiki.ubuntu.com/StableReleaseUpdates

which explains the logic behind updates in the LTS version, and the procedure to nominate an update for an LTS release.

So the procedure now that you know that the bug has been fixed in a development branch is to open a new bug report and provide the argumentation and information that you see in the link.

Pausanias (pausanias) wrote :

Walter, I just read that document. I need to be a computer scientist just to decipher that thing. I am not a community member, coder, or someone with the time to follow all that procedure.

Look, I'm just a poor LTS user. I bought into the whole promise of Ubuntu that while LTS is supposed to lack new features, it would fix critical bugs. This is a critical bug with LTS. It's been fixed upstream. It causes the file open dialog to behave in an erratic and potentially harmful way. And no one is willing to bring it back to LTS?

If there isn't a regular Ubuntu dev, whether paid or volunteer, who recognizes how important this bug is, then I give up on Ubuntu. Even worse, if you do recognize how important this bug is to fix, but lack the willingness to put your expertise into use for 2 minutes to follow that procedure of which you just spoke, then I give up on Ubuntu even worse. This isn't a case of an unknown random bug which can't be reproduced, it is the case of a bug which has been recognized by upstream and for which there is a specific patch.

Changed in gtk+2.0 (Ubuntu Lucid):
status: New → Confirmed
importance: Undecided → Medium
IKT (ikt) wrote :

Pausanias, we get it, here's the issue as I see it and I'll best 'transcribe' it for non-computer scientists ;)

1) 2010-04-09

Stephen makes the original bug report.

2) 2010-05-01

Luke Plant confirms the bug is present in GTK2.0

3) 2010-10-11

Tristan Moody reports the bug upstream with Gnome, as they are the developers of the GTK software, therefore they are the ones who would be best equipped to fix it

4) 2010-10-24

André Klapper (A Gnome developer) advises that he can't replicate the bug, and therefore can't fix the issue. He then requests someone try GTK 2.22.

5) 2010-10-27

Tristan Moody reports that it appears that the bug is fixed in 2.22

--
At this stage there is no patch for the bug, therefore there is nothing to simply throw down the update pipe. This is the issue, if there was a patch for the bug we wouldn't be having this convo, the issue would have been fixed long ago.

But because the Gnome developer couldn't find the bug in 2.0, this bug never existed in Gnome's world in the first place.

I mean the Gnome Developer (André Klapper) response could have been "don't care, go away" because nobody got anything useful out of it except that the bug they couldn't find is apparently fixed in GTK 2.2
--

6) 2011-11-29

Ikt runs across the bug from reddit :D

--

"If there isn't a regular Ubuntu dev, whether paid or volunteer, who recognizes how important this bug is, then I give up on Ubuntu."

There's lots of people who do realise how important it is, however there's a few who don't understand the reason why Ubuntu simply haven't fixed the bug, I mean it's fixed in 2.22, so just update to 2.22 already!

I think part of the issue is understanding just how big a package GTK is, and just how unhappy many people would be if Ubuntu sent down the update and broke the entire desktop, which co-incidentally uses GTK for the majority of it.

"if you do recognize how important this bug is to fix, but lack the willingness to put your expertise into use for 2 minutes to follow that procedure"

That's the problem, it's not a 2 minute fix because there's no patch.

So here are the options since we have no patch:

a) leave as is, a bug that affects a few people, and I mean 'a few' in a nice way, a bug that affects just 1 person (ie me) sucks (Hi #873016 :) ), and having it effect 30 is worse, but even medium level bugs affect 50%+ of users, and that's not indicated here.

b) send down GTK2.22 as a gigantic update that may break the critical applications and make 90%+ very unhappy.

That is as is my understanding of the options on the table, if anyone has any corrections I'm happy to be hear them.

And yes many of us are well aware of the limitations of the linux desktop and are working on changing this, unfortunately this doesn't help now :(

Hope this helps. :-)

Marc Deslauriers (mdeslaur) wrote :

Debian's gtk+2.0 (2.20.1-2) contains the following patches:

   + 030_gtkscake_redraw.patch: correctly redraw GtkScales.
     + 031_papersize_usletter.patch: update list of countries using US
       Letter paper format.
     + 032_offscreenwindow_dnd.patch: fix crasher with offscreen windows.
     + 033_filechooser_sort.patch: fix a bug that leaves a file chooser
       dialog unusable after a file has been touched in the open folder.
     + 034_grab_broken.patch: generate correct event for WM_KILLFOCUS.
     + 035_filechooser_crash.patch: fix a crasher when the file list is
       updated.

Maybe one of those fixes the issue.

Marc Deslauriers (mdeslaur) wrote :

SRU Request:

Impact: Current lucid users have an issue with the GTK file chooser selecting the wrong file when the sort order is changed, or when files get added to the tree. This may lead to the wrong file being selected.

Development fix: This issue affects 2.20, and was resolved in 2.22. Only Lucid is affected.

Stable Fix: This was corrected by adding two patched from the upstream git tree. See the attached minimal debdiff.

Test case: Open firefox to a page that requires a file upload (such as http://www.imgpaste.com), while the file selector is open, resort the files a few times, and enter and exit directories. Eventually you will end up with the wrong item being selected. (See video in comment #7)

Regression potential: The patches are simple and are included in later releases, there's not much potential for regressions here.

Hello Stephen, or anyone else affected,

Accepted gtk+2.0 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gtk+2.0 (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: added: verification-needed
JaumeFigueras (jaume-figueras) wrote :

Hello,

thanks for the fix. I've updated the packages from lucid-proposed (just the 4 affected) and begin testing.

Rolf Leggewie (r0lf) wrote :

Thanks. I had recently run into this problem and was able to verify it again today as well as the fix from the packages in -proposed. Please release.

tags: added: verification-done
removed: verification-needed
JaumeFigueras (jaume-figueras) wrote :

Hello again,
I've used intensively the openfiledialog with FF on joomla and moodle sites with no problems since the update.
Thank you.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.20.1-0ubuntu2.1

---------------
gtk+2.0 (2.20.1-0ubuntu2.1) lucid-proposed; urgency=low

  * Added two patches from git to fix filechooser issue (LP: #558674)
    - debian/patches/033_filechooser_sort.patch: fix new_order index in
      gtk/gtkfilesystemmodel.c.
    - debian/patches/035_filechooser_crash.patch: properly update Node IDs
      in gtk/gtkfilesystemmodel.c.
 -- Marc Deslauriers <email address hidden> Fri, 28 Oct 2011 19:28:58 -0400

Changed in gtk+2.0 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Pausanias (pausanias) wrote :

Thank you! The fix is much appreciated and shows the Ubuntu spirit is alive and well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.