Decorations and RGBA

Bug #491521 reported by Cody Russell on 2009-12-02
254
This bug affects 38 people
Affects Status Importance Assigned to Milestone
Ayatana Ubuntu
High
Cody Russell
GTK+
Invalid
Wishlist
Nautilus
Expired
Medium
gnome-desktop
Expired
Medium
gnome-desktop (Ubuntu)
Low
Unassigned
Nominated for Maverick by jv13613
gnome-screensaver (Ubuntu)
Low
Unassigned
Nominated for Maverick by jv13613
gtk+2.0 (Ubuntu)
Wishlist
Unassigned
Nominated for Maverick by jv13613
gtk-recordmydesktop (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by jv13613
libgksu (Ubuntu)
High
Cody Russell
Nominated for Maverick by jv13613
nautilus (Ubuntu)
High
Unassigned
Nominated for Maverick by jv13613

Bug Description

For Lucid, I'd like to get the new decorations feature integrated. This patch adds support for doing client-side window decorations, which pulls in support for RGBA colormaps.

The new decorations feature requires explicit support from a theme before it becomes active (it defaults to being disabled). However, RGBA support is enabled by default and there is a chance for some fallout from this being added.

Cody Russell (bratsche) on 2009-12-02
Changed in gtk+2.0 (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gtk+2.0 (Ubuntu):
status: New → In Progress
Cody Russell (bratsche) wrote :
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
importance: Low → Undecided
milestone: none → lucid-alpha-1
Ken VanDine (ken-vandine) wrote :

nautilus will also require a patch to work with these gtk changes

Changed in nautilus (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Low
milestone: none → lucid-alpha-1
status: New → In Progress
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Thanks guys, please get ppa testing before uploading those changes to lucid though

Cody Russell (bratsche) wrote :

This removes some functions that were listed in gtkwindow.h that didn't exist in gtkwindow.c, and it removes gtk_window_set_client_side_decorations() from gtkwindow.h and marks it static in gtkwindow.c

Cody Russell (bratsche) wrote :
Cody Russell (bratsche) wrote :
Cody Russell (bratsche) wrote :

Sorry, trying to keep one thing different in the patch between upstream and Ubuntu and I keep getting it mixed up. :)

David Barth (dbarth) wrote :

Cody tracking that for the DX team.

Changed in ayatana-ubuntu:
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Cody Russell (bratsche)
importance: Low → Medium
milestone: none → ubuntu-10.04-alpha-1
Cody Russell (bratsche) wrote :
Changed in nautilus (Ubuntu):
milestone: lucid-alpha-1 → lucid-alpha-2
Changed in gtk+2.0 (Ubuntu):
milestone: lucid-alpha-1 → lucid-alpha-2

Just added the ubuntu-desktop ppa and updated. Got the following updates:
------------------
The following packages will be upgraded:
  gtk2-engines-pixbuf libgail-common libgail18 libgtk2.0-0 libgtk2.0-bin
  libgtk2.0-common libnautilus-extension1 nautilus nautilus-data
9 packages upgraded, 0 newly installed, 0 to remove and 23 not upgraded.
Need to get 16.9MB of archives. After unpacking 20.5kB will be used.
Do you want to continue? [Y/n/?] y
-------------------
On restart, I can no longer navigate using nautilus. Using the sidebar to navigate is unresponsive and clicking on folders gives a pop up message: "opening 'folder' you can stop this operation by clicking cancel" the folder however, never opens.

godhika (godhika) wrote :

I guess I have found another regression. at least this appeared immediatley after I installed the packages from the ppa and restarted: I can`t open any windows with administartive privileges anymore. So no software sources , synaptic, the check updates option in update manager..... you get the idea.

godhika (godhika) wrote :

Forgot to mention: I can start all these programs from the terminal with no problems and scrolling in nautilus leaves artifacts until I resize the window

Brian (neon-lights) wrote :

I've got the same problem as Reynaldo, nautilus is pretty much unresponsive unless opened as root.

Chris Halse Rogers (raof) wrote :

The new gtk kills banshee stone-dead. It dies with a BadMatch X error as soon as it displays its main window. I'll see if I can get a useful backtrace.

Andrea Cimitan (cimi) wrote :

Hi, I'm the author of murrine engine and the maintainer of clearlooks.
I'm quite interested in client side window decorations, do you know how can I patch the engines to add that support?

Murrine already supports RGBA (transparency), but it lacks support for decorations

Cody Russell (bratsche) wrote :

Hey Andrea,

The decorations currently only defines some new style properties on GtkWindow, so you should be able to use it already from murrine I think.

GtkWindow:client-side-decorated - bool, defaults to FALSE
GtkWindow:decoration-border-width - int
GtkWindow:decoration-resize-handle - int
GtkWindow:client-side-drop-shadows - bool, defaults to FALSE
GtkWindow:extents-left - int
GtkWindow:extents-right - int
GtkWindow:extents-top - int
GtkWindow:extents-bottom - int

client-side-decorated needs to be set to TRUE to enable the feature, it defaults to FALSE

The four extents values control drop shadow size. For now make sure you set all four of those to the same value, or the drop shadow may be messed up.

Glad you're interested in it.. let me know how your experimentation goes, and until it gets officially merged into master could you report bugs to me directly by email? Use <email address hidden>

Cody Russell (bratsche) wrote :

Oh, and also gtk_paint_box() is passed a detail string of "decoration" that would be very useful to you for murrine.

jerrylamos (jerrylamos) wrote :

Using
Gnome Places > (another partition) > (folder) > rsyn
didn't do anything. rsyn is an executable file (to do rsynch on daily build) however the only way I can get it to go now is by using terminal and doing
sudo ./rsyn

The launch from Gnome Places doesn't work.

Any ideas how to track down the failure?

Thanks, Jerry

No idea if this is related:

After the update from the ppa totem is stone cold dead on start up, the app will render on to screen but then crash in flames.

terminal output:
(totem:21095): Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed

(totem:21095): Gtk-CRITICAL **: gtk_box_pack: assertion `child->parent == NULL' failed

(totem:21095): Gtk-WARNING **: Attempting to add a widget with type GtkHBox to a GtkFrame, but as a GtkBin subclass a GtkFrame can only contain one widget at a time; it already contains a widget of type GtkHBox

Gdk-ERROR **: The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 916 error_code 8 request_code 1 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Trace/breakpoint trap

Ken VanDine (ken-vandine) wrote :

The totem failure sounds related to this patch, that is the same error we get from gksudo.

Sebastien Bacher (seb128) wrote :

the current ppa version makes gnome-panel use cpu and not display any content there

Angel Guzman Maeso (shakaran) wrote :

Total freeze with gnome-panel for me. I cant use the gnome-desktop.

Andrea Cimitan (cimi) wrote :

but what about decorating the buttons (window controls)? I have not tried yet, but I guess that the detail in gtk_paint_box works for the window border, but not its controls!
Also, how does shadow work? how could the engine know if the border has to be rounded or squared?

all the crashes of totem, terminal etc etc depends on embedded windows, like gstreamer (banshee's now playing), rhythmbox's visualization, or terminal which uses a rgba window for the terminal screen

David (davidboy) wrote :

Tried opening firefox as sudo from the terminal and it messed up. Window borders were gone, and everything was frozen. Screen shot attached.

Angel Guzman Maeso (shakaran) wrote :

I get a temporaly workaround for fix gnome-panel freeze:
Download and install the last stable package for gtk+2.0:
wget http://archive.ubuntu.com/ubuntu/pool/main/g/gtk+2.0/libgtk2.0-0_2.19.1-1_i386.deb
sudo dpkg -i libgtk2.0-0_2.19.1-1_i386.deb
Reboot or start a new gnome session. For me works now.

Phill Whiteside (phillw) wrote :

+1 to #26. If I then go into synaptics, it offers to repair broken packages - selecting that borks the system again.

Setting these bug tasks to High ... these tasks are blocking integration in Lucid, and I would like to see this code get into Lucid as early as possible

Changed in ayatana-ubuntu:
importance: Medium → High
Changed in gtk+2.0 (Ubuntu):
importance: Low → High
Changed in nautilus (Ubuntu):
importance: Low → High
David Barth (dbarth) wrote :

Marking gksu as affected, being the main blocker for the integration of that in lucid. Cody is investigating the issue and preparing a fix for that one in priority.

Changed in gksu (Ubuntu):
assignee: nobody → Cody Russell (bratsche)
importance: Undecided → High
milestone: none → lucid-alpha-1
status: New → Triaged
Sebastien Bacher (seb128) wrote :

why is the nautilus change required? does every application need to do that? could you open an upstream bug too?

Changed in gksu (Ubuntu):
milestone: lucid-alpha-1 → lucid-alpha-2
Sebastien Bacher (seb128) wrote :

changing alpha1 milestone since that was a week ago now

Cody Russell (bratsche) wrote :

This fixes gksu

Sebastien Bacher (seb128) wrote :

libgksu (2.0.13~pre1-1ubuntu2) lucid; urgency=low

  * debian/patches/23_correct_colormap_get.patch:
    - change by Cody Russell to fix a rgba crasher (lp: #491521)

affects: gksu (Ubuntu) → libgksu (Ubuntu)
Changed in libgksu (Ubuntu):
status: Triaged → Fix Released
harrydb (harrydeboer) wrote :

I can add my wallpaper disappeared after installing these packages. When I try to change the wallpaper the screen turns black and than back to gray again. When I log out i can see the wallpaper briefly.

Dana Goyette (danagoyette) wrote :

Speaking of Nautilus, I get some assertion failures, currently:

(nautilus:3021): Gdk-CRITICAL **: gdk_window_set_back_pixmap: assertion `pixmap == NULL || gdk_drawable_get_depth (window) == gdk_drawable_get_depth (pixmap)' failed

(nautilus:3021): GLib-GObject-CRITICAL **: g_type_instance_get_private: assertion `instance != NULL && instance->g_class != NULL' failed

** (nautilus:3021): CRITICAL **: dbus_g_proxy_begin_call: assertion `DBUS_IS_G_PROXY (proxy)' failed

While we're adding RGBA to Nautilus anyway, it would be nice to be able to use the alpha channel in wallpapers -- both solid colors and images. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=545339

Omer Akram (om26er) wrote :

i also get the same condition as harrydb.

Bartłomiej (beton) wrote :

Had the same problem like harrydv and om26er. After reverting to older gtk+ version everything is ok.

Javier Jardón (jjardon) wrote :

Hello,

I've tried the c-s-d GTK+ branch and I've found some problems with glade3:

I've tried to add a GtkWindow to the workspace but then you can't add any widget to it. Also, the titlebar of the GtkWindow is transparent.

Kills Banshee death on startup:

Gdk-ERROR **: The program '/usr/lib/banshee-1/Banshee.exe' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 342 error_code 8 request_code 2 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Trace/breakpoint trap

Omer Akram (om26er) wrote :

transmission torrent = segmentation fault

Totem
Gdk-ERROR **: The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1768 error_code 8 request_code 1 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Trace/breakpoint trap

Chromium browser= flash plugin breaks, firefox works fine.

every applicaion of openoffice is having problem

desktop wallpaper is gone

nautilus is working great no problem for me.

Omer Akram (om26er) on 2010-01-06
Changed in gtk-recordmydesktop (Ubuntu):
status: New → Fix Released
Changed in gnome-desktop (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Changed in nautilus (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
status: In Progress → Fix Committed
Changed in gnome-desktop (Ubuntu):
status: Fix Committed → Fix Released
Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2010-01-07
Changed in gtk-recordmydesktop (Ubuntu):
status: Fix Released → Invalid
40 comments hidden view all 120 comments
Andrea Cimitan (cimi) wrote :

Just tried, works. If you add rgba = TRUE in your murrine theme, applications are transparent.

I'm still having problems with pidgin, sonata, and liferea. Though the other problems are solved (except for flash, embedding gstreamer, and previously mentioned drawing problems). Webkit is broken, both epiphany and midori have broken see-through rendering when gtk widgets are present on the page (google.com displays terribly for example, while ubuntuforums works perfectly). Sonata is broken because it uses egg.trayicon over gtk.statusicon (though it implements both). Forcing it to use gtk.statusicon makes it work perfectly. And chromium still has flash issues too, but since it doesn't use gtk on web pages it doesn't have the problems epiphany or midori have, but it doesn't display the titlebar correctly when using gtk theme.

Oh, and I'm liking the rgba, Cimitan. :D

Andrea Cimitan (cimi) wrote :

webkit is transparent because murrine clears the area, and webkit does
not initialize a background

2010/1/9 Michael Coupet <email address hidden>:
> I'm still having problems with pidgin, sonata, and liferea. Though the
> other problems are solved (except for flash, embedding gstreamer, and
> previously mentioned drawing problems). Webkit is broken, both epiphany
> and midori have broken see-through rendering when gtk widgets are
> present on the page (google.com displays terribly for example, while
> ubuntuforums works perfectly). Sonata is broken because it uses
> egg.trayicon over gtk.statusicon (though it implements both). Forcing it
> to use gtk.statusicon makes it work perfectly. And chromium still has
> flash issues too, but since it doesn't use gtk on web pages it doesn't
> have the problems epiphany or midori have, but it doesn't display the
> titlebar correctly when using gtk theme.
>
> Oh, and I'm liking the rgba, Cimitan. :D
>
> --
> Decorations and RGBA
> https://bugs.launchpad.net/bugs/491521
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ayatana Ubuntu Love Project: In Progress
> Status in GNOME Desktop Common Files: Unknown
> Status in GTK+ GUI Toolkit: Unknown
> Status in Nautilus: Unknown
> Status in “gnome-desktop” package in Ubuntu: Fix Released
> Status in “gnome-screensaver” package in Ubuntu: New
> Status in “gtk+2.0” package in Ubuntu: In Progress
> Status in “gtk-recordmydesktop” package in Ubuntu: Invalid
> Status in “libgksu” package in Ubuntu: Fix Released
> Status in “nautilus” package in Ubuntu: Fix Released
>
> Bug description:
> For Lucid, I'd like to get the new decorations feature integrated.  This patch adds support for doing client-side window decorations, which pulls in support for RGBA colormaps.
>
> The new decorations feature requires explicit support from a theme before it becomes active (it defaults to being disabled).  However, RGBA support is enabled by default and there is a chance for some fallout from this being added.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ayatana-ubuntu/+bug/491521/+subscribe
>

--
Andrea Cimitan - http://www.cimitan.com

Dunno if this is the best place to put this, but gnome-system-monitor's custom widgets have opaque backgrounds and it bothered me enough to try to fix it.

Patch attached to make gnome-system-monitor draw its custom widgets properly with transparent backgrounds. I'm pretty sure I did it right.

Andrea Cimitan (cimi) wrote :

go and open a new bugreport in gnome's bugzilla!

2010/1/10 Michael Coupet <email address hidden>:
> Dunno if this is the best place to put this, but gnome-system-monitor's
> custom widgets have opaque backgrounds and it bothered me enough to try
> to fix it.
>
> Patch attached to make gnome-system-monitor draw its custom widgets
> properly with transparent backgrounds. I'm pretty sure I did it right.
>
> ** Attachment added: "CustomWidgetOffscreenRendering.patch"
>   http://launchpadlibrarian.net/37665959/CustomWidgetOffscreenRendering.patch
>
> --
> Decorations and RGBA
> https://bugs.launchpad.net/bugs/491521
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ayatana Ubuntu Love Project: In Progress
> Status in GNOME Desktop Common Files: Unknown
> Status in GTK+ GUI Toolkit: Unknown
> Status in Nautilus: Unknown
> Status in “gnome-desktop” package in Ubuntu: Fix Released
> Status in “gnome-screensaver” package in Ubuntu: New
> Status in “gtk+2.0” package in Ubuntu: In Progress
> Status in “gtk-recordmydesktop” package in Ubuntu: Invalid
> Status in “libgksu” package in Ubuntu: Fix Released
> Status in “nautilus” package in Ubuntu: Fix Released
>
> Bug description:
> For Lucid, I'd like to get the new decorations feature integrated.  This patch adds support for doing client-side window decorations, which pulls in support for RGBA colormaps.
>
> The new decorations feature requires explicit support from a theme before it becomes active (it defaults to being disabled).  However, RGBA support is enabled by default and there is a chance for some fallout from this being added.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ayatana-ubuntu/+bug/491521/+subscribe
>

--
Andrea Cimitan - http://www.cimitan.com

Cody Russell (bratsche) wrote :

Not a proper fix, but it will get totem working for now.

Cimitan, I think the problem with webkit is actually in murrine. The problem goes away if in murrine_style.c lines 269-279 you change:

if (DETAIL ("entry_bg"))
{
 /* Draw (erase) the background */
 cairo_set_operator (cr, CAIRO_OPERATOR_CLEAR);
 cairo_paint (cr);
 cairo_set_operator (cr, CAIRO_OPERATOR_OVER);

 murrine_set_color_rgba (cr, &colors->base[state_type], ENTRY_OPACITY);
 cairo_rectangle (cr, 0, 0, width, height);
 cairo_fill (cr);
}

to

if (DETAIL ("entry_bg"))
{
 /* Draw (erase) the background */
 cairo_set_operator (cr, CAIRO_OPERATOR_CLEAR);
 cairo_rectangle (cr, x, y, width, height);
 cairo_clip(cr);
 cairo_paint (cr);
 cairo_set_operator (cr, CAIRO_OPERATOR_OVER);

 murrine_set_color_rgba (cr, &colors->base[state_type], ENTRY_OPACITY);
 cairo_rectangle (cr, x, y, width, height);
 cairo_fill (cr);
}

Thanks for redirecting me btw.

Andrea Cimitan (cimi) wrote :

Haven't tried yet... but I will merge the patch to git ASAP :) thanks
Is the cairo_clip necessary if you replace cairo_paint with cairo_fill?

2010/1/11 Michael Coupet <email address hidden>:
> Cimitan, I think the problem with webkit is actually in murrine. The
> problem goes away if in murrine_style.c lines 269-279 you change:
>
> if (DETAIL ("entry_bg"))
> {
>        /* Draw (erase) the background */
>        cairo_set_operator (cr, CAIRO_OPERATOR_CLEAR);
>        cairo_paint (cr);
>        cairo_set_operator (cr, CAIRO_OPERATOR_OVER);
>
>        murrine_set_color_rgba (cr, &colors->base[state_type], ENTRY_OPACITY);
>        cairo_rectangle (cr, 0, 0, width, height);
>        cairo_fill (cr);
> }
>
> to
>
> if (DETAIL ("entry_bg"))
> {
>        /* Draw (erase) the background */
>        cairo_set_operator (cr, CAIRO_OPERATOR_CLEAR);
>        cairo_rectangle (cr, x, y, width, height);
>        cairo_clip(cr);
>        cairo_paint (cr);
>        cairo_set_operator (cr, CAIRO_OPERATOR_OVER);
>
>        murrine_set_color_rgba (cr, &colors->base[state_type], ENTRY_OPACITY);
>        cairo_rectangle (cr, x, y, width, height);
>        cairo_fill (cr);
> }
>
> Thanks for redirecting me btw.
>
> --
> Decorations and RGBA
> https://bugs.launchpad.net/bugs/491521
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ayatana Ubuntu Love Project: In Progress
> Status in GNOME Desktop Common Files: Unknown
> Status in GTK+ GUI Toolkit: Unknown
> Status in Nautilus: Unknown
> Status in “gnome-desktop” package in Ubuntu: Fix Released
> Status in “gnome-screensaver” package in Ubuntu: New
> Status in “gtk+2.0” package in Ubuntu: In Progress
> Status in “gtk-recordmydesktop” package in Ubuntu: Invalid
> Status in “libgksu” package in Ubuntu: Fix Released
> Status in “nautilus” package in Ubuntu: Fix Released
>
> Bug description:
> For Lucid, I'd like to get the new decorations feature integrated.  This patch adds support for doing client-side window decorations, which pulls in support for RGBA colormaps.
>
> The new decorations feature requires explicit support from a theme before it becomes active (it defaults to being disabled).  However, RGBA support is enabled by default and there is a chance for some fallout from this being added.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ayatana-ubuntu/+bug/491521/+subscribe
>

--
Andrea Cimitan - http://www.cimitan.com

Benjamin Otte (Company) (otte) wrote :

if (DETAIL ("entry_bg"))
{
  cairo_set_operator (cr, CAIRO_OPERATOR_SOURCE);
  murrine_set_color_rgba (cr, &colors->base[state_type], ENTRY_OPACITY);
  cairo_rectangle (cr, 0, 0, width, height);
  cairo_fill (cr);
}

should work as well. It's even more than twice as fast.

right, but

cairo_rectangle (cr, 0, 0, width, height);

would need to be

cairo_rectangle (cr, x, y, width, height);

otherwise it draws in the wrong place, i.e. the top left corner of webpages.

Andrea Cimitan (cimi) wrote :

Patches committed to git, MANY MANY THANKS :)

2010/1/11 Michael Coupet <email address hidden>:
> right, but
>
> cairo_rectangle (cr, 0, 0, width, height);
>
> would need to be
>
> cairo_rectangle (cr, x, y, width, height);
>
> otherwise it draws in the wrong place, i.e. the top left corner of
> webpages.

--
Andrea Cimitan - http://www.cimitan.com

Andrea Cimitan (cimi) wrote :

unfortunately, gnome-panel still does not display anything and eats
all my slow cpu (atom)... so it's harder to test the whole thing

What I've noticed is that this patch to gtk also causes more expose events to occur, including one I've specifically spotted where resizing a window to the same size it already was causes an event. I had a piece of code that used to run perfectly but since it had a resize in the expose event handler, it wasn't actually able to draw at all and just used 100% cpu. I think this also applies to animated progressbars in murrine, they give me 100% cpu as well, but they do draw.

Andrea Cimitan (cimi) wrote :

Animations currently look more like a hack... I personally disable
them in every theme waiting for a better gtk+ api with animations

Andrea Cimitan (cimi) wrote :

I have seen RGBA was removed from the PPA... any reason for this?

I didn't see any client-side decorations until now, and they're kinda broken for any program that's using an rgba colormap. Gnome-terminal doesn't seem to paint its border fully and neither does gedit with the rgba plugin. Gnome-system-monitor crashes on startup.

I have just added the PPA, but I doin't get any updates then? Is it normal? Are you going to put it in the main repos?

@thib it has been postponed till lucid+1

@Shane Fagan so no RGBA in lucid? It's a pity. Let's wait till october...

I use Ubuntu Karmic on an Intel Core Duo, 64 bit Acer Aspire 5738 laptop.

According to the instructions on https://lists.ubuntu.com/archives/ubuntu-desktop/2009-December/002337.html , I followed these steps to add the PPA and upgrade:
sudo add-apt-repository ppa:ubuntu-desktop/ppa
sudo apt-get update
sudo apt-get upgrade

Transparency works wonderfully! I love the way it looks. Sadly, I get transparency only in Nautilus. No transparency in gcalc, Banshee, Totem, etc.

GianZap (gianzap) wrote :

Since you patched nautilus and gnome-desktop for RGBA, I wonder if it's possible now to tell nautilus to draw a really transparent background for the desktop, still keeping the icons, so that the wallpaper plugin of compiz can take care of drawing the wallpaper(s). This would allow different wallpapers on each workspace, still keeping desktop icons.

(Just asking hoping it's trivial, won't disturb again. )

This is currently in lucid and I'm using it and have two problems.

- Resize code is broken, when a window tries to resize itself to say, 500x500px you get a 500x500px window, including decorations rather than 500x500px window and then decorations surrounding that. This breaks apps like gnome-mplayer resizing to the video size.

- setting no decoration hint no longer works with other window managers. With csd off, the window manager displays decorations for all windows, but with csd on, there are csd window decorations for only the windows that don't have the hint (which is good), but the other windows have decorations from the window manager. Turning off decorations for the window manager is one solution (i.e. in compiz) but that means that QT apps don't have any decorations.

I'm mostly just worried about the resize thing right now and I hope it can be fixed soon.

Thanks,

Mike

One last thing that I find mildly annoying is that the window title isn't vertically centered, but that's just aesthetics.

Kari Takanen (refic) wrote :

So how does one enable it?

Sam Illingworth (mazz0) wrote :

Did you get an answer to that?

On 21 February 2010 16:32, Kari Takanen <email address hidden> wrote:

> So how does one enable it?
>
> --
> Decorations and RGBA
> https://bugs.launchpad.net/bugs/491521
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ayatana Ubuntu Love Project: In Progress
> Status in GNOME Desktop Common Files: Unknown
> Status in GTK+ GUI Toolkit: Unknown
> Status in Nautilus: Unknown
> Status in “gnome-desktop” package in Ubuntu: Fix Released
> Status in “gnome-screensaver” package in Ubuntu: New
> Status in “gtk+2.0” package in Ubuntu: In Progress
> Status in “gtk-recordmydesktop” package in Ubuntu: Invalid
> Status in “libgksu” package in Ubuntu: Fix Released
> Status in “nautilus” package in Ubuntu: Fix Released
>
> Bug description:
> For Lucid, I'd like to get the new decorations feature integrated. This
> patch adds support for doing client-side window decorations, which pulls in
> support for RGBA colormaps.
>
> The new decorations feature requires explicit support from a theme before
> it becomes active (it defaults to being disabled). However, RGBA support is
> enabled by default and there is a chance for some fallout from this being
> added.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ayatana-ubuntu/+bug/491521/+subscribe
>

--
Sam Illingworth

Changed in gtk+2.0 (Ubuntu):
milestone: lucid-alpha-2 → none
assignee: Ken VanDine (ken-vandine) → nobody
importance: High → Wishlist
Sebastien Bacher (seb128) wrote :

closing the bug since csd has been delayed to after lucid

Changed in gtk+2.0 (Ubuntu):
status: In Progress → Invalid
Cody Russell (bratsche) on 2010-03-11
Changed in ayatana-ubuntu:
status: In Progress → Invalid
Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Low
Changed in gnome-screensaver (Ubuntu):
status: New → Invalid
Sergio Zanchetta (primes2h) wrote :

@Jacopo
Is there a valid reason to mark it as Invalid?
Please explain it before changing bug status.

Changed in gnome-screensaver (Ubuntu):
status: Invalid → New
Sense Egbert Hofstede (sense) wrote :

Marking gnome-screensaver Invalid in accordance with the gtk+2.0 task status, indicating that this is postponed to lucid+1.

Changed in gnome-screensaver (Ubuntu):
status: New → Invalid
Changed in gtk:
status: Unknown → In Progress
sasagundul (mindscrewer06) wrote :

i've found a fix for banshee to run without RGBA
you should add Banshee to RGBA blacklist

gedit ~/.profile

add these two lines :

export GTK_MODULES=rgba
export GTK_RGBA_APPS=allbut:Banshee

Ive noticed that CSD is in Maverick already (im on it already) but RGBA isnt turned on. Is that intentional or is it some bug with my system?

Erik B. Andersen (azendale) wrote :

@sasagundul
I would like to point out that the PPA I made is not official, and turns on RGBA with (probably) different code than this bug uses. So, if you are using my PPA and there is a problem with it, email me (I think my email is on my page on launchpad) and I'll try to fix it.
My PPA uses those to environment variables, but I don't think the code this bug used/uses does.

sasagundul (mindscrewer06) wrote :

@Erik B. Andersen
i'm so sorry for my mistake. thank for reminding me
i have suggestion for your PPA. please add more application to the blacklist file. Banshee won't run with the RGBA enabled.
thanks in advance

Changed in gnome-desktop:
status: Unknown → New
Changed in nautilus:
status: Unknown → New
Changed in gnome-desktop:
importance: Unknown → Medium
Changed in gtk:
importance: Unknown → Wishlist
Changed in nautilus:
importance: Unknown → Medium
Sebastien Bacher (seb128) wrote :

Cody, your patch for gnome-desktop will need updating for GNOME3, they stopped using a gdk colormap but use cairo directly in the current version

Changed in gnome-desktop:
status: New → Incomplete
Changed in gnome-desktop:
status: Incomplete → Expired
Changed in nautilus:
status: New → Expired
Changed in gtk:
status: In Progress → Invalid

I'm not involved in the development of gksu. Nor have I looked at GTK2
related code in ages.
So I'm definitely the wrong person to poke.

Benjamin

On Sun, Jan 17, 2016 at 3:32 PM, Mattias Andrée <email address hidden>
wrote:

> https://launchpadlibrarian.net/36875787/libgksu-rgba-fix.diff
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/491521
>
> Title:
> Decorations and RGBA
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-ubuntu/+bug/491521/+subscriptions
>

I see it fixed.

Displaying first 40 and last 40 comments. View all 120 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.