cups printer instances not usable from gtk applications

Bug #458116 reported by Patrick Pfeifer on 2009-10-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Common Print Dialog
Wishlist
Unassigned
GTK+
Fix Released
Medium
gtk+2.0 (Ubuntu)
Low
Unassigned

Bug Description

This (http://lists.opensuse.org/opensuse-bugs/2009-02/msg05856.html) bug on suse summarizes the problem.

I have once filed a bug upstream (http://bugzilla.gnome.org/show_bug.cgi?id=582747) which never got any attention.

My suggested workaround in the upstream bug would at least prevent one bad effect the bug is having if you define cups "instances" in your /etc/cups/lpoptions or ~/.cups/lpoptions - either using old kde 3.5 print configuration dialog or "lpoptions" command line.

Read the loptions man page to learn about cups "instances". They are really useful. If anybody knows an alternative I'd be happy to learn about it as well. Multiple "queues" (printers) for the same "device URL" are not an alternative, as at least /usr/share/system-config-printer/system-config-printer.py (System->Administration->Printing) doesn't seem to allow setting up multiple printers with the same device file due to a cups error (client-error-not-possible) occurring if you try (at least for the cnij_usb: backend I'm using).

If the cups instances are here to stay and somebody gave me some tips on how to get my code accepted by upstream I'd maybe take some effort to implement instances in the gtk libprintbackend-cups library.

But there is some other printing dialog efforts going on. E.g. "Common Printing Dialog" (https://wiki.edubuntu.org/CommonPrintingDialog) On this (https://www.linuxfoundation.org/en/OpenPrinting/OpenPrinting_Summit_San_Francisco_2009) page you find some nice slides (https://www.linuxfoundation.org/images/4/4d/CommonPrintingDialogLF09.pdf) about it. Does anybody know if there are any useable results from this project yet ?

ProblemType: Bug
Architecture: amd64
Date: Thu Oct 22 13:57:49 2009
DistroRelease: Ubuntu 9.10
Package: libgtk2.0-0 2.18.3-1
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=C
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: gtk+2.0
Uname: Linux 2.6.31-14-generic x86_64

Patrick Pfeifer (patrick2000) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report

Changed in gtk+2.0 (Ubuntu):
status: New → Triaged
status: Triaged → New
importance: Undecided → Low
status: New → Triaged
Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
tags: added: cpd
Changed in common-print-dialog-gtk:
importance: Undecided → Wishlist
Changed in gtk:
status: New → Confirmed
Changed in gtk:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.