libgtk upgrade to 2.17.2-0ubuntu3 breaks lotus notes 8.5.x

Bug #398250 reported by DSHR on 2009-07-11
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GTK+
Unknown
High
gtk+2.0 (Ubuntu)
Low
Ubuntu Desktop Bugs
Declined for Karmic by Sebastien Bacher

Bug Description

IBM Lotus Notes fails to draw several windows correctly after upgrade:

$ apt-cache policy gtk2-engines-pixbuf
gtk2-engines-pixbuf:
  Installiert: 2.17.2-0ubuntu2
  Kandidat: 2.17.3-0ubuntu1
  Versions-Tabelle:
     2.17.3-0ubuntu1 0
        500 http://de.archive.ubuntu.com karmic/main Packages
 *** 2.17.2-0ubuntu2 0
        100 /var/lib/dpkg/status

Downgrading gtk2-engines-pixbuf and libgtk2.0-0 to previous version seems to make it work again.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

summary: - [karmic] libgtk upgrade to 2.17.2-0ubuntu3 breaks lotus notes 8.5.x
+ libgtk upgrade to 2.17.2-0ubuntu3 breaks lotus notes 8.5.x
Changed in gtk+2.0 (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

the issue could be one of the ones fixed in 2.17.4 which will be uploaded tomorrow

DSHR (s-heuer) wrote :

I'm going to try that version then ...

Sebastien Bacher (seb128) wrote :

the issue needs to be tested and sent to GNOME by somebody using lotus notes bugs triagers will not likely have access to this software

DSHR (s-heuer) wrote :

The new version does not fix it - part of the UI ist still completely black. I copied

libgdk_pixbuf-2.0.so.0.1702.0 libgdk_pixbuf_xlib-2.0.so.0.1702.0 libgdk-x11-2.0.so.0.1702.0 libgtk-x11-2.0.so.0.1702.0

to /opt/ibm/lotus/notes folder (removing the version number) and that restores functionality.

Attaching Lotus output from .xsession-errors ...

DSHR (s-heuer) wrote :

Issue isn't fixed with the latest updates. I've upgraded Notes to 8.5 FP1 - no change.

Filed a bug on gnome then: http://bugzilla.gnome.org/show_bug.cgi?id=590404

Karmic will not be a supported Notes release, but maybe the report helps if the bug is not in notes but in gtk.

Changed in gtk+2.0 (Ubuntu):
status: New → Triaged
Changed in gtk:
importance: Undecided → Unknown
status: New → Unknown
Bryn Hughes (linux-nashira) wrote :

I can confirm this issue. Like the original poster I was able to work around the problem by installing

libgdk_pixbuf-2.0.so.0.1702.0 libgdk_pixbuf_xlib-2.0.so.0.1702.0 libgdk-x11-2.0.so.0.1702.0 libgtk-x11-2.0.so.0.1702.0

into /opt/ibm/lotus/notes and removing the version information (.1702.0)

Sebastien Bacher (seb128) wrote :

The upstream bug has details on the issue, it's mainly somebody notus notes need to get fixed because GNOME doesn't want to add workaround for this specific software

Changed in gtk+2.0 (Ubuntu):
importance: Medium → Low
DSHR (s-heuer) wrote :

I rebuilt gtk+2.0-2.17.11 with the upstream fix and that solves the problem for me.

As far as I know IBM plans to release 8.5.1 in October '09. There are no public betas for that release available. So I suspect that Karmic will not be able to run Lotus Notes.

Is there anything I can do?

Sebastien Bacher (seb128) wrote :

You can try to contact Lotus and ask them when the new version will be there or if they have any suggestion, otherwise you can keep using jaunty or preload an old gtk version to run lotus or try to build a patched gtk with the upstream change

I copied the 4 files from /usr/lib to the /opt/../notes directory, removing the version number (.1800.2) but it doesn't change anything. Can anybody confirm that this is the workaround ?

can anybody tell me where I could find the .1702 files ?

EclipseAgent (ben-kevan) wrote :

Here, I have uploaded the 1702 files without the version numbering:
http://www.benkevan.com/upload/lotus_notes/

Copy them into your /opt/ibm/lotus/notes directory and you'll be golden.

Lionel,

Yes, the .1800 version is also bad.. IBM is working on the issue

EclipseAgent : thanks a lot, it's really helpful. The strangest thing is that, with 1800 version, LN worked once but then failed again after a restart. Seems to work perfectly with your files.

Tim O'Hare (timohare) wrote :

EclipseAgent & others, thanks heaps for the files and fixes.
Worked a treat.

EclipseAgent (ben-kevan) wrote :

You guys are welcome.. I'd like to note that the summary should report "Breaks Lotus Notes 8.5.0 and 8.5.1", since they may be fixing it for 8.5.2, but I haven't been able to confirm.

I have confirmed that it's broken in the release of 8.5.1

That libs http://www.benkevan.com/upload/lotus_notes/ work for me either. Thank you

Stéphane Gautrin (penkoad) wrote :

Yes the hack of EclipseAgent on comment #13 works fine for a Karmic RC and Lotus Notes Revision 20090929.1223 (Release 8.5.1)
Cheers mate.

frana (jiri-sramek) wrote :

Yes, it is working. NICE work. I have Ubuntu 9.10 with L.N. 8.5
Best Regards from Prague, Czech republic

MMO (mmo-cuenta) wrote :

Thanks a lot. With these four files it worked for me too.

Kind regards

@EclipseAgent Thank you!!! After upgrade to 9.10 mi Lotus Notes 8.5 didn't show anything. Now works fine!

@EclipseAgent.
Also thanks from me.
I have been using Ubuntu now for 3 months and without the help of the wonderful people on the forums it would have been so much harder if not impossible to solve the problems i have faced during that time

MN (mnagraj) wrote :

 Yes, adding these four files fixed the issue in 9.10, thanks a lot. ( I had to use root login to add these files to Notes folder). But it doesn't allow me to replicate. All the options in Basic tab are grayed and I can't check mark the optional boxes in other tabs.

pema (peter-adser) wrote :

Thank you!!! After upgrade to 9.10 mi Lotus Notes 8.5 didn't show anything. But ... I can't copy the files in de map. This map belog to ROOT en I can't copy anything in there ... can anyone help me?

alt-F2
enter: gksudo nautilus

this will start the file manager as root so you can move the files there, but pay attention because moving other files could screw up your installation

Echo (echofloripa) wrote :

I copied the libraries in http://www.benkevan.com/upload/lotus_notes/ to /opt/ibm/lotus/notes but still can't select checkboxes.

I get a few warning though (when starting through the command line)

Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
(<unknown>:29322): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libmurrine.so: wrong ELF class: ELFCLASS64

Thanks
emerson

You probably are running a 64 bit linux. I think those files are 32 bit only. You could ask AclipseAgent to build the x64 ones for you?

MrGuga (mrguga) wrote :

Im also running 64bit karmic and i cant see if checkboxes are marked or not, like Emerson.

The checkbox problem is a problem with the Clearlooks theme. Try using NewWave instead.

EclipseAgent (ben-kevan) wrote :

Just wanted to note that I'm currently on Lotus Notes 8.5.2 Beta and the problem has been resolved :o)

Running GTK 2.18.6 I've tested.. yay

DSHR (s-heuer) wrote :

Problem is fixed with Lotus Notes 8.5.1 FP3 - upgrade to that version ...

Hm, how is that fixpack supposed to be installed? Or else: how is it supposed to help installing Notes 8.5 when its initial installation still requires those old libraries?

DSHR (s-heuer) wrote :

With Lotus Notes 8.5.2 under Lucid the problem is gone ...

Changed in gtk:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.