gtk-button-images not respected

Bug #367257 reported by Marcin Gałązka on 2009-04-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GTK+
Expired
Medium
gtk+2.0 (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

A 'gtk-button-images=0' setting when placed in '~/.gtkrc-2.0' (or theme specific 'gtk-2.0/gtkrc') is supposed to hide stock icons on buttons. It was working as adversized before but 9.04 seems to ignore this setting.

Ubuntu 9.04.

See http://www.gtk.org/api/2.6/gtk/GtkSettings.html#GtkSettings--gtk-button-images for relevant API description.

See http://ubuntuforums.org/showthread.php?t=1135510 and http://ubuntuforums.org/showthread.php?t=1130442 for related threads.

Andreas Moog (ampelbein) on 2009-04-26
affects: ubuntu → gtk+2.0 (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that seems an upstream issue and something to send to bugzilla.gnome.org

Changed in gtk+2.0 (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Wishlist
Marcin Gałązka (hipnoizz) wrote :

Ok, I will report this issue to Gnome Bugzilla then.

Changed in gtk:
status: Unknown → New
Changed in gtk+2.0 (Ubuntu):
status: New → Triaged

I can confirm the issue. Ubuntu 9.04. It works fine with 8.04, which I will continue to use because of this bug.

If there's anything I can do to help, please let me know. Thanks.

Marcin Gałązka (hipnoizz) wrote :

New gconf key '/desktop/gnome/interface/buttons_have_icons' can be used to toggle stock icons visibility. See linked Gnome issue for an additional info.

I will mark this bug as invalid.

Changed in gtk+2.0 (Ubuntu):
status: Triaged → Invalid
Changed in gtk:
status: New → Invalid
pickarooney (richard-walsh) wrote :

This bug is still in effect in XFCE/Xubuntu and there is no workaround as above (gconf).
Please provide a fix or workaround for XFCE users.
Thanks.

Changed in gtk+2.0 (Ubuntu):
status: Invalid → In Progress
Sebastien Bacher (seb128) wrote :

don't reopen bugs without comment

Changed in gtk+2.0 (Ubuntu):
status: In Progress → Invalid
pickarooney (richard-walsh) wrote :

Comment is in post #5:

"This bug is still in effect in XFCE/Xubuntu and there is no workaround as above (gconf).
Please provide a fix or workaround for XFCE users.
Thanks."

Changed in gtk+2.0 (Ubuntu):
status: Invalid → In Progress
Sebastien Bacher (seb128) wrote :

do you work on the issue that you set the bug in progress now?

pickarooney (richard-walsh) wrote :

Is that better? It seems like you're more interested in closing it than addressing it.

Changed in gtk+2.0 (Ubuntu):
status: In Progress → Confirmed
Sebastien Bacher (seb128) wrote :

not really, rather not interest by the issue it's an upstream one and should be discussed on bugzilla rather than on launchpad

Changed in gtk:
status: Invalid → Incomplete
Changed in gtk:
status: Incomplete → New
Changed in gtk:
importance: Unknown → Medium
Changed in gtk:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.