Ubuntu

Volume control hotkeys don’t work while a popup menu is open in any application

Reported by Anders Kaseorg on 2009-04-07
4
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-settings-daemon

My laptop’s volume up/down/mute keys work just fine most of the time, but *not* when any application has a popup menu open. This includes the panel main menu, any application menu, a right-click context menu, the Firefox address bar, etc.

I’m using Jaunty amd64, but I think I’ve seen this in many previous Ubuntu releases too.

YoBoY (yoboy-leguesh) wrote :

Tested on Ubuntu Intrepid, and Jaunty

It's not only the volume hotkeys who don't work, but also other shortkeys like ALT+F2, ....

I don't think it's the right package.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

affects: gnome-settings-daemon (Ubuntu) → gtk+2.0 (Ubuntu)
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

that's not a bug but how gtk works, it grabs key events to get menus working

Anders Kaseorg (anders-kaseorg) wrote :

I understand that’s how GTK works. But the resulting behavior is still a bug.

Changed in gtk+2.0 (Ubuntu):
status: Invalid → New
Sebastien Bacher (seb128) wrote :

the bug has been closed because that's a duplicate don't reopen it

Changed in gtk+2.0 (Ubuntu):
status: New → Invalid
Anders Kaseorg (anders-kaseorg) wrote :

My apologies; normally a duplicate bug is linked to the bug that it is a duplicate of. Can you please give me a pointer to the other bug so I can follow it?

Sebastien Bacher (seb128) wrote :

ideally, there is several duplicates about that one though and there is lot of bugs coming after beta so I would rather spend efforts on fixing issue than looking numbers for you, they should be easy to find though

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers