GtkExpander reports incorrect "name" to accessibility tools

Bug #305226 reported by Pete Johanson on 2008-12-04
6
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+2.0 (Ubuntu)
Low
Ubuntu Desktop Bugs
Intrepid
Undecided
Unassigned
Jaunty
Low
Ubuntu Desktop Bugs

Bug Description

This is a request to add the fix from GNOME bug #353088 (http://bugzilla.gnome.org/show_bug.cgi?id=353088) to the Intrepid gtk+ package. Without this fix, on Intrepid, GtkExpander widgets that normally would be named something like "Options" now have a name of "_Options" if there was a mnemonic of "O" to toggle the GtkExpander.

This has broken our automated GUI tests via Strongwind (http://medsphere.org/community/project/strongwind) because different names are now reported.

Thanks.

Pedro Villavicencio (pedro) wrote :

thanks for the report, Sebastien may you have a look to this later?

Changed in gtk+2.0:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in gtk:
status: Unknown → New

Any activity on this? This isn't just a problem for automated test utilities, it also affects screen readers, and anyone else using ATK/AT-SPI to get information. Seeing as Ubuntu touts themselves on accessibility stuff... shouldn't this be a priority?

While on the topic of "gtk+ bugs that make accessibility harder/impossible", I've also openned GNOME bug #568592 (http://bugzilla.gnome.org/show_bug.cgi?id=568592) for another regression in gail introduced in gtk+ 2.14.

Can we please also get that fixed in Ubuntu's gtk+ packages on Intrepid?

Sebastien Bacher (seb128) wrote :

has the bug been fixed in the upstream svn?
that would be something that could be consider for a stable update if somebody wants to work on it, the desktop team has limited ressources and lot to do and intrepid is not a lts

Yes, upstream gtk+ has both fixes now. Cody Russell has done some work on creating packages for us that incorporate both fixes, if the work he has done would be helpful in getting this packaged, I will talk to him about getting his changes published/attached.

Cody Russell (bratsche) wrote :

I talked to Sebastien briefly on #gnome-hackers today and he suggested that I could attach the necessary diffs to this bug report and that would be useful.

The two bugs in question are:

http://bugzilla.gnome.org/show_bug.cgi?id=568592
http://bugzilla.gnome.org/show_bug.cgi?id=567944

I'll attach the diffs below.

Cody Russell (bratsche) wrote :
Cody Russell (bratsche) wrote :

Wait, sorry.. I messed up. #567944 has nothing to do with this, although that is the correct diff.

Cody Russell (bratsche) wrote :

This is the same diff I attached above, but I accidentally marked it as coming from the wrong bug#. It actually comes from this one:

http://bugzilla.gnome.org/show_bug.cgi?id=353088

Sorry for the confusion.

Martin Pitt (pitti) wrote :

Accepted gtk+2.0 into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gtk+2.0:
status: New → Fix Committed
Cody Russell (bratsche) wrote :

This fix is released upstream, and we already have it in our sources. (the bug isn't closed upstream yet because it's waiting for documentation)

Changed in gtk+2.0 (Ubuntu Jaunty):
status: Triaged → Fix Released
Changed in gtk:
status: New → Fix Released
Martin Pitt (pitti) wrote :

Any testers? Anyone using the intrepid-proposed gtk version and can confirm that GNOME still works?

Martin Pitt (pitti) wrote :

Unless we can get someone to test this, I'm going to remove this from intrepid-proposed again. This has sat in -proposed for almost 300 days already.

Martin Pitt (pitti) wrote :

2009-09-09 09:32:17 INFO Removing candidates:
2009-09-09 09:32:17 INFO gtk+2.0 2.14.4-0ubuntu2 in intrepid
2009-09-09 09:32:17 INFO Removed-by: Martin Pitt
2009-09-09 09:32:17 INFO Comment: unverified SRU
2009-09-09 09:32:17 INFO 78 packages successfully removed.
2009-09-09 09:32:17 INFO Transaction committed.

Changed in gtk+2.0 (Ubuntu Intrepid):
status: Fix Committed → Won't Fix
Changed in gtk:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.