Ubuntu

Problem with showing some Lao Unicode char

Reported by Os555 on 2008-11-06
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
High
Mozilla Firefox
Invalid
Undecided
Unassigned
Pango
Expired
Medium
epiphany-browser (Ubuntu)
Undecided
Unassigned
gedit (Ubuntu)
Low
Unassigned
gtk+2.0 (Ubuntu)
Low
Unassigned
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: firefox-3.0

firefox-3.0 Problem with showing some Lao Unicode character
Description: Ubuntu 8.10
Release: 8.10
firefox-3.0

Hi Ubuntu team
i'm very new for ubuntu and this is my first time reporting the bug
I'm Lao and i found some bug with Firefox 3 On ubuntu with showing ປົ on web pages or text box

when i type or viewing website have ົ and ປ the char ົ will show as ຍ
firefox-3.0
but ົ with another char is showing correctly

Lao language is UTF-8 (lo)

Lao(lo) = English
ົ = q
ປ = x
ຍ = p
 the problem is when i type ປົກ is ( xqd ) in english the ົ will show as ຍ

but when i try with another ສົກ = ( lqd ) is showing correctly

Please check for this
Thanks

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
Package: firefox-3.0 3.0.3+nobinonly-0ubuntu2
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.27-7-generic i686

Os555 (laozaainfo) wrote :

Os555 wrote:
> Public bug reported:
>
> Binary package hint: firefox-3.0
>
>
> firefox-3.0 Problem with showing some Lao Unicode character
> Description: Ubuntu 8.10
> Release: 8.10
> firefox-3.0
>
> Hi Ubuntu team
> i'm very new for ubuntu and this is my first time reporting the bug
> I'm Lao and i found some bug with Firefox 3 On ubuntu with showing ປົ on web pages or text box
>
>
could you please bring the bug description in the
https://wiki.ubuntu.com/MozillaTeam/NormalizedBugFormat ?

 status incomplete

> when i type or viewing website have ົ and ປ the char ົ will show as ຍ
> firefox-3.0
> but ົ with another char is showing correctly
>
> Lao language is UTF-8 (lo)
>
> Lao(lo) = English
> ົ = q
> ປ = x
> ຍ = p
> the problem is when i type ປົກ is ( xqd ) in english the ົ will show as ຍ
>
> but when i try with another ສົກ = ( lqd ) is showing correctly
>
>
maybe its a font problem? Do you see the same issue only in ffox or also
in other apps that allow you to type things?

Changed in firefox-3.0:
status: New → Incomplete

For other Application on ubuntu is don't have this problem I have try with
many of app
i found only on firefox
i dont know why ?

Regard

On Sun, Dec 28, 2008 at 9:15 PM, Alexander Sack <email address hidden> wrote:

> Os555 wrote:
> > Public bug reported:
> >
> > Binary package hint: firefox-3.0
> >
> >
> > firefox-3.0 Problem with showing some Lao Unicode character
> > Description: Ubuntu 8.10
> > Release: 8.10
> > firefox-3.0
> >
> > Hi Ubuntu team
> > i'm very new for ubuntu and this is my first time reporting the bug
> > I'm Lao and i found some bug with Firefox 3 On ubuntu with showing ປົ on
> web pages or text box
> >
> >
> could you please bring the bug description in the
> https://wiki.ubuntu.com/MozillaTeam/NormalizedBugFormat ?
>
> status incomplete
>
> > when i type or viewing website have ົ and ປ the char ົ will show as ຍ
> > firefox-3.0
> > but ົ with another char is showing correctly
> >
> > Lao language is UTF-8 (lo)
> >
> > Lao(lo) = English
> > ົ = q
> > ປ = x
> > ຍ = p
> > the problem is when i type ປົກ is ( xqd ) in english the ົ will show as
> ຍ
> >
> > but when i try with another ສົກ = ( lqd ) is showing correctly
> >
> >
> maybe its a font problem? Do you see the same issue only in ffox or also
> in other apps that allow you to type things?
>
>
>
> ** Changed in: firefox-3.0 (Ubuntu)
> Status: New => Incomplete
>
> --
> Problem with showing some Lao Unicode char
> https://bugs.launchpad.net/bugs/294545
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "firefox-3.0" source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: firefox-3.0
>
>
> firefox-3.0 Problem with showing some Lao Unicode character
> Description: Ubuntu 8.10
> Release: 8.10
> firefox-3.0
>
> Hi Ubuntu team
> i'm very new for ubuntu and this is my first time reporting the bug
> I'm Lao and i found some bug with Firefox 3 On ubuntu with showing ປົ on
> web pages or text box
>
> when i type or viewing website have ົ and ປ the char ົ will show as ຍ
> firefox-3.0
> but ົ with another char is showing correctly
>
> Lao language is UTF-8 (lo)
>
> Lao(lo) = English
> ົ = q
> ປ = x
> ຍ = p
> the problem is when i type ປົກ is ( xqd ) in english the ົ will show as ຍ
>
> but when i try with another ສົກ = ( lqd ) is showing correctly
>
> Please check for this
> Thanks
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 8.10
> Package: firefox-3.0 3.0.3+nobinonly-0ubuntu2
> ProcEnviron:
>
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: firefox-3.0
> Uname: Linux 2.6.27-7-generic i686
>

Hi,

I'm quite sure that it isn't bug on Firefox but maybe Gnome itself instead. I've tried typing the mentioned keys on Ubuntu, OpenSolaris 10 they also behave the same issue but not in some applications such as OO.o

Steps to reproduce:
  1. Adding Lao language keyboard layout to your Desktop.
  2. Switch your keyboard layout language to Lao and type "xqd" (without quote) into somewhere on Firefox. ie. search box.

Expected Result:
 It should be "ປົກ" (UTF-16 code units: 0E9B 0EBB 0E81) instead of

Actual Result:
"ປຍກ" (UTF-16 code units: 0E9B 0E8D 0E81)

I'll post more details soon.

Attached screenshot of Linux version of Firefox 3.0.5

Notice the ປົກ is being displayed as ປຍກ but the key is input correctly as Google can bring ປົກ to the search result.

Another ss indicates Firefox on Windows. Searching the same keyword.

UrkoM (urko-masse) wrote :

I just verified this on Firefox 3.5.3 in Karmic.

affects: firefox-3.0 (Ubuntu) → firefox-3.5 (Ubuntu)
Changed in firefox-3.5 (Ubuntu):
status: Incomplete → Confirmed
UrkoM (urko-masse) wrote :

Typing "xqd" in OpenOffice.org in Karmic works correctly. Arora browser (QT-based) works correctly.

Firefox shows the issue. Also verified on Epiphany browser, and Gedit.

This seems to be a problem with the GTK widgets?

Attached is a screenshot of OpenOffice, Arora, GEdit, Firefox and Epiphany browser, showing the results of typing "xq" after switching to Lao keyboard layout.

Running Karmic with all updates as of today (so it's the Release Candidate).

UrkoM (urko-masse) wrote :

Nautilus is also affected.

Verified that this is "simply" a display error. Copying the text between GTK applications and OpenOffice Writer works.

Steps to reproduce:
1- Start OpenOffice.org Writer.
2- Switch keyboard layout to Lao.
3- Type "xq".
4- Select the resulting text, copy it. It should display as one character. This is correct.
5- Open GEdit.
6- Paste the text. It displays as two characters. This is incorrect.
7- Select the two characters in GEdit. Copy it.
8- Paste it into OpenOffice. It displays as one character. This is correct.

Changed in epiphany-browser (Ubuntu):
status: New → Confirmed
Changed in gedit (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. Thanks in advance!

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Changed in gedit (Ubuntu):
importance: Undecided → Low
Javier Jardón (jjardon) on 2009-11-30
Changed in firefox:
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
Javier Jardón (jjardon) on 2009-11-30
affects: firefox-3.5 (Ubuntu) → gtk+2.0 (Ubuntu)
Javier Jardón (jjardon) on 2009-11-30
Changed in gtk:
importance: Unknown → Undecided
status: Unknown → New
importance: Undecided → Unknown
status: New → Unknown
importance: Unknown → Undecided
status: Unknown → New
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus (Ubuntu):
status: Confirmed → Invalid
Changed in gedit (Ubuntu):
status: Confirmed → Invalid
Changed in epiphany-browser (Ubuntu):
status: Confirmed → Invalid
Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low

Why Villavicencio changed the status of nautilus and gedit to invalid?

This is a valid bug as I tried it on Ubuntu 9.10.

Because the bug is actually in GTK 2.0, not in Gedit and Nautilus. Gedit and
Nautilus use GTK 2.0, and the bug is in that code.

I have been too busy to react to that, but I will. But Pedro Villavicencio
is totally right.

You should be happy more people are looking at the problem. This is an
advance! :)

Urko Masse
+84-90-9088876

On Wed, Dec 9, 2009 at 21:52, Thanavorakit Kounthawatphinyo <
<email address hidden>> wrote:

> Why Villavicencio changed the status of nautilus and gedit to invalid?
>
> This is a valid bug as I tried it on Ubuntu 9.10.
>
>
> ** Attachment added: "PrtScr capture.png"
> http://launchpadlibrarian.net/36624683/PrtScr%20capture.png
>
> --
> Problem with showing some Lao Unicode char
> https://bugs.launchpad.net/bugs/294545
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I see. So it means that once GTK 2.0 got a fix, all the whole problem will be fixed too. Is that right?

Thanks for the explanation Urko!

UrkoM (urko-masse) wrote :

Yes, that's right. But to make that happen, we need to report it directly to
the GNOME project, because they take care of GTK 2.0.

I'll look into that, but you can already see how to do it here:
https://wiki.ubuntu.com/Bugs/Upstream/GNOME

It means we need to go to this website:
http://bugzilla.gnome.org/
Register an account, and report the bug there.

Let me know if you do it, so I don't do it twice.

--
Urko Masse
+84-90-9088876

On Thu, Dec 10, 2009 at 08:04, Thanavorakit Kounthawatphinyo <
<email address hidden>> wrote:

> I see. So it means that once GTK 2.0 got a fix, all the whole problem
> will be fixed too. Is that right?
>
> Thanks for the explanation Urko!
>
> --
> Problem with showing some Lao Unicode char
> https://bugs.launchpad.net/bugs/294545
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Pedro Villavicencio (pedro) wrote :

Yes, what UrkoM said is true, sorry for not adding a comment about that change but looked obvious to me, Thanks folks.

This is apparently pango's bug. Please follow up upstream bug:
  https://bugzilla.gnome.org/show_bug.cgi?id=616495

Changed in gtk:
importance: Unknown → High
status: Unknown → Fix Released
Changed in libgtk:
importance: Unknown → High
status: Unknown → Fix Released
Changed in pango:
importance: Unknown → Medium
status: Unknown → New
Changed in pango:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.