implicit pointer conversion will cause SIGSEGV

Bug #287611 reported by LaMont Jones on 2008-10-22
6
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
Medium
Unassigned
Intrepid
Medium
Unassigned

Bug Description

See the full build log at: https://lists.ubuntu.com/archives/ubuntu-autotest/2008-October/020151.html

Function `cairo_pdf_surface_create_for_stream' implicitly converted to pointer at /build/buildd/gtk+2.0-2.14.4/modules/printbackends/lpr/gtkprintbackendlpr.c:212
Function `cairo_pdf_surface_create_for_stream' implicitly converted to pointer at /build/buildd/gtk+2.0-2.14.4/modules/printbackends/lpr/gtkprintbackendlpr.c:212
Function `cairo_pdf_surface_create_for_stream' implicitly converted to pointer at /build/buildd/gtk+2.0-2.14.4/modules/printbackends/lpr/gtkprintbackendlpr.c:212

This will cause SEGVs on amd64 and other 64-bit architectures, at least from time to time.

Steve Langasek (vorlon) on 2008-10-22
Changed in gtk+2.0:
importance: Undecided → Medium
status: New → Confirmed
to be removed (liw) wrote :

I don't seem to be able to reproduce this under pbuilder (both host and pbuilder base.tgz running intrepid, amd64).

Sebastien Bacher (seb128) wrote :

confirmed and will be fixed in the next upload

Changed in gtk+2.0:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :
Martin Pitt (pitti) wrote :

Is this really a regression from hardy, or a serious bug? Are there crash reports in Launchpad, or any reproduction recipe? Right now it doesn't look SRU worthy.

Martin Pitt (pitti) wrote :

OK, trivial and obvious fix (missing #include) to go along with another SRU.

Changed in gtk+2.0:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Accepted gtk+2.0 into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package gtk+2.0 - 2.15.3-0ubuntu1

---------------
gtk+2.0 (2.15.3-0ubuntu1) jaunty; urgency=low

  * New upstream version:
    - Keyboard shortcut handling has been changed, to help with a longstanding
    complaint about the way GTK+ handles multiple layouts. GTK+ now only uses
    keys from groups other than the current group if they are not present in
    the current group. Feedback on this change is appreciated. (lp: #23244)
    - Bugs fixed:
    569336 change in gtkbutton klass is causing crash...
    569435 make maintainer-clean removes non-generated sources
    145058 Inputting "^^" requires four keystrokes on Win32...
    559408 Transparency lost when images are copied...
    359288 Toolbar items are not shown after hiding
    569918 64bit portability issue in gtkrecentchooser.c
    162726 Multiple Latin layouts in XKB break keyboard shortcuts
    569635 fontchooser should reload list of families/styles on...
  * debian/patches/071_jasper_link_fix.patch:
    - the change is in the new version

gtk+2.0 (2.15.2-0ubuntu1) jaunty; urgency=low

  * New upstream version:
    GtkAction:
    - Make toolitems pick up icon names from actions
    - Draw proxies of radio actions properly
    - Make menu proxies of recent actions work
    - Avoid accidental activations when changing actions on proxies
    - Make derived button classes work as proxies
    Input methods:
    - Avoid an assertion due to early use of input methods
    GtkScale:
    - Avoid a segfault in the marker drawing code
    GtkImageMenuItem:
    - Add a property to override the show-menu-images setting
    Bugs fixed:
    566628 gdk_display_close always asserts on win32 and quartz
    569240 Crasher when using markers
    569104 Toggle menu entries showed as check menu entries...
    322932 Always show icons on panel menus
  * debian/patches/061_use_pdf_as_default_printing_standard.patch:
    - updated to fix an implicit declaration issue (lp: #287611)

gtk+2.0 (2.15.1-0ubuntu1) jaunty; urgency=low

  * New upstream version:
    GtkFileChooser:
    - Remember the file chooser's size across invocations
    - Handle uris that are entered in the entry
    - Improve autocompletion, in particular for uris
    GtkEntry:
    - New property "im-module" for selecting input methods per-widget
    - New icon-related API got renamed for consistency
    - Added properties and setters for icon tooltips
    GtkTextView:
    - New property "im-module" for selecting input methods per-widget
    - New signal "paste-done" to allow better handling of async pasting
    GtkScale:
    - New api to add annotated marks: gtk_scale_add_mark.
    GtkAction:
    - Rework the way actions and proxies interact, to make the
      interaction less ad hoc, more extensible, and better suited
      for support in GUI builders like glade.
      To be used as a proxy, a widget must now implement the
      ` GtkActivatable interface, and GtkActivatable implementations
      are responsible for syncing their appearance with the action
      and for activating the action.
      All the widgets that are commonly used as proxies implement
      GtkActivatable now.
      This is a big change, a...

Read more...

Changed in gtk+2.0:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Anyone using the intrepid-proposed gtk version and can confirm that GNOME still works?

Martin Pitt (pitti) wrote :

Unless we can get someone to test this, I'm going to remove this from intrepid-proposed again. This has sat in -proposed for almost 300 days already.

tags: added: regression-update
Martin Pitt (pitti) wrote :

2009-09-09 09:32:17 INFO Removing candidates:
2009-09-09 09:32:17 INFO gtk+2.0 2.14.4-0ubuntu2 in intrepid
2009-09-09 09:32:17 INFO Removed-by: Martin Pitt
2009-09-09 09:32:17 INFO Comment: unverified SRU
2009-09-09 09:32:17 INFO 78 packages successfully removed.
2009-09-09 09:32:17 INFO Transaction committed.

Changed in gtk+2.0 (Ubuntu Intrepid):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers