gtkprint doesn't use the ppd default paper size

Bug #258794 reported by Julien Raeis on 2008-08-17
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Low
gtk+2.0 (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Release of Ubuntu: hardy (no proposed and no backport packages).
Version: libgtk2.0-0 - 2.12.9-3ubuntu4

When adding a printer using either the CUPS configuration interface or the system-config-printer tool, one can choose the default paper size of the printer, among several other options, depending on the driver.
An interesting consequence is that one can add multiple print queues with different configuration options, and especially different paper sizes, which can be very useful for multifunction printers (such as the Canon MPxxx series for example). These options are stored into the PPD files located in /etc/cups/ppd/.

For instance, a typical configuration, for a MFP, could be:
- one print queue for normal text printing (with A4 paper size, 600x600 dpi, colors),
- one print queue for draft text printing (A4 paper, 300x300 dpi DRAFT and grayscale),
- one print queue for photo printing (4x6 inches paper, 2400x2400 dpi, glossy photo paper, vivid colors).

The GTKPrint dialog allows the user to set several options, but not the paper size, which can be instead set on the "Page Setup" dialog, located into the "File" menu (for applications implementing GTKPrint).

The problem is that the paper size selected on the "Page Setup" dialog always overrides the default page size defined into the PPD file, and GTKPrint doesn't seem to use the paper size defined into the PPD file at all.
So, considering the default paper for the system is A4 (as for every European locales), whenever the user wants to print a photo using the associated print queue (#3 in the examples above), he has to set the paper size on the "Page Setup" dialog first.

This is counter-intuitive, since it requires the user additional steps to print a picture, while he already defined a default paper size when installing the printer.
A correct behavior would be for GTKPrint to use the default paper size set into the PPD files, while the "Page Setup" dialog would be used to *optionaly* override this setting.

The "Page Setup" dialog should also have an option to store the default settings per application ("Set as default").

Several applications are impacted by this behavior:
- evince, evolution, openoffice, eog, f-spot, etc.

Note: in hardy, f-spot doesn't even have the "Page Setup" dialog available, so it's not even possible to print photos using a MFP with "a4" as the system-wide default paper size.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, the issue is an upstream one, could you open a bug on bugzilla.gnome.org?

Changed in gtk+2.0:
importance: Undecided → Low
Changed in gtk:
status: Unknown → New
Julien Raeis (julien-raeis) wrote :

I think bug #427748 on bugzilla is directly related (if not a duplicate): http://bugzilla.gnome.org/show_bug.cgi?id=427748

Pedro Villavicencio (pedro) wrote :

thanks you for sent it upstream.

Changed in gtk+2.0:
assignee: nobody → desktop-bugs
status: New → Triaged
Changed in gtk:
importance: Unknown → Low
Changed in gtk:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.