Ubuntu

Ubuntu Browse Multiple Files dialog does not recognize capital / uppercase JPG as image

Reported by Brent Newland on 2008-04-24
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
Low
Unassigned

Bug Description

When I use Firefox to upload images (multiple), the multiple file upload box (when set to limit to images only) does not show jpeg images if the file extension is a capital or uppercase JPG. It shows others just fine.

I've seen reports of this occurring on Myspace, as well as http://www.imagebam.com/flash_upload

I believe this is an Ubuntu problem and not a Firefox problem, as the browse window should be part of Ubuntu.

The single file upload may or may not be affected by this problem - I haven't seen any websites that limit to the image filetype on single file upload.

Brent Newland (brent-newland) wrote :

I tried to reproduce this bug, it works fine on my system however. (also on the imagebam.com site) Could you give some more information about your system and maybe if you can find them some other sites on which this bug occurs so I can try to reproduce it?

Changed in firefox-3.0:
status: New → Incomplete
Brent Newland (brent-newland) wrote :

It works on any site that limits you to uploading images.

To test: create a new directory, fill it with ten images. Make SURE the file extension is .JPG (all upercase letters). Go to imagebam.com (you have to sign up for a new account or login) then choose the Multi-upload option. If you are affected, you will not see any images.

I'm running the latest 8.04 with latest firefox and all updates. Running Gnome and Nautilus (also OpenBox, but same thing). Just tested and same problem, also does it for capitalized PNG extensions (and presumably others).

I tried to test in Opera, but no flash in my opera yet (so I can't access the upload dialog).

Also happens at Myspace.com when you upload a pic to your profile.

I so far can only find flash uploads that have the image extensions for upload enabled.

I also have Flash 10 beta(alpha?).

I do not believe they are related though, because file upload dialog is exclusively through the OS and is not dependent on a website (letting a website directly access your files would be a big security risk).

I can confirm this bug on the "imagebam" site, however, this is not the case for all multiple image flash uploaders. On this site: http://www.23hq.com/photo/upload-flash, I was able to upload some .JPG and .PNG images, so I think this has to do with the site rather than Firefox or Ubuntu: they probably set up the file browser only to accept .png .jpg .gif etc. (as displayed in the allowed files box, also see the screenshots)
Therefore I will close this bug, because it is not a bug in Firefox or Ubuntu. If you believe it is, and if you have some extra information, please set the status to "Incomplete" again.

Changed in firefox-3.0:
status: Incomplete → Invalid
Brent Newland (brent-newland) wrote :

I am apparently not the only one to notice this problem:
http://brainstorm.ubuntu.com/idea/7388/

And I finally was able to get to that 23hq.com page and I noticed... that it will show all files for me, whether they are pictures or not.

Additionally, I can't replicate your screenshot1 (showing the file extensions).

Until someone can show me the code being used to get that dialog box that states "images" and limits to image types, I can't be sure that it isn't an ubuntu or firefox bug.

Changed in firefox-3.0:
status: Invalid → Incomplete

I have this problem as well using Ubuntu - Myspace and Photobucket will not recognize my .JPG files with a multiple uploader, although it will recognize them using a single file uploader. (However, Facebook, I've noticed has no problem at all with capitalized file extensions.)

I've never had a problem with this using the Windows system, which is what leads me to wonder if it actually isn't something related to Ubuntu... There are many facets to this issue (working on Facebook, while not working on Myspace, working on WIndows but not working on Linux) and I am far from a computer expert... I just wanted to post my thoughts and see if they help.

etali (etali) wrote :

Thank you for reporting this and trying to make Ubuntu better. I am unable to replicate this issue in FireFox 3.5 - does this version fix the issue for you?

etali (etali) wrote :

We'd like to solve this issue for you, but we haven't heard back from you in a while. Could you please let us know if this is still a problem for you? Thanks for taking the time to make Ubuntu better.

Steve Karg (steve-karg) wrote :

Still a problem (using Firefox 3.6.6 on Ubuntu 10.04) at Facebook.com website. I can rename the files to use lower case .jpg and then they are visible in the file dialog.

dustin (dtn25) wrote :

This is occurring on facebook. It is not a firefox, the same behavior happens in chrome. I believe the issue is in the file chooser which I think is part of nautilus. It appears someone else had this bug reported #172860 and it was closed stating it wasn't a bug. It is a bug!

affects: firefox-3.0 (Ubuntu) → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed
affects: nautilus (Ubuntu) → gtk+2.0 (Ubuntu)
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
Zambini (zambini845) wrote :

Hi All,
For anyone viewing this, you've obviously got some google skills.

I too have this same problem, using {Ubuntu 10.04, Chrome 5.0.375.86 beta, Nautilus 2.30.1}

Here is a temporary workaround to this problem, simply by re-naming all the files:
1) Open up the terminal and cd into the directory where your .JPG files are
2) Type in the following command:
---
for i in *.JPG; do mv "$i" "`basename $i .JPG `.jpg"; done
---
and hit enter. What this does is re-names all files that end in .JPG and re-names them to end with .jpg. For example:
IMG_1112.JPG gets re-named into IMG_1112.jpg

You can also use the gIMP plugin "David's Batch Processor" to do a batch re-name, but this one line command is much easier.

You can even write yourself a simple script that does this and place it into /usr/bin and chmod +x it and then you can run it just like it's a regular command.

Here's my script:
---
#!/bin/bash
for i in *.JPG; do mv "$i" "`basename $i .JPG `.jpg"; done
---
And now whenever I encounter this problem I can open up the Terminal and cd into my photos directory and then just run JPGtojpg (that's what I named it in my bin folder)

Marks Petz (ravenwyn) wrote :

I used GIMP - which automatically gave an uppercase sic - JPEG - IF GIMP gave a lower case sic - jpeg. It would save having to batch process or change individually.

I wanted to upload an image using flash plugin in facebook. It works fine with uppercase images from Windows 7. Just from Ubuntu, using firefox do I have a problem. The flash does not see the files to select. AS in when I browse to the folder I see only the lower case files to select from.

aykut (karaca-aykut) wrote :

I have exactly the same problem. It is not only firefox, chrome does the same. It must be flash. I use 10.04. Any fix that solves it forever, instead of renaming all the time?

J B (scottie) wrote :

still present on ubuntu 10.04 lucid.

specs:
nautilus file browser 2.30.1 <- not sure if this is used by firefox
flash 11.0.1.152

on both
firefox 7.0.1
chromium 15.0.874.106

i thought linux didnt depend on file extensions.
(i guess it doesnt when running a file, but it does when filtering file displays in the file manager)

tried to replicate on xubuntu 11.10, the first time i clicked on button, filter is set to 'ALL FILES' and files can be seen.
(but multiple files can't be selected, when they are expected to be selectable holding down shift <-works on windows)
only single file selectable.
clicked cancel tried again.
this time filter is set to "Images" and cant be changed.
No more images displayed. same problem.

All images have .JPG extension. which is what a lot of cameras are producing.
guess workaround is rename. but this won't be as straightforward for other users.

xubuntu file manager: thunar 1.2.3 <not sure if firefox uses this

same problem, only .jpg files are visible.

important because photos from different cameras produce .JPG

guess another workaround (but not as feasible :) ), ask everyone to only use .jpg as extension.

wouldn't it be simpler to just add .JPG to the Images filter in whatever filter the internet browsers are using?

Hein (hhanssen) wrote :

I have the very same problem on version 12.10 of Ubuntu! Does any one test Ubuntu thoroughly?

I'm using Frugalware 1.7. I had this same problem, caused by flashplugin. Removing flashplugin helped.

Some sites (iStore.pl shopping system in my case) are using flash to download multiple images simultaneously. After removing flashplugin my shop is using standard firefox/chrome browsing windows recognizing all lower- and uppercase extensions. I can't download images simultaneously, but one after another... but it works.

kernoelpanic (dev-8) wrote :

Hi,

same problem here. Firefox or chromium wont display "*.jpg" files for uploading because they search for "*.JPG". Moreover there is no switch for "All file types" so that the only solution is to rename the files:

$ find ./ -name "*.JPG" -exec rename -v .JPG .jpg "{}" \;

plz add a swicht to the gtk menu to display all filetypes! This is a good fall back in any case.

Data::::::::::::::::::::
Ubuntu 13.04
Linux 3.8.0-30-generic x86_64

Package: firefox
Architecture: amd64
Version: 23.0+build2-0ubuntu0.13.04.1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers