Ubuntu

xkb greek polytonic: cannot write psili and dasia after upgrade to breezy

Reported by Annette v. Stockhausen on 2005-09-14
16
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+2.0 (Ubuntu)
Medium
Ubuntu Desktop Bugs
libx11 (Debian)
Fix Released
Unknown
libx11 (Ubuntu)
Undecided
Colin Watson
xkeyboard-config (Ubuntu)
Undecided
Colin Watson

Bug Description

After upgrading from hoary to breezy i cannot write the polytonic greek dasia and psili (spiritus
asper and lenis) on a german keyboard. If I type shift+ö or shift+ä and a vowel afterwards
there's nothing. All other accents and hypogegrammeni work very well.

_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "de,gr,il", ",polytonic,", "grp:rwin_toggle,
grp_led:scroll"

http://bugzilla.gnome.org/show_bug.cgi?id=321896: http://bugzilla.gnome.org/show_bug.cgi?id=321896

Simos Xenitellis (simosx) wrote :

How do you write the other Greek Polytonic accents in GNOME?

See
http://bugzilla.gnome.org/show_bug.cgi?id=167940
and if you speak Greek, see
http://www.livejournal.com/users/simos74/32918.html

(In reply to comment #1)

I use X Input Method. The effect is the descripted above.

John (auxsvr) wrote :

Happened to me too on SuSE 9.3 using KDE, using polytonic greek layout typing shift+semicolon prints nothing, whereas everything else works according to the xkb symbol file pc/el. Maybe LC_CTYPE has something to do with it?

setxkbmap -model pc104 -layout us,el -variant ,polytonic -option grp:caps_toggle
LANG=en_US.UTF-8

Simos Xenitellis (simosx) wrote :

I verify that this bug exists.

What happens is that Xorg is able to send the mentioned characters, however, somewhere in both GTK+ and QT applications cannot receive them.

To verify, run an X application such as "xterm" (is there an old-style X editor around?).

Try
$ xterm -font "-bitstream-dejavu sans mono-medium-r-normal--0-0-0-0-c-0-iso10646-1"

Then, switch the keyboard to Greek Polytonic:
άὰἁἀᾷᾶὰἇῢ

I cannot figure out why some characters are excluded and other are not.

This issue is not directly related to the upstream bug report in GTK+.

Simos Xenitellis (simosx) wrote :

Some more results:

The compose file in Breezy (probably Dapper) contains "incompatible" (???) compose sequences for polytonic letters that have diacritical marks. Those "incompatible" compose sequences do not produce any characters, so as is, it is not possible to produce daseia, psili and possibly others. Not possible, either in GTK+, QT, old X apps.

If someone fixes the Compose file*, then in QT applications it is possible to type all those characters. In GTK+ applications I was not able to type them, though it is possible that some settings where cached; I did not restart my session.

Due to the upstream GTK+ bug report, for GTK+ applications one needs to set the Input Method to the X Input Method in order to use the fixed Compose file.

To "fix" the compose file, replace the existing Greek polytonic compose sequences in /usr/share/X11/locale/en_US.UTF-8/Compose
with those generated by
http://hal.csd.auth.gr/~vvas/i18n/xkb/polytonic-compose.pl

It seems to be a bug in the greek layout file in /etc/X11/xkb/symbols/gr. Following the hint in http://www.jw-stumpel.nl/stestu.html#T6.5.3 I changed the lines
key <AC10> { [ dead_acute, dead_horn ] };
key <AC11> { [ dead_grave, dead_ogonek ] };
 to
key <AC10> { [ dead_acute, U0313 ] };
key <AC11> { [ dead_grave, U0314 ] };
and writing psili and dasia is working again.

Changed in gtk:
status: Unconfirmed → In Progress
Sebastien Bacher (seb128) wrote :

Marking as Confirmed to match upstream bug, assigning to team since I'm not working on that and we will likely wait for upstream

Changed in gtk+2.0:
assignee: seb128 → desktop-bugs
importance: High → Medium
status: Unconfirmed → Confirmed
Changed in libx11:
status: Unknown → Fix Released
Colin Watson (cjwatson) wrote :

libx11 (2:1.0.3-0ubuntu5) feisty; urgency=low

  * Backport from Debian to unblock xkeyboard-config merge (and thereby
    console-setup and debian-installer; LP: #21637):
    - 019_greek_polytonic_Compose.diff (numbered 016 in Debian): Add compose
      sequences with the right breathing signs U0313/U0314 to
      el_GR.UTF-8/Compose. Thanks Jan Willem Stumpel. (closes: #386471)

 -- Colin Watson <email address hidden> Mon, 27 Nov 2006 20:00:57 +0000

Changed in libx11:
assignee: nobody → kamion
status: Unconfirmed → Fix Released
Colin Watson (cjwatson) wrote :

yboard-config (0.8-15) unstable; urgency=low

  * debian/patches/greek.diff: New patch to replace dead_horn and
    dead_ogonek by U0313/U0314, which are the correct breathing
    signs for polytonic Greek. This change can be performed now
    that an updated el_GR.UTF-8/Compose file hit testing.
    Closes: #386385 Thanks Jan Willem Stumpel.

  * debian/patches/compatibility.diff: Add compatibility rules to
    make sure that changes in symbols/pc do not cause trouble.
    Closes: #389589 Thanks Robert Bihlmeyer.

 -- Denis Barbier <email address hidden> Wed, 27 Sep 2006 23:19:39 +0200

Changed in xkeyboard-config:
status: Unconfirmed → Fix Released
assignee: nobody → kamion
Colin Watson (cjwatson) wrote :

I think this should be a lot better following the libx11 and xkeyboard-config merges above in Feisty, but I don't know enough about GTK to know if it still needs to be modified. Can anyone check, perhaps once Herd 1 is out?

Rob Caskey (rcaskey) wrote :

dead_grave doesn't seem to produce grave's properly. Used with shift it does produce another dead-keys character as expected, and it does produce a grave if used in xterm, but not in gtk apps.

Simos Xenitellis (simosx) wrote :

A patch has been applied upstream which should solve these issues.

On Tue, Mar 4, 2008 at 4:08 PM, Simos Xenitellis <email address hidden>
wrote:

> A patch has been applied upstream which should solve these issues.
>
> --
> xkb greek polytonic: cannot write psili and dasia after upgrade to breezy
> https://bugs.launchpad.net/bugs/21637
> You received this bug notification because you are a member of Ubuntu
> Greek Users, which is a direct subscriber.
>
> --
> Ubuntu-gr mailing list
> <email address hidden>
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-gr
>

--
Ηλίας Φ. Ζεέρης,
Φυσικοθεραπευτής
Ανδρομάχης 61, 176 71
Καλλιθέα Αθήνα

Simos Xenitellis (simosx) wrote :

Patch is described at
http://blogs.gnome.org/simos/2008/03/05/testing-the-updated-im-support-in-gtk/

Two new keysyms, dead_psili and dead_dasia have been added to Xorg.
xkeyboard-config has been updated with dead_psili and dead_dasia.
GTK+ has been updated to dead_psili and dead_dasia (on Trunk).

This means that Hardy should be able to type Greek polytonic (when using XIM).
The GTK+ patch will probably make it in the next version of Ubuntu.

Simos Xenitellis (simosx) wrote :

Fix has been commited in GTK+ (trunk)

Changed in gtk+2.0:
status: Confirmed → Fix Committed
Changed in gtk:
status: In Progress → Fix Released
Ilja Sidoroff (ilja-sidoroff) wrote :

There might still be some problems left in hardy. I upgraded from gutsy, where I was able to write polytonic Greek with XIM after I replaced the Compose file with a modified one. After upgrading to hardy (beta -- now up to date as of 2008-04-20) I found that I was not able to type dasia or psili anymore (with XIM, previously shift+ä and shift+ö + plus letter produced the breathings -- ä and ö being the two keys left from L in my keyboard) -- pressing them did not produce anything.

Then I modified /usr/share/X11/xkb/symbols/gr file, keys AC10 and AC11 to

  key <AC10> { [ dead_acute, dead_dasia ] }; // ´ ̓
  key <AC11> { [ dead_grave, dead_psili ] }; // `

According to a freedesktop.org bug (unfortunately I don't have the link right here, if I recall, Simos Xenitellis who also subscribes to this bug, commented/opened it.

This didn't change anything.

Then I changed dead_dasia to U0313 and dead_psili to U0314 -- Now I am able to type the breathing marks, but they don't combine with other accents -- acute is just written over the breathing, for instance.

I seems that the fixes that are in hardy are not complete. What has changed since gutsy, where I had perfect output, just after modifying the Compose file?

Ilja Sidoroff (ilja-sidoroff) wrote :

Ok. I should have checked my old modified Compose file. It seems that hardy has

/usr/share/X11/xkb/symbols/gr:

key <AC10> { [ dead_acute, dead_horn ] };
key <AC11> { [ dead_grave, dead_ogonek ] };

which I changed to

key <AC10> { [ dead_acute, U0313 ] };
key <AC11> { [ dead_grave, U0314 ] };

and in /usr/share/locale/en_US.UTF-8

has U10000313's and 010000314's instead of U0313 or U0314. I changed U1000313's and U1000314 to U0314 and got polytonic input working correctly. Let's see how the upgrades in x.org ja gtk have progressed in hardy+1

Sebastien Bacher (seb128) wrote :

the new version has been uploaded to intrepid now

Changed in gtk+2.0:
status: Fix Committed → Fix Released
iaenus (super-iaenus) wrote :

Sorry, but I not english speaker:
I solved in this way:
I didn't modificated neither Compose file neither gr file.
I had spanishlayout and installed greek polytonic, with the GUI of Gnome.
I saw the composer combination didn't work in greek
I correct /etc/environment with the line export GTK_IM_MODULE=xim
export QT_IM_MODULE=xim
I copy Composer en_US.UTF-8 to .XCompose (this archive seem to have the combination Composer of the predefinide language)
  cp /usr/share/X11/locale/en_US.UTF-8/Compose ~/.XCompose
and works.
The changes of gr file (U0313 and U0314) are not usefull, because the introduce a combinated acent, not show the real ancient greek character.
about the horrible definition of <dead_ogonek> and <dead_horn>, I tried to changed modificating (keysymdef.h). But the <dead_dasia> and <dead_psili> i think are wrong.
Please, If someboy understand me, rewrite this post correctly
Iaenus

Changed in gtk:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.