Ubuntu

[breezy] clicking on open in gedit generates gtk error

Reported by Daniel Robitaille on 2005-08-23
10
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
Low
Sebastien Bacher

Bug Description

If I start gedit from the command line then click on the "open" button, I get
this error in my xterm (but the open file dialog still appear to work normally):

daniel@home:~$ gedit

(gedit:14505): Gtk-CRITICAL **: gtk_file_system_path_is_local: assertion `path
!= NULL' failed

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Do you still have this issue with libgnomeui 2.11.4?

Daniel Robitaille (robitaille) wrote :

yes; still experiencing the bug with an updated Breezy install:

ii libgnomeui-0 2.11.4-0ubuntu1 The GNOME 2 libraries (User
Interface) - runtime files
ii libgnomeui-common 2.11.4-0ubuntu1 The GNOME 2 libraries (User
Interface) - common files
ii libgnomeui-dev 2.11.4-0ubuntu1 The GNOME 2 libraries (User
Interface) - development fil

Sebastien Bacher (seb128) wrote :

That's fixed upstream according to http://bugzilla.gnome.org/show_bug.cgi?id=310270

Fabio Marzocca (thesaltydog) wrote :

Thanks for the information, seb.
Do you think it will be sync-ed in breezy before release? It is not a major
problem, but users can get scared of those "Gtk-Critical" messages..

Sebastien Bacher (seb128) wrote :

If there is no new GTK tarball I'll patch the package for it

Fabio Marzocca (thesaltydog) wrote :

Today I have some news on this bug:

- the bug seems not to happen on a fresh Breezy installation, while it is there
on every PC dist-upgraded from Hoary.
I have checked versions of main gui libraries, and they look the same!

Daniel Robitaille (robitaille) wrote :

(In reply to comment #6)

> - the bug seems not to happen on a fresh Breezy installation, while it is there
> on every PC dist-upgraded from Hoary.
> I have checked versions of main gui libraries, and they look the same!
>

that's not what I'm experiencing: I see this problem on 2 different computers:
one was a dist-upgrade from Hoary, but the other is a laptop that received a
fresh install of Breezy using the Preview release.

Fabio Marzocca (thesaltydog) wrote :

I made following test:

- dist-upgrade to Breezy (the bug was there)
- cleared up the partition and install from COlony 4 CD
- upon finishing installation, I have upgraded packages and bug was no more there

- on another pc (laptop), I directly made a fresh installation and the bug is
not there

- on my PC at home I made an upgrade from Hoary and the bug is there.

Sebastien Bacher (seb128) wrote :

do you have any non-local bookmarks for the laptop installation?

Daniel Robitaille (robitaille) wrote :

On my laptop I don't have any bookmarks.

Sebastien Bacher (seb128) wrote :

the sourceforge comment is wrong

Sebastien Bacher (seb128) wrote :

This upload fixes the issue:

gtk+2.0 (2.8.4-0ubuntu1) breezy; urgency=low
 .
   * New upstream version:
     - fix the fileselector warnings about non-local bookmarks (Ubuntu: #14011).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.