Orientation should be an option in gnome-print dialog

Bug #196091 reported by Alex Launi on 2008-02-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Wishlist
gtk+2.0 (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
(fully updated)

The native gnome-print application is missing a critical feature: The ability to change the orientation of the paper you are printing on. Some applications such as firefox have this implemented in other places, this however is not ideal as some applications do not have it implemented at all. This is a printing issue and as such should be handled in the printing dialog rather than in an obscure menu option elsewhere.

I assume this is GtkPrint, see File>Print Setup. If it doesn't exist, it's a bug in the application.

Sebastien Bacher (seb128) wrote :

setting to wishlist, is that something really useful?

Changed in gtk+2.0:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
Alex Launi (alexlauni) wrote :

In my opinion it's a necessary feature! It's very redundant to make the application developers implement this over and over, and when they don't it's a major pain when you need to print something in a different orientation. For example the gnome keyboard layout manager, it doesn't have a file menu to switch the orientation, but it would be nicer if you could print out a big diagram of the keyboard in landscape orientation, instead one is limited by the portrait.

Sebastien Bacher (seb128) wrote :

gtkprint has an api to set the orientation, the issue might be due to applications rather

Sebastien Bacher (seb128) wrote :

There is a bug on http://bugzilla.gnome.org/show_bug.cgi?id=551726 about that too

Changed in gtk+2.0 (Ubuntu):
status: New → Triaged
Changed in gtk:
status: Unknown → New
Changed in gtk:
status: New → Invalid
Changed in gtk:
status: Invalid → New
Changed in gtk:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the issue is fixed in karmic now

Changed in gtk+2.0 (Ubuntu):
status: Triaged → Fix Released
Changed in gtk:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.