gtk apps don't behave properly after xrandr dual-screen modifications

Bug #162212 reported by Peter Zijlstra on 2007-11-12
4
Affects Status Importance Assigned to Milestone
GTK+
Expired
Medium
gtk+2.0 (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

xorg r200 driver, 2 24" dell screens @ 1920x1200

In feisty I used to use MergedFB to have two screens, in gutsy I have to use xrandr to set this up. I provide Virtual 3840 1200 in the Display section, and run xrandr --output VGA-0 --right-of DVI-0 after startup [ can't seem to get this statically configured :-( ]

Most (unfortunately not all) gtk progs, notably xchat, firefox clip their menus and popups to the left xinerama screen when the main window is on the right screen. The exception is evolution, that seems to behave correct. All QT apps (running kubuntu) also work properly.

/me tries a few more applications,...

QT/KDE -> good (konsole, amarok, konqueror)
Gnome -> good (evolution, gnome-terminal, gnometris)
GTK -> buggy (xchat, pavucontrol, firefox)
gvim -> good

Peter Zijlstra (a-p-zijlstra) wrote :

*argh*, I just figured out what this is.

Applications only load their Xinerama information at startup, and if its dynamically changed (blame xrandr) then they're stuck with it. So if I restart all applications after I change the desktop setup using xrandr all is well.

So the bug is not reloading Xinerama information on xrandr events.

Bryce Harrington (bryce) wrote :

See wiki.ubuntu.com/X/Config for an example of how to configure it statically. Or you can use Screen Resolution to set it. Or put your xrandr command line in your ~/.xsession file.

Sebastien Bacher (seb128) wrote :

the new GTK uses xrandr, could you try if that's still an issue in intrepid?

Changed in gtk+2.0:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Incomplete
rubberglove (infinite-nwar) wrote :

Nice! I just tested it under intrepid, and it seems to have solved this issue for me.
This has been a minor, but persistent irritation for me for the past year of so.

I use XrandR to turn my s-video output on/off (to let my son watch tv/movies while I work), and each time would mess up my firefox menus.

Hardly a big deal, but this will push me to upgrade to intrepid sooner rather than later.

Sebastien Bacher (seb128) wrote :

closing the bug since that works correctly in intrepid

Changed in gtk+2.0:
status: Incomplete → Fix Released
rubberglove (infinite-nwar) wrote :

I think spoke too soon. Now that I've been running intrepid for a while, I still see the broken behaviour, especially with firefox and thunderbird.

In firefox, *some* dropdown menus will appear shifted from their correct location (testing it as I type this, the file/edit/tools/etc menus are correctly placed, as are the dropdowns for the addressbar and searchbar. However, dropdown menus from the 'status' area at the bottom of the window are incorrectly placed -- right-clicking on the noscript icon, for example).

thunderbird becomes mostly unusable for me, and must be relaunched after changing the screen configuration. As with firefox, some dropdowns work properly (file/edit/view/etc menus), but clicking on folders or messages has no effect (nor does tying to scroll in either of those two panes).

Changed in gtk+2.0:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

could somebody having a dual screen configuration take the issue upstream where it should be discussed?

Changed in gtk+2.0:
status: Confirmed → Incomplete
rubberglove (infinite-nwar) wrote :

Since this bug is still 'bugging' me, I can report it somewhere else -- where would be the most appropriate place?
bugs.freedesktop.org?
bugzilla.gnome.org?

Sebastien Bacher (seb128) wrote :

you can open a bug against gtk on bugzilla.gnome.org

Pedro Villavicencio (pedro) wrote :

did you reported it upstream? may you tell us the bug number?

rubberglove (infinite-nwar) wrote :

I just reported it here: http://bugzilla.gnome.org/show_bug.cgi?id=561583

Note, the problem seems to be getting better in general. I'm not sure if it is due to updates, or just the fact that I recently added the https://launchpad.net/~fta/+archive PPA (which has the firefox 3.1 and the latest xulrunner, etc), but firefox now seems to work correctly, and thunderbird will work after a screen resolution change once it has been minimized/restored (previously, I had to restart it altogether).

Pedro Villavicencio (pedro) wrote :

Thanks you, linking the report.

Changed in gtk+2.0:
status: Incomplete → Triaged
Changed in gtk:
status: Unknown → New
Changed in gtk:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

the issue should be fixed in jaunty

Changed in gtk+2.0 (Ubuntu):
status: Triaged → Fix Released
Changed in gtk:
importance: Unknown → Medium
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.