Evince hangs on showing print dialog

Bug #156647 reported by Alexander Hunziker
34
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+2.0 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: evince

since the updates on 22nd and/or 23rd october, i cannot print using evince anymore (other applications work). evince simply hangs upon showing the print dialog, but doesn't print any error message to the terminal, nor actually crashes.

ProblemType: Bug
Architecture: i386
Date: Wed Oct 24 13:40:20 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/evince
Package: evince 2.20.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: evince file:///home/hunzikea/Desktop/temp/saturationmeasure.pdf
ProcCwd: /home/hunzikea
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_CH.UTF-8
 SHELL=/bin/bash
SourcePackage: evince
Uname: Linux AlexT60 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Revision history for this message
Alexander Hunziker (alex-hunziker) wrote :
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to run evince from gdb with the following instructions http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report, to see what's going on there. This will greatly help us in tracking down your problem.

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Revision history for this message
Alexander Hunziker (alex-hunziker) wrote :

As evince "just" hangs, not crashes, i had to press "ctrl" to get a gdb prompt, i hope the results are still okay, otherwise complain.

Revision history for this message
Alexander Hunziker (alex-hunziker) wrote :

It somehow works again. I don't know what's different now. I don't think there have been any relevant updates, have there? And I had tried to reboot my machine the other day. Anyway, put this on hold and close if I don't complain again.

Revision history for this message
Chris Conway (cconway) wrote :

I am also having this issue. Attached is a backtrace with debug symbols from libgtk. Beyond that, I can trace the problem... It looks like the crash may be cause be the current default printer being unavailable. I.e., I printed at home, then went to work, then evince started crashing; maybe it's trying to connect to my home printer?

Revision history for this message
jan-teichmann (teichmann-jan) wrote :

same problem:

Revision history for this message
jan-teichmann (teichmann-jan) wrote :
Revision history for this message
oleibrock (oliver-leibrock) wrote :

I have the same issue. Sorry can't estimate for how long, but it worked after the upgrade to Hardy 8.04. For me it is regardless which is the default printer. The menue does not appear and the whole application hang.

I am running the following kernel:
Linux 2.6.24-19-generic #1 SMP Fri Jul 11 23:41:49 UTC 2008 i686 GNU/Linux
on a Acer Laptop.

Revision history for this message
Pedro Villavicencio (pedro) wrote :

latest backtrace looks similar to bug http://bugzilla.gnome.org/show_bug.cgi?id=508905 ; reassigning to the right component (gtk+) thanks for reporting.

Changed in evince:
status: Incomplete → Triaged
Changed in gtk:
status: Unknown → New
Revision history for this message
lafontaj (lafontaj) wrote :

Description:Recently without change on my side, Evince hang when the printing dialog box opened.

Context: My portable computer is connect to my home network and i print throught the network to a remote printer share on a usb port on my other computer. The printer computer is sometimes running Ubuntu 8.04 and some time for the kid's games windows xp.

I setup 2 differents remote printer on my portable to be able to print. A IPP setup when ubuntu is running and a samba setup when windows is running.

When the printer's computer is up running windows, the ipp connection is not available so i thinks evince is trying to reach that printer connection thats why its hang...

So i notice that there is no "timeout" parameters in the cups cupsd.conf. I just add one to see what it will do. i had "timeout=3"

I restart /etc/init.d/cupsys restart

All my problems disappear.

Do i'm wrong? I'm a novice in Linux 6 months only and french speaking.

Revision history for this message
oleibrock (oliver-leibrock) wrote :

Hi all,

I fxed my issue after I repaired my /etc/hosts. I had a wrong entry for loopback device in it.

Thanks
 Oliver

Changed in gtk:
status: New → Invalid
Changed in gtk:
status: Invalid → Confirmed
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

This is a known problem, but unfortunately Mike Sweet, author of CUPS, is refusing to provide a solution from the CUPS side, and the GTK upstream bug does not show any move in the last two years.

Revision history for this message
Anakin Starkiller (sunrider) wrote :

And isn't there any workaround ? Can't we use an alternative printing server ?

Revision history for this message
Anakin Starkiller (sunrider) wrote :
Revision history for this message
Anakin Starkiller (sunrider) wrote :

So I've done some more testing. It appears that when I'm on same local network, the hang only lasts for a few seconds (still annoying though). It freezes when the computer with cups server is shutdown but not when the ipp printer is switch off.
But on my laptop, when I connect somewhere else, and I want to print something on another printer (a local one for example), juste because I have some IPP printers in my printers list, it hangs completely...

Revision history for this message
Anakin Starkiller (sunrider) wrote :

As indicated there http://bugzilla.gnome.org/show_bug.cgi?id=424041, I've tried to choose HTTPS IPP option, but this option is not present in CUPS with Jaunty....

Changed in gtk:
status: Confirmed → Fix Released
Changed in gtk:
importance: Unknown → Medium
Revision history for this message
Thomas Hotz (thotz-deactivatedaccount) wrote :

Is this still an issue for you? Which Ubuntu version do you use? Thank you for telling us!

Changed in gtk+2.0 (Ubuntu):
status: Triaged → Incomplete
Changed in gtk+2.0 (Ubuntu):
status: Incomplete → Confirmed
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.