libgtk2.0-dev needs dependencies fails to install

Bug #145786 reported by herbster on 2007-09-27
2
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: libgtk2.0-dev

I am trying to build the program "nitrogen" from source, for use with Openbox. During ./configure, it gives an error indicating it needs libgtk2.0-dev. I have posted a thread on ubuntuforums.org to no avail of solution (http://ubuntuforums.org/showthread.php?p=3436462). Here's what I'm getting:

bobby:~$ sudo apt-get install libgtk2.0-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help resolve the situation:

The following packages have unmet dependencies:
  libgtk2.0-dev: Depends: libpango1.0-dev (>= 1.12) but it is not going to be installed
                 Depends: libcairo2-dev (>= 1.2.0) but it is not going to be installed
E: Broken packages
bobby:~$
------------------------------------

Now if I do apt-get install libcairo2-dev, I get this:

bobby:~$ sudo apt-get install libcairo2-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help resolve the situation:

The following packages have unmet dependencies:
  libcairo2-dev: Depends: libcairo2 (= 1.4.2-0ubuntu1) but 1.4.10-1turner3~feisty0.1 is to be installed
E: Broken packages
bobby:~$
-------------------------------------------------

Here's my sources.list: http://pastebin.ca/717698

I apologize in advance as I'm a total newbie to this site and bug process, so If there is a solution that my googling didn't provide that would be great.

Sebastien Bacher (seb128) wrote :

Thanks for your comments. This does not appear to be a bug report as such. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. http://launchpad.net/support. Your log mentions that you have installed a 1.4.10-1turner3~feisty0.1 libcairo version which is creating your issue, that's not an Ubuntu version so not a bug. We recommend to not install unofficial packages if you want to avoid such issues

Changed in gtk+2.0:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers