Ubuntu

volume is set to zero when changed in fullscreen mode

Reported by SebastienBarthelemy on 2007-09-03
88
This bug affects 8 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
Totem
Fix Released
Medium
gtk+2.0 (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

Hello

I have a small problem using totem in Ubuntu Gutsy.
I use totem-gstreamer version 2.19.90-0ubuntu3.

When you click the volume button in window mode, a slider appears, with the cursor position set according to the current volume level. It's ok.

In fullscreen mode, when you click the volume button, _the volume is set to zero_ and the slider appears, with the cursor at the bottom of the slider (this is consistent, as the volume level is now zero. But why is this happening ?)
You can then move the cursor to the position you want.

Related branches

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Confirmed here with Gutsy.

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Pedro Villavicencio (pedro) wrote :

known upstream you can track it here: http://bugzilla.gnome.org/show_bug.cgi?id=461944

Changed in totem:
status: Unknown → New
Nicholas (drkoljan) wrote :

I was going to report this, it's extremely annoying.

Still present in Ubuntu 8.04

Still present in Intrepid.
It's also reproducible in windowed mode: Set volume to max, move the totem window to the bottom of the screen, click the volume button.

snifer@snifer-laptop:~$ dpkg -l | grep totem
ii libtotem-plparser12 2.23.3-0ubuntu1 Totem Playlist Parser library - runtime vers
ii totem 2.23.4-0ubuntu2 A simple media player for the GNOME desktop
ii totem-common 2.23.4-0ubuntu2 Data files for the Totem media player
ii totem-gstreamer 2.23.4-0ubuntu2 A simple media player for the GNOME desktop
ii totem-mozilla 2.23.4-0ubuntu2 Totem Mozilla plugin
ii totem-plugins 2.23.4-0ubuntu2 Plugins for the Totem media player

Tom (tom6) wrote :

I like this way of quickly muting the sound when the phone goes or something. Also you don't need to see the slider to adjust the volume, and that's great for me too.

All i do is use the mouse wheel when the mouse arrow is over the speaker/volume icon. Ideally i'd like the mouse wheel to change the volume where-ever the arrow is on the screen.

Vall-k (nv-vallcanera) wrote :

I'm using the 8.10 version and have the same problem

Andrei Buneyeu (yankeppey) wrote :

I have the same problem in Ubuntu 8.10.
Tom, thanks for advice, do you think it is feature, not bug?
I don`t understand why can`t developers fix so simple bug since Gutsy?

KEIII (cashagent) wrote :

I have the same problem in Ubuntu 9.04 RC :)

hrustov (hrustov) wrote :

waiting for working patch to be commited in upstream

Nameless (nameless-oleco) wrote :

This problem still exists in Ubuntu 9.04 Final :(

Changed in hundredpapercuts:
status: New → Confirmed

This bug has been fixed upstream (see the linked upstream bug report) and is now in the master branch and the gtk-2-16 branch of gtk+2.0

http://git.gnome.org/cgit/gtk+/commit/?id=b436f5b8a3c8ad0468d2420895fa97dc7c711969

I've applied the patch against Jaunty's gtk+2.0 (gtk+2.0_2.16.1-0ubuntu2) and the issue is resolved for me. Clicking the volume icon now only opens the slider, but doesn't adjust the volume.

Changed in hundredpapercuts:
milestone: none → round-7
status: Confirmed → Fix Committed
Changed in gtk+2.0 (Ubuntu):
status: Triaged → Fix Committed
Changed in hundredpapercuts:
milestone: round-7 → round-1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.17.3-0ubuntu1

---------------
gtk+2.0 (2.17.3-0ubuntu1) karmic; urgency=low

  * New upstream version:
    GtkFileChooser:
    - Shows the size column by default now
    GtkStatusIcon:
    - Has a title property, which can be used by ATs when they read status icons
    GtkInfoBar:
    - The default theme now includes color definitions for infobars
    - The ::use-tooltip-style style property has been removed
    GtkMountOperation now supports interaction during unmount operations.
    The client-side windows branch has been merged; GDK now maintains
    its own window hierarchy client-side, and only uses X windows where
    unavoidable. Some of the benefits of this change are
    - Reduced flicker
    - The ability to do transformed and animated rendering of widgets
    - Easier embedding of GTK+ widgets e.g. into Clutter scene graphs
      This is a fundamental change to the way GDK works,
      so watch out for regressions.
    Bugs fixed:
    586315 Crash in GTK+ 2.14 when calling gtk.FileChooser.list_shor...
    461944 pressing the volume icon in full screen shuts down the sound
    (lp: #137041)
    490724 iconview item's height would be changed event with same m...
    564063 regression: Left margin in popup menus
    582025 Accelerators fail for submenus
    585626 Setting widget tooltip hammers X11 server on any TCP/IP X...
    (lp: #386199)
    585802 Add API to make GtkStatusIcon accessible with a name
    585858 right-click Add-to-Booksmarks is sometimes greyed out
    586330 GtkButton ignores user_underline when an image is set
    318807 Offscreen windows and window redirection
    587716 GtkInfoBar broken on resize
    587485 GMountOperation::show-processes support
    Updated translations
  * debian/control.in:
    - updated libglib requirement
  * debian/patches/090_directfb_csw_build.patch:
    - new patch from Cody Russel to fix the directfb build
  * debian/patches/091_directfb_build_workaround.patch:
    - workaround build issue
  * debian/rules:
    - updated shlibs version

 -- Sebastien Bacher <email address hidden> Thu, 09 Jul 2009 17:15:04 +0200

Changed in gtk+2.0 (Ubuntu):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
IKT (ikt) wrote :

Is it possible to consider not having the volume bar going vertical, but having it going horizontal like a majority of other media players?

IKT, you have to open a wishlist request if you want to propose this.

Changed in totem:
status: New → Fix Released

heheh, but now it is set to 0% when starting totem :D

Changed in totem:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.