GtkFileChooser crashes due to a signal connection left behind by GtkMountOperation

Bug #1316509 reported by Simon Steinbeiß on 2014-05-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
gtk+2.0 (Ubuntu)
High
Unassigned
Trusty
High
Unassigned

Bug Description

Note: This bug has been reported upstream and also fixed (the patch attached is from the upstream bugreport).

[Impact]
 * Unmounting/ejecting a volume can lead to crashes/segfaults.
 * This bug is quite critical for users of Xubuntu and Ubuntu Studio, as it affects the file-manager Thunar, which is still Gtk2. (The problem occurs when users unmount a volume.)
 * A detailed description/explanation of the patch is included in the upstream bugreport.

[Test Case]
 * Test-case from the upstream bugreport
1
. The system has a volume (partition, connected USB stick, whatever else) that
is not mounted at the moment.
2. Launch smplayer (the bug may trigger with other apps as well).
3. Select "Open" => "File...". The dialog appears.
4. Click on the volume label in the dialog for the volume to be mounted.
5. Select a file on the volume.
6. Click "Open".
 * Our users have also reported frequently that unmounting/ejecting of network drives can cause this problem. Thunar only segfaults/hangs on quitting.

[Regression Potential]
 * Practically zero, as the patch only removes a signal connection.
 * This will obviously only affect distros/desktops that rely on Gtk2.

[Other Info]
 * Upstream, this patch has only been merged into Gtk3, but it also applies in Gtk2. As Gtk2 is crucial for some members of the Ubuntu family (namely Xubuntu and Ubuntu Studio), we need this patch for Gtk2 as well.
 * This bug is one of the most frequently reported ones on Xubuntu's bugtracker. Obviously most users filed it against our file-manager (which exposes the bug), e.g. https://bugs.launchpad.net/ubuntu/+source/thunar/+bug/1203296

Simon Steinbeiß (ochosi) wrote :
description: updated
description: updated
Changed in gtk:
importance: Unknown → Medium
status: Unknown → Fix Released
Alistair Buxton (a-j-buxton) wrote :

This backports the full commit from Gtk3 upstream, which also fixes a closely related memory leak.

The fixed Gtk prevents Thunar from crashing for me.

Simon Steinbeiß (ochosi) wrote :

I tested the packages from the PPA and unmounting/ejecting devices works again as it should (while it was consistently crashing Thunar before).

Elfy (elfy) wrote :

I too tested this PPA in Trusty and confirm that unmounting/ejecting devices now works as it should do.

amigamagic (debianmaverick) wrote :

I tried the patch me too in Trusty and now the mounting/unmounting of usb devices works well.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks, sponsored the SRU

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress

Hello Simon, or anyone else affected,

Accepted gtk+2.0 into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gtk+2.0/2.24.23-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gtk+2.0 (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
Changed in gtk+2.0 (Ubuntu):
status: In Progress → Triaged
Changed in gtk+2.0 (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Simon Steinbeiß (ochosi) wrote :

Hi Brian,
I've been testing gtk+2.0 (Version 2.24.23-0ubuntu1.1) for a few days now and it's working fine. Thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.24.23-0ubuntu1.1

---------------
gtk+2.0 (2.24.23-0ubuntu1.1) trusty; urgency=medium

  * Backport GtkMountOperation signal fix (LP: #1316509)
 -- Alistair Buxton <email address hidden> Tue, 06 May 2014 12:28:57 +0100

Changed in gtk+2.0 (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gtk+2.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.24.23-0ubuntu1.1

---------------
gtk+2.0 (2.24.23-0ubuntu1.1) trusty; urgency=medium

  * Backport GtkMountOperation signal fix (LP: #1316509)
 -- Alistair Buxton <email address hidden> Tue, 06 May 2014 12:28:57 +0100

Changed in gtk+2.0 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.