[gutsy] Places->Recent documents does not reflect the content of $HOME/.recently-used.xbel

Bug #131266 reported by Miguel Martinez on 2007-08-09
2
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
Medium
gnome-panel (Fedora)
Fix Released
Medium
gtk+2.0 (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Symptom:
  Places->Recent documents does not update even though one opens several files of different MIME types. This means that if one clears recent documents, it will reman grayed out.

Reproducibility:
  Near 100% on my system, in various languages, although not everybody suffers this bug:

Possible causes:
  As $HOME/.recently-used.xbel is being updated all the time, it is possible that gnome-panel (I'm not sure it's this package) is not reading or parsing properly $HOME/.recently-used.xbel.

What has been attempted:
  I've deleted a remnant .recently-used on my $HOME to see if this was the culprit, but it seems it wasn't. I've also installed more language packs to see if this was a language pack issue. So far I've seen the same in Spanish (Spain), Basque (Spain), English (US) and English (UK).
  I've also made a symlink called .recently-used pointing to .recently-used.xbel to see if the issue was that gnome-panel was reading the old .recently-used instead of the updated .xbel one. It seems it didn't help.
  I'm now trying to see if the issue lies with the existance of two .recently* files.

Related branches

Description of problem:
Recent Documents doesn't work.

Version-Release number of selected component (if applicable):
2.19.5-5.fc8

How reproducible:
always

Steps to Reproduce:
1. opne a text file with gedit.
2. close gedit
3. Click Location on panel.

Actual results:

Expected results:

Additional info:
gtk2-2.11.6-5.fc8

Sebastien Bacher (seb128) wrote :

Thank you for your bug. That's known upstream, http://bugzilla.gnome.org/show_bug.cgi?id=463907

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Changed in gnome-panel:
status: Unknown → New

seems to work for me.

Do you have a ~/.recently-used.xbel file? If so, can you attach it?

Created attachment 161318
~/.recently-used.xbel

(In reply to comment #1)
> seems to work for me.
>
> Do you have a ~/.recently-used.xbel file?
Yes.

$rpm -q gnome-panel
gnome-panel-2.19.6-1.fc8
This problem still happens in recent rawhide (20070814).

Changed in gnome-panel:
status: New → Confirmed
Changed in gnome-panel:
status: Unknown → In Progress
Sebastien Bacher (seb128) wrote :

The bug has been fixed upstream now

Changed in gnome-panel:
status: Triaged → Fix Committed
Changed in gnome-panel:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :
Download full text (5.4 KiB)

gtk+2.0 (2.12.0-0ubuntu1) gutsy; urgency=low

  * New upstream version:
    GtkTooltips
    - All widgets have been ported to the new tooltips code
    - Tooltips are disabled in touchscreen mode
    GtkBuilder
    - Support custom tabs in GtkPrintUnixDialog
    Bugs fixed:
    - 459561 critical warnings with custom tooltips
    - 461648 GdkWindowQueueItem::serial overflow
    - 463773 Openoffice and flash run into a deadlock when used with KDE
    - 468801 thunar segfaults when selecting targa image (LP: #127574)
    - 473441 [patch] Ungrab windows when gdk_window_destroy() is calle...
    - 473954 gnome-background-properties: crash on drag-n-drop to "Add...
      (LP: #128931)
    - 461945 totem outputs errors in terminal (LP: #129438, #130329)
    - 348493 _gdk_quartz_copy_to_image needs implementing for pixmaps
    - 405868 Missing implementation of gdk_window_get_geometry()
    - 441219 Do not allow moving cursor to separators
    - 447214 rename the tips_data_list field back
    - 451202 New tooltips API has too long default timeout (LP: #133919)
    - 451397 Use new tooltip API in gtk+
    - 452225 check and option mark drawing is a mess of inconsistency
    - 457642 tooltips on notebook's tab labels
    - 458088 Improve mouse cursor for paned widgets
    - 458102 GtkScrolledWindow doesn't redraw when gtk-scrolled-window...
    - 458280 remove set-toolip handler from menutoolbutton
    - 458298 broken cursor movement with inline selection
    - 459459 Missing implementation of gdk_window_set_decorations() an...
    - 459515 gtk_menu_key_press() buglets
    - 459566 update testtooltips
    - 459667 Missing implementation of gdk_window_set_keep_above and g...
    - 460272 GtkFrame publishes incorrect defaults for "label-xalign"
    - 460534 No expose events if input swamps main loop with scrolled ...
    - 461225 gtk_tree_view_set_tooltip_cell() documentation: cell
     -463907 'Recent Documents' is broken in gnome-panel 2.19.5 (LP: #131266)
     -464528 gdk_rectangle_union() and gdk_rectangle_intersect() shoul...
    - 465039 "keynav-failed" signal not emitted when treeview has just...
    - 467003 tooltips do not pick up theme changes
    - 467117 Documentation for the GtkPaned key binding signals
    - 467414 gtkcupsutil.c won't build with cups 1.3
    - 468055 Incorrect compose mapping for capital U with macron (LP: #113721)
    - 468245 Tooltip timer doesn't get reset when mouse leaves into ot...
      (LP: #135076)
    - 469214 Recently used blocks side-panel browsing until loaded
    - 469374 menu accelerators don't work
    - 469395 make dist failure
    - 471132 Highlighting a suggestion with the keyboard changes the U...
      (LP: #134304)
    - 471215 Cursor drawing broken
    - 472974 gtk-builder-convert doesn't set correctly the tab label f...
    - 472981 make gtk-builder-convert not remove some empty properties
    - 356630 Print to file dialog suggests "output.pdf" even for ps ou...
    - 447883 PATCH Documentation about SVN in HACKING and README.cvs-c...
    - 459340 GtkContainer API documentation refers deprecated gtk_widg...
    - 459732 build system: cups detection with only cups-config might ...
    - 460207 there a...

Read more...

Changed in gtk+2.0:
status: Fix Committed → Fix Released
Miguel Martinez (el-quark) wrote :

That's a huge list of changes. Thanks for the upload, the issue seems to be corrected (I've only tested for a few minutes)

Changed in gnome-panel:
status: In Progress → Fix Released
Changed in gnome-panel:
importance: Unknown → Medium
Changed in gnome-panel (Fedora):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.