gnome-background-properties: crash on drag-n-drop to "Add Wallpaper"

Bug #128931 reported by Sebastian Xavier on 2007-07-28
4
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Critical
gtk+2.0 (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-control-center

Right click desktop...
"Change Desktop Background"
"Add Wallpaper"
The Places sidepanel does not show mounted HD volumes, with the exception of "Filesystem".
Drag a disk volume icon from the desktop over to the Places sidepanel.
A window pops up saying "Could not add a bookmark" followed by unintelligible symbols.
The "Add Wallpaper" and "Desktop Background Preferences" dialogs disappear completely. (program crashes)

This behavior is different than with other GTK2 Open File dialogs, for example in Gedit, dragging the disk icon adds a new - but invalid - entry to the bookmarks. It can't be accessed, but at least doesn't crash the application.

Related branches

Wousser (wousser) wrote :

Confirmed
GNOME gnome-background-properties 2.18.1

Changed in gnome-control-center:
status: New → Incomplete
status: Incomplete → Confirmed
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-control-center:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Incomplete
Sebastian Xavier (zabeus) wrote :

Here you go. It says there are no debugging symbols, but the output contained a very descriptive error message from GLib, so it should help.

Pedro Villavicencio (pedro) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, the trace isn't good, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in gnome-control-center:
status: Incomplete → Invalid
Sebastian Xavier (zabeus) wrote :

Eh, why can't whomever goes about fixing the bug make their own backtrace?
I'll try duplicating the steps described again to include debugging symbols.

The bug has been confirmed by others, however.

Sebastien Bacher (seb128) wrote :

Confirmed and looks like a GTK bug

Changed in gnome-control-center:
status: Invalid → Triaged
Changed in gtk:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

The bug has been fixed upstream now

Changed in gtk+2.0:
status: Triaged → Fix Committed
Changed in gtk:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :
Download full text (5.4 KiB)

gtk+2.0 (2.12.0-0ubuntu1) gutsy; urgency=low

  * New upstream version:
    GtkTooltips
    - All widgets have been ported to the new tooltips code
    - Tooltips are disabled in touchscreen mode
    GtkBuilder
    - Support custom tabs in GtkPrintUnixDialog
    Bugs fixed:
    - 459561 critical warnings with custom tooltips
    - 461648 GdkWindowQueueItem::serial overflow
    - 463773 Openoffice and flash run into a deadlock when used with KDE
    - 468801 thunar segfaults when selecting targa image (LP: #127574)
    - 473441 [patch] Ungrab windows when gdk_window_destroy() is calle...
    - 473954 gnome-background-properties: crash on drag-n-drop to "Add...
      (LP: #128931)
    - 461945 totem outputs errors in terminal (LP: #129438, #130329)
    - 348493 _gdk_quartz_copy_to_image needs implementing for pixmaps
    - 405868 Missing implementation of gdk_window_get_geometry()
    - 441219 Do not allow moving cursor to separators
    - 447214 rename the tips_data_list field back
    - 451202 New tooltips API has too long default timeout (LP: #133919)
    - 451397 Use new tooltip API in gtk+
    - 452225 check and option mark drawing is a mess of inconsistency
    - 457642 tooltips on notebook's tab labels
    - 458088 Improve mouse cursor for paned widgets
    - 458102 GtkScrolledWindow doesn't redraw when gtk-scrolled-window...
    - 458280 remove set-toolip handler from menutoolbutton
    - 458298 broken cursor movement with inline selection
    - 459459 Missing implementation of gdk_window_set_decorations() an...
    - 459515 gtk_menu_key_press() buglets
    - 459566 update testtooltips
    - 459667 Missing implementation of gdk_window_set_keep_above and g...
    - 460272 GtkFrame publishes incorrect defaults for "label-xalign"
    - 460534 No expose events if input swamps main loop with scrolled ...
    - 461225 gtk_tree_view_set_tooltip_cell() documentation: cell
     -463907 'Recent Documents' is broken in gnome-panel 2.19.5 (LP: #131266)
     -464528 gdk_rectangle_union() and gdk_rectangle_intersect() shoul...
    - 465039 "keynav-failed" signal not emitted when treeview has just...
    - 467003 tooltips do not pick up theme changes
    - 467117 Documentation for the GtkPaned key binding signals
    - 467414 gtkcupsutil.c won't build with cups 1.3
    - 468055 Incorrect compose mapping for capital U with macron (LP: #113721)
    - 468245 Tooltip timer doesn't get reset when mouse leaves into ot...
      (LP: #135076)
    - 469214 Recently used blocks side-panel browsing until loaded
    - 469374 menu accelerators don't work
    - 469395 make dist failure
    - 471132 Highlighting a suggestion with the keyboard changes the U...
      (LP: #134304)
    - 471215 Cursor drawing broken
    - 472974 gtk-builder-convert doesn't set correctly the tab label f...
    - 472981 make gtk-builder-convert not remove some empty properties
    - 356630 Print to file dialog suggests "output.pdf" even for ps ou...
    - 447883 PATCH Documentation about SVN in HACKING and README.cvs-c...
    - 459340 GtkContainer API documentation refers deprecated gtk_widg...
    - 459732 build system: cups detection with only cups-config might ...
    - 460207 there a...

Read more...

Changed in gtk+2.0:
status: Fix Committed → Fix Released
Changed in gtk:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.