Printing to raw queues (without PPD) does not work

Bug #107425 reported by M Lucius on 2007-04-18
12
Affects Status Importance Assigned to Milestone
CUPS
Fix Released
Medium
gtk+2.0 (Ubuntu)
Medium
Pascal De Vuyst

Bug Description

Binary package hint: evince

unable to print

gnome-termimal console

(evince:6543): Gtk-WARNING **: Unsupported unit

(evince:6543): Gtk-WARNING **: Unsupported unit

twice per print job

ProblemType: Bug
Architecture: i386
Date: Wed Apr 18 10:16:44 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/evince
Package: evince 0.8.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: evince B-50_51-detailboek.pdf
ProcCwd: /home/marcel/werk/scan
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=nl_NL.UTF-8
 LANGUAGE=nl_NL:nl
SourcePackage: evince
Uname: Linux ws016marcel 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

M Lucius (marcel-lucius) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug. Does printing from other applications work correctly? Could you try with gtk-demo?

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Markus Kolb (mkolb) wrote :

I think and got told from Bug #66379 that I've the problem, too.
I've no problem with other applications so far and I remember the problem already existed in Dapper.
In which package is the gtk-demo stuff?

ii evince 0.8.1-0ubuntu1

== System information ==
Release : Ubuntu 7.04 (feisty)
Architecture : i686
Kernel : 2.6.20-15-generic
Locale : LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8, LC_PAPER=de_DE.UTF-8
/etc/papersize: a4

== Configured printers ==
device for Queue: ipp://192.168.0.130/printers/tp0

== Versions of important printing packages ==
ii cupsys 1.2.8-0ubuntu8 Common UNIX Printing System(tm) - server
ii cupsys-driver-gutenprint 5.0.0.99.1-0ubuntu2 printer drivers for CUPS
ii foomatic-db 20070327-0ubuntu1 OpenPrinting printer support - database
ii foomatic-db-engine 3.0.2-20070303-0ubuntu1 OpenPrinting printer support - programs
ii foomatic-db-gimp-print 5.0.0.99.1-0ubuntu2 OpenPrinting printer support - database for
ii foomatic-db-gutenprint 5.0.0.99.1-0ubuntu2 OpenPrinting printer support - database for
ii foomatic-filters 3.0.2-20070323-0ubuntu1 OpenPrinting printer support - filters
ii gs-common 0.3.11ubuntu1 Common files for different Ghostscript relea
ii gs-esp 8.15.4.dfsg.1-0ubuntu1 The Ghostscript PostScript interpreter - ESP
ii gs-esp-x 8.15.4.dfsg.1-0ubuntu1 The Ghostscript PostScript interpreter - ESP
ii ijsgutenprint 5.0.0.99.1-0ubuntu2 inkjet server - Ghostscript driver for Guten
ii libgnomeprint2.2-0 2.18.0-0ubuntu1 The GNOME 2.2 print architecture - runtime f

Created with printingbuginfo script v1.4 (https://wiki.ubuntu.com/PrintingBugInfoScript)
Tue, 01 May 2007 16:51:30 +0200

-----------

127.0.0.1 localhost.localdomain localhost menteth

# The following lines are desirable for IPv6 capable hosts
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

M Lucius,
Can you attach the output of the printingbug info script. The printingbug info script can be found here: https://wiki.ubuntu.com/PrintingBugInfoScript.

>In which package is the gtk-demo stuff?
The gtk-demo binary is part of the gtk2.0-examples package.

Please confirm if the following workaround solves your problem:
$ lpstat -v
device for x: ...
$ touch /etc/cups/ppd/x.ppd
Don't forget to replace the x by your printer name!

here the output

 Pascal De Vuyst said on 2007-05-12: (permalink)

Please confirm if the following workaround solves your problem:
$ lpstat -v
device for x: ...
$ touch /etc/cups/ppd/x.ppd
Don't forget to replace the x by your printer name!

I can confirm that this workaround does not solve the problem.
here is the printingbuginfo:

== System information ==
Ubuntu Release : 7.04 (feisty)
Desktop Environment: none
Architecture : i686
Kernel : 2.6.20-15-generic
Locale : LANG=en_ZA.UTF-8, LC_CTYPE=en_ZA.UTF-8, LC_PAPER=en_ZA.UTF-8
/etc/papersize : a4

== Configured printers ==
GaryColor: HP Color LaserJet 3800 Postscript (recommended)
hp3380: HP LaserJet 3380 Postscript (recommended)
device for GaryColor: socket://10.0.0.50
device for hp3380: ipp://10.0.0.2/printers/hp3380

== Installed versions of important printing packages ==
ii cupsys 1.2.8-0ubuntu8 Common UNIX Printing System(tm) - server
ii cupsys-driver-gutenprint 5.0.0.99.1-0ubuntu2 printer drivers for CUPS
ii foo2zjs 20061224-0ubuntu3 Support for printing to ZjStream-based print
ii foomatic-db 20070327-0ubuntu1 OpenPrinting printer support - database
ii foomatic-db-engine 3.0.2-20070303-0ubuntu1 OpenPrinting printer support - programs
ii foomatic-db-hpijs 20070327-0ubuntu1 OpenPrinting printer support - database for
ii foomatic-filters 3.0.2-20070323-0ubuntu1 OpenPrinting printer support - filters
ii gnome-cups-manager 0.31-3ubuntu5 CUPS printer admin tool for GNOME
ii gs-common 0.3.11ubuntu1 Common files for different Ghostscript relea
ii gs-esp 8.15.4.dfsg.1-0ubuntu1 The Ghostscript PostScript interpreter - ESP
ii gs-esp-x 8.15.4.dfsg.1-0ubuntu1 The Ghostscript PostScript interpreter - ESP
ii hpijs 2.7.2+1.7.3-0ubuntu1 HP Linux Printing and Imaging - gs IJS drive
ii hplip 1.7.3-0ubuntu1 HP Linux Printing and Imaging System (HPLIP)
ii libgnomeprint2.2-0 2.18.0-0ubuntu1 The GNOME 2.2 print architecture - runtime f
ii min12xxw 0.0.9-1build1 Printer driver for KonicaMinolta PagePro 1[2
ii openprinting-ppds 20070327-0ubuntu1 OpenPrinting printer support - PostScript PP
ii pnm2ppa 1.12-16 PPM to PPA converter

Created with printingbuginfo script v1.5 (https://wiki.ubuntu.com/PrintingBugInfoScript)
Mon, 14 May 2007 10:47:36 +0200

M Lucius (marcel-lucius) wrote :

confirmed it works

Markus Kolb (mkolb) wrote :

The workaround with the touched ppd file works for me, too.

Sebastien Bacher (seb128) wrote :

touching the ppd workaround the bug, looks like a cupsys thing

Changed in evince:
assignee: desktop-bugs → nobody
status: Needs Info → Unconfirmed

Looks like a gtk printing bug to me.
GTK in Feisty does not support raw printer queues (without PPD), see upstream bug watch.

Changed in cupsys:
status: Unconfirmed → Confirmed
Changed in cups:
status: Unconfirmed → Unknown
Changed in cups:
status: Unknown → Fix Released
Kansei (clauretano) wrote :
Download full text (3.1 KiB)

I'm trying to figure out if what I'm experiencing is this same bug or it it's something new.

I'm running Gutsy Gibbon (32 and 64 bit on two different laptops) and have been since May. I guess since both systems are up to day I'm currently using the Beta release, though originally both systems were installed with Tribe 1. In evince, I can print the first page of a PDF just fine.. I told it to print Page 3, and cups saw no print job.. 5 minutes later, out pops page 3 from the printer. I just can't get it to print the whole document (32 pages).

The printer is a Brother HL-5140 connected to an Apple Airport Express (a client on the wireless network).

Here is my printingbuginfo script output:
----------------------------------------------------------------------------------------------------
ProblemType: printingbuginfo v2.0: printingbug (https://wiki.ubuntu.com/PrintingBugInfoScript)
CupsConfiguredDevices:
 device for brother: socket://192.168.0.2:9100
 device for PDF: cups-pdf:/
CupsConfiguredPPDs:
 PDF: Generic PDF file generator
 brother: Brother HL-5140 Foomatic/hl1250 (recommended)
Date: Fri Sep 28 13:47:59 2007
DesktopEnvironment: GNOME
DistroRelease: Ubuntu 7.10
EtcPapersize: cat: /etc/papersize: No such file or directory
InstalledPrintingPackages:
 ii cupsys 1.3.2-1ubuntu1 Common UNIX Printing System(tm) - server
 ii cupsys-driver-gutenprint 5.0.1-0ubuntu5 printer drivers for CUPS
 ii foo2zjs 20070625-0ubuntu1 Support for printing to ZjStream-based printers
 ii foomatic-db 20070919-0ubuntu2 OpenPrinting printer support - database
 ii foomatic-db-engine 3.0.2-20070719-0ubuntu3 OpenPrinting printer support - programs
 ii foomatic-db-hpijs 20070813-0ubuntu1 OpenPrinting printer support - database for HPIJS driver
 ii foomatic-filters 3.0.2-20070719-0ubuntu1 OpenPrinting printer support - filters
 ii ghostscript 8.61.dfsg.1~svn8187-0ubu The GPL Ghostscript PostScript/PDF interpreter
 ii gs-esp 8.61.dfsg.1~svn8187-0ubu Transitional package
 ii hpijs 2.7.7+2.7.7.dfsg.1-0ubun HP Linux Printing and Imaging - gs IJS driver (hpijs)
 ii hplip 2.7.7.dfsg.1-0ubuntu2 HP Linux Printing and Imaging System (HPLIP)
 ii libgnomeprint2.2-0 2.18.2-0ubuntu1 The GNOME 2.2 print architecture - runtime files
 ii min12xxw 0.0.9-1build1 Printer driver for KonicaMinolta PagePro 1[234]xxW
 ii openprinting-ppds 20070919-0ubuntu2 OpenPrinting printer support - PostScript PPD files
 ii pnm2ppa 1.12-16 PPM to PPA converter
 ii pxljr 1.1-0ubuntu1 Driver for HP's Color LaserJet 35xx/36xx color laser printers
 ii splix 1.0.1.1-0ubuntu2 Driver for Samsung's SPL2 (bw) and SPLc (color) laser printers
 ii system-config-printer 0.7.75+svn1566-0ubuntu1 printer configuration GUI
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8, LC_PAPER=en_US.UTF-8
Uname: Linux cdl-D620 2.6.22-12-generic #1 SMP Sun Sep 23 20:03:18 GMT 2007 x86_64 GN...

Read more...

Linda Ang (aslang) wrote :

I still cannot get my HP Colour LaserJet 3800 to print. I also could not install the printingbuginfo as it say could not the package.

I try the touch, but the print job still show on the queue but never get print out.

M Lucius or Markus Kolb,

Do you still need the workaround in Ubuntu 7.10 (Gutsy)?

Make sure that /etc/cups/ppd/x.ppd has been removed by running the following commands:
$ lpstat -v
device for x: ...
$ sudo rm /etc/cups/ppd/x.ppd
Don't forget to replace the x by your printer name!

Changed in gtk+2.0:
assignee: nobody → pascal-devuyst
status: Confirmed → Incomplete

Kansei and Linda Ang,
Please open a separate bug report and attach the information described here: https://wiki.ubuntu.com/DebuggingPrintingProblems.

We believe this bug is fixed since Ubuntu 7.10, please reopen if you still have a problem.
To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gtk+2.0:
status: Incomplete → Fix Released
Changed in cups:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.