Updating libswt-gtk in synaptic yields error and breaks eclipse

Bug #23386 reported by Nathan Meryash on 2005-10-07
6
Affects Status Importance Assigned to Milestone
gtk+1.2 (Ubuntu)
Medium
Unassigned

Bug Description

The following error is given when attempting to upgrade or repair libswt3.1-gtk
in Synaptic.

===error message============================================
E: /var/cache/apt/archives/libswt3.1-gtk-java_3.1-10ubuntu1_all.deb: trying to
overwrite `/usr/share/java/swt-gtk-3.1.jar', which is also in package
libswt-gtk-3.1-java
============================================================

This gives the following error message when trying to launch eclipse.

===error message============================================
A suitible Java Virtual Machine for running the Eclipse platform could not be
located.
============================================================

Matt Zimmerman (mdz) wrote :

Thanks for your bug report. However, libswt-gtk is a part of the 'universe'
component, so its bugs are not currently tracked in this system. Bugs for these
packages should be reported to Malone: [WWW]
https://launchpad.ubuntu.com/malone/distros/ubuntu

For more information about universe packages, contact the MOTU team: [WWW]
https://wiki.ubuntu.com/MOTU

Nathan Meryash (ngmlinux) wrote :

(In reply to comment #1)

I've reposted the bug as per your suggestions at:
https://launchpad.net/malone/bugs/2954

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.