gthumb fails camera import and then loads an attached hard drive

Bug #713838 reported by Martin G Miller on 2011-02-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gthumb (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gthumb

After upgrading 64 bit 10.04 to 10.10 gthumb no longer loads pictures from my canon SD550 digital camera when connected by USB.
Version of gthumb is 3:2.11.3-2build1
What was expected is a normal gthumb import session which reads the camera and presents the pictures for importing.
What happened instead:
You get a popup window which says "Could not load the folder DBus error org.freedesktop.DBus.Error.UnknownMethod: Method "QueryInfo" with signature "aysus" on interface "org.gtk.vfs.Mount" doesn't exist".

After closing that popup, gthumb then loads a pictures folder that is on an sata hard drive that is mounted and used as my backup drive. The drop down list in the picture importer only shows "backup" as the source of the photos.

I have tried changing the command for gthumb importer from:
sh -c 'gvfs-mount -u ~/.gvfs/gphoto2*; exec gthumb --import-photos'

to:
sh -c 'gvfs-mount -s gphoto2 ; sleep 3 ; exec gthumb --import-photos'

as this was needed to get it to work in 10.04, but it has no effect in 10.10.

If I take the memory card out of the camera and put it in an external card reader, gthumb will import the pictures as expected.

Shotwell, the new default picture import application in 10.10, has no problems seeing and importing photos from the camera.

Paolo (paolo-becci) wrote :

i have the same problem with my canon ixus 860is.
i'm working with 10.10 32bit.
Has anyone solved this problem or found a workaround?

Martin G Miller (mgmiller) wrote :

As a work around, I am using Shotwell to import from my camera. It does a good job and allows me to erase from the camera after importing. I am not crazy about the way it organizes the imported pictures by date, several layers deep. I just tell it to save to my desktop and then move the pictures around to where I want them from there. I still use gthumb as my basic photo editor when I don't want to fire up gimp. For actual picture managment, I use Picasa 3.0 installed from the Google testing repositories. This is a truly amazing application. http://www.ubuntuupdates.org/ppas/13

mjc (mjc-avtechpulse) wrote :

What version of gThumb is this (check in Help > About)?

It could be that the old importer script is still present somewhere on the system, and it is unmounting the gvfs mounts ("gvfs-mount -u ~/.gvfs/gphoto2*").

Old versions of gThumb (2.10.x) conflicted with the gvfs/gphoto backend, and had to umount those gvfs mounts.

The new versions (2.12.x) are compatible with the gvfs/gphoto backend, and unmounting things would actually be harmful.

So, look for some "helper script" that might be unmounting things.

I don't actually use Ubuntu, so this theory could be all wrong...

- Mike

Paolo Benvenuto (donpaolo) wrote :

ok, but where actually was the "helper script"?

Was it a gthumb script or a ubuntu one?

mjc (mjc-avtechpulse) wrote :

Make sure there is no "mount" stuff in the output when you execute this command:

[mjc@xena ~]$ grep -i exec /usr/share/applications/gthumb*.desktop
/usr/share/applications/gthumb.desktop:Exec=gthumb %U
/usr/share/applications/gthumb-import.desktop:Exec=gthumb --import-photos %U

- Mike

Martin G Miller (mgmiller) wrote :

OK, I got it to work. Based on your comments, I changed the command in the menu for gThumb Photo Import Tool to:
sh -c 'gphoto2 ; exec gthumb --import-photos'
and that did the trick. Apparently you can't mention anything about gvfs any more.
Thanks for the clues.

Martin G Miller (mgmiller) wrote :

Paolo, you need to right click Applications the select "Edit Menus". In the resulting window, select Graphics on the left side and then on the right side, right click gThumb Photo Import Tool. Select Properties and in the resulting window, change the command in the "Command" box to read:
sh -c 'gphoto2 ; exec gthumb --import-photos'
It's easiest to just blank out the old command and paste in the one I wrote above.
Once the new command is in the box, just click "Close" and close out of the menu editor.

If your camera is already connected, disconnect it. Then the next time you plug it in and set it to upload, everything should work as before. Some of the choices in the new version of the import tool have been moved to the "Preferences" button, so look at that once it runs.

Paolo (paolo-becci) wrote :

Thanks Martin.
Eventually worked perfectly!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers