GThumb import fails if any files in camera are movies

Bug #486617 reported by Jan Schürmann on 2009-11-22
86
This bug affects 15 people
Affects Status Importance Assigned to Milestone
gThumb
Fix Released
Medium
gphoto2 (Ubuntu)
Undecided
Unassigned
gthumb (Debian)
Fix Released
Unknown
gthumb (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gthumb

i'm using karmic on 64-bit with nvidia 9800GT.
i don't know exactly when this first happens, it works in jaunty. perhaps after the update?
if i start import tool from terminal, the following message appears if i want to import photos AND movies from my Sony DSC:

(gthumb:6921): Gtk-CRITICAL **: gtk_progress_set_percentage: assertion `percentage >= 0 && percentage <= 1.0' failed

if i only have photos on the camera it works just fine.

Jendrik Seipp (jendrikseipp) wrote :

I have the same problem. After clicking "Import" in the "Import Photos" dialog, nothing happens and the error message

(gthumb:2805): Gtk-CRITICAL **: gtk_progress_set_percentage: assertion `percentage >= 0 && percentage <= 1.0' failed

is shown.

The only difference is that in my situation the import never works, even without videos. Everything worked fine on Jaunty.

description: updated
description: updated
Pelládi Gábor (pelladigabor) wrote :

Same here, Ubuntu Karmic amd64. On Jaunty, it was working.

Pelládi Gábor (pelladigabor) wrote :

I tested this bug with only an image on the camera. It was working. So the video might cause the error, as the reporter said.

Rupert (rupert-everweb) wrote :

In my case: gthumb --import-photos
[I see the thumbnails but when I press the "Import" button, the app does nothing but displays the following in the console:]
(gthumb:5261): Gtk-CRITICAL **: gtk_progress_set_percentage: assertion `percentage >= 0 && percentage <= 1.0' failed

[The "Help" button gives me this:]
** (gnome-help:5566): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed

** (gnome-help:5566): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
OMF category 'Applications|Other' not recognised, ignoring.
OMF category 'Applications|Other' not recognised, ignoring.
OMF category 'Applications|Other' not recognised, ignoring.

[The Cancel button closes the app as expected.]

Bradly Wilson (mocoloco) wrote :

Same problem here, USB Mass storage camera, importing just images works fine. If there are any videos the importer hangs, terminal output:
(gthumb:3603): Gtk-CRITICAL **: gtk_progress_set_percentage: assertion `percentage >= 0 && percentage <= 1.0' failed

wiennat (wiennat) wrote :

I'm using karmic 32-bit. I tried to import pictures from my memory card. There were many videos there but I didn't import them.

draco (draco31-fr) wrote :

I think the problem is due to libghoto2.
I try an other import tool, gphoto2, and an error occurs when I want to download files.
Both gThumb and gphoto2 software use libgphoto2 to acces the digital camera or mass storage.

See the debug output from gphoto2 in attachment.

Glen Journeay (glenjo) wrote :

I'm running karmic 32-bit. Gthumb is failing to import photos with the same error:

(gthumb:xxxx): Gtk-CRITICAL **: gtk_progress_set_percentage: assertion `percentage >= 0 && percentage <= 1.0' failed

xcape77 (xcape77) wrote :

Same problem with Karmic here. But after deleting my videos from the camera it works.

Jeff Bowden (jlb) wrote :

Also seeing this in Lucid

also in Lucid 64-bit

Changed in gthumb (Debian):
status: Unknown → New
Changed in gthumb:
status: Unknown → New
Changed in gthumb:
status: New → Fix Released
Chad Miller (cmiller) on 2010-05-27
summary: - GThumb doesn't import photos and movies from camera anymore
+ GThumb import fails if any files in camera are movies
Chad Miller (cmiller) wrote :

A work-around is to not have any unsupported file formats in the camera. If you have movies, for instance, you will hit this bug.

It's fixed in upstream with a simple patch that clears error flags that failing to produce a thumbnail sets.

That patch is already applied to gthumb trunk. If someone will make sure that it's safe to unset the error flag (for instance, is it possible to have an error earlier, for which we should not unset it if there is *another* error we want to ignore), then I think it should be safe for a Ubuntu-package patch.

Since having movies on cameras is almost the default case these days, this deserves some attention and a High or Critical severity.

mjc (mjc-avtechpulse) wrote :

Clarification: The patch isn't in gthumb "trunk", it is in gthumb-2-10 branch.

I'm not sure if another release will be made from the gthumb-2-10 branch (developers are focusing on 2.11.x), so Ubuntu should probably apply the patch directly.

- Mike

Chad Miller (cmiller) on 2010-05-27
Changed in gthumb (Ubuntu):
milestone: none → maverick-updates
Changed in gthumb (Ubuntu):
milestone: maverick-updates → none
importance: Undecided → Low
status: New → Triaged
Changed in gthumb:
importance: Unknown → Medium
Changed in gphoto2 (Ubuntu):
status: New → Confirmed
Vibhav Pant (vibhavp) on 2012-04-18
Changed in gthumb (Ubuntu):
assignee: nobody → Vibhav Pant (vibhavp)
assignee: Vibhav Pant (vibhavp) → nobody
Changed in gthumb (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.