gthumb is hogging on the cpu after searching for images

Bug #207330 reported by Fedor Isakov on 2008-03-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gthumb (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gthumb

Hardy x86_64:

After searching for all images in an icons collection (about 1700 files), the "search result" is displayed fine and there's no sluggishness in the interface. However, the system monitor indicates that gthumb process is using 100% CPU. After restarting the process, the same search results are shown with no problems at all.

Pedro Villavicencio (pedro) wrote :

works fine here, may you tell us a few steps in order to reproduce the issue? does it happens with all the images icons or only with a specific one? thanks.

Changed in gthumb:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Fedor Isakov (fisakov) wrote :

The following is tested on Hardy x86_64, latest updates:

$ uname -a
Linux moya 2.6.24-12-generic #1 SMP Wed Mar 12 22:31:43 UTC 2008 x86_64 GNU/Linux

1. download the Mac4Lin icons pack from http://sourceforge.net/projects/mac4lin
2. unpack the icons to /tmp
3. start gthumb and search for all icons in /tmp/Mac4Lin_Icons_v0.4 inclding subfolders
4. after choosing "View" the gthumb process starts to consume 100% CPU

Pedro Villavicencio (pedro) wrote :

still an issue? that works fine for me, can you try in Intrepid? thanks.

Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in gthumb:
status: Incomplete → Invalid
Anthony DeChiaro (adechiaro) wrote :

Can this be reopened? I've noticed this problem with gthumb for a few months now, certainly able to reproduce on Jaunty with a fairly large animated GIF (~7mb). After the image finishes playing all frames, gthumb CPU usage spikes up and stays there until I switch to a different image.

Fedor Isakov (fisakov) wrote :

Just tested with jaunty 32 bit. Same thing. Any particular info I need to provide, please ask.

Changed in gthumb (Ubuntu):
status: Invalid → Confirmed
Pedro Villavicencio (pedro) wrote :

Thanks for your report, that's something to send directly upstream at http://bugzilla.gnome.org by someone having the issue, for forwarding instructions please read http://wiki.ubuntu.com/Bugs/Upstream/GNOME, Thanks in advance.

Paolo Benvenuto (donpaolo) wrote :

My gthumb suffers this bug, too.

dronus (paul-geisler) wrote :

I encounter the same issues.

When running from terminal, gthumb reports in a very high frequency:

"Warning: Photoshop IRB data is not padded to even size"

It seems some thumbnails won't be created due to some error while reading the jpeg file, and gthumb endlessly repeats trying to recreate the thumbnail.

Same thing sometimes happend for video files.

It also happens in nemo sometimes, where the thumbnail shows a waiting symbol endlessly while hogging the cpu.

I guess gthumb (and nemo) would have to handle thumbnailing errors more gracefully (do not retry).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers