Can not import anything from camera if one photo is bad

Bug #202318 reported by Davide Capodaglio on 2008-03-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gThumb
Fix Released
Medium
gthumb (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gthumb

I am trying to import photos with gthumb (Ubuntu 7.10) from my mobile phone.
The list of image thumbnails is correctly viewed, but I can not import anything
because I have both photos and small GIFs (clipart, frames ecc) that libgphoto
seem not to handle correctly; in gthumb there are no thumbnails for these and
the message "PTP No thumbnail present" appears (even if this is a MTP device)
while loading them.
However, the error for the cliparts inhibits the import for the jpg photos,
that can be imported without problems with gphoto2 and digikam.

In fact I gave a brief look and debug at the source code and in
dlg-photo-importer.c in ctx_error_func is set the global data->error flag, that
ok_clicked_cb causes a return...
So I think that the import procedure should be made more fault-tolerant,
otherwise a single broken (or unsupported) image can inhibit the import of the
whole correct images.

Davide Capodaglio (davidecapod) wrote :

I also signalled this in gnome bugzilla since the problem is present upstream
http://bugzilla.gnome.org/show_bug.cgi?id=521891

Changed in gthumb:
status: Unknown → New
Changed in gthumb:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Eugene Crosser (crosser) wrote :

For me, it is also impossible to download photos when video clip files are present in the camera. Looks like it is the same problem.

Changed in gthumb:
status: New → Fix Released
Changed in gthumb:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.