gthumb crashes with Segmentation fault, after upgrade to Ubuntu 20.10

Bug #1903569 reported by Roland
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gthumb (Ubuntu)
Undecided
Unassigned
intel-media-driver (Debian)
Fix Released
Unknown
intel-media-driver (Ubuntu)
Undecided
Unassigned

Bug Description

When play a video with gthumb, it crashes with "Segmentation fault", after upgrade to Ubuntu 20.10
No problem with pictures.
Problem was not with Ubuntu 20.04 LTS (all versions)

Same behaviour in with hardware (and not) video support in Extensions.

Error from dmesg:
[24148.160196] qtdemux0:sink[518446]: segfault at 0 ip 00007f9bd64fabc5 sp 00007f9bd7c29bd0 error 4 in iHD_drv_video.so[7f9bd63e1000+348000]
[24148.160205] Code: 01 48 83 f8 42 75 e6 31 db 66 41 89 9f 58 0c 00 00 49 8b 5f 28 8b 83 f0 1d 00 00 85 c0 0f 84 ba 01 00 00 48 8b b3 e8 1d 00 00 <81> 3e 00 00 01 00 48 89 75 c8 0f 85 a3 01 00 00 44 8d 70 f0 4d 63

gthumb version 3:3.8.0-2.1build1
Ubuntu :latest 20.10 release

Revision history for this message
Arie Skliarouk (skliarie) wrote :

It seems the problem is not specific to gthumb.
The segfault happens in iHD_drv_video.so for many programs:
Viber: https://askubuntu.com/questions/1287450/viber-executable-crashes-on-ubuntu-20-10
vokoscreenNG: https://github.com/vkohaupt/vokoscreenNG/issues/117
gcompris-qt: - it is how it fail for me

It seems that segfaults happen with free intel-media-va-driver but not with intel-media-va-driver-non-free. At least in my case gcompris started working after the replacement.

Please try to replace the free driver like this:
apt install intel-media-va-driver-non-free

Changed in gthumb (Ubuntu):
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in intel-media-driver (Ubuntu):
status: New → Confirmed
Revision history for this message
Sebastian Ramacher (s-ramacher) wrote :

As soon as Ubuntu syncs 21.3.0+dfsg1-1, this issue will be fixed.

Changed in intel-media-driver (Ubuntu):
status: Confirmed → Fix Released
Changed in intel-media-driver (Debian):
status: Unknown → Fix Released
Revision history for this message
Junior Lawrence Kibirige (juniorkibirige) wrote :

Still getting the same issue after multiple updates

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.