GThumb crashes everytime!!!

Bug #173082 reported by stambec92 on 2007-11-30
8
Affects Status Importance Assigned to Milestone
gthumb (Ubuntu)
Medium
Ubuntu Desktop Bugs
Gutsy
Undecided
Tormod Volden

Bug Description

Binary package hint: gthumb

Architecture: i386
Distro: Ubuntu 7.10
Running Compiz Fusion "Normal effects"

I run Gthumb, I load some photos, I right-click a photo and select print, but many and many times Gthumb crashes. I'm so angry!!!
Don't say that it's not a bug ;)

Hoping that it will fixed, bye.

TEST CASE:
 gthumb /usr/share/example-content/logo-Ubuntu.png
Then ctrl-P (Print), "Paper Details" tab, select "Custom" in drop-down list. Crashes immediately.

Related branches

stambec92 (stambec92) wrote :

It happens often when I select the "custom" print dimension in the print properties

mjc (mjc-avtechpulse) wrote :

A fix will be provided in gthumb 2.10.8 when it is released.

The Ubuntu packagers might want to pull in this one-line fix before that, though:

http://svn.gnome.org/viewvc/gthumb?view=revision&revision=2028

- Mike

Changed in gthumb:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
stambec92 (stambec92) wrote :

Good job. Thanks!

Tormod Volden (tormodvolden) wrote :

Here's a debdiff with the upstream patch + fixes a FTBFS.

gthumb (3:2.10.6-0ubuntu3) hardy; urgency=low

  * 22_paper_size_free.dpatch crasher fix (LP: #173082)
  * debian/rules: use dh_icons instead of dh_iconcache (LP: #151696)

Tormod Volden (tormodvolden) wrote :

gthumb (3:2.10.6-0ubuntu3) hardy; urgency=low

  * 22_paper_size_free.dpatch crasher fix (LP: #173082)
  * debian/rules: use dh_icons instead of dh_iconcache (LP: #151696)

 -- Tormod Volden <email address hidden> Thu, 13 Dec 2007 10:24:52 +0100

Changed in gthumb:
status: Triaged → Fix Released
Tormod Volden (tormodvolden) wrote :

SRU: minimal patch for Gutsy is attached

Nominating for SRU, fulfills: (1) have an obviously safe patch and (2) affect an application rather than critical infrastructure packages

The fix is from upstream and has been verified in Hardy.

NB: There seems to be a missing build dependency on libltdl3-dev as well. I don't know how the old version could be build. However, I have added that fix to the SRU in bug #165174. I don't know the best way to handle these two SRUs at the same time. They could be fixed together as well, which would be equivalent to the 3:2.10.6-0ubuntu3 package in Hardy.

Martin Pitt (pitti) wrote :

Approved for Gutsy. Similarly to #165174 this needs a much more human readable changelog. Both changes should be applied to the current gutsy package and uploaded in one go.

I see to sponsoring this a little later.

Changed in gthumb:
assignee: nobody → pitti
status: New → In Progress
Tormod Volden (tormodvolden) wrote :

New patch, including the fix from bug #165174, with more detailed changelog.

Martin Pitt (pitti) wrote :

Sponsored and accepted into gutsy-proposed, please test. Thank you!

Changed in gthumb:
assignee: pitti → tormodvolden
status: In Progress → Fix Committed
Tormod Volden (tormodvolden) wrote :

stambec92, it would be nice if you also could confirm that the package in gutsy-proposed fixes the problems that you reported.

description: updated
Pedro Villavicencio (pedro) wrote :

Verification done:

- With gthumb 2.10.6-0ubuntu1 on gutsy after following the test case it crashed after select custom on the dropdown list.
- With gthumb 2.10.6-0ubuntu1.1 on gutsy , it doesn't crash anymore if you select custom on the print dialog, the bug is fixed. thanks.

Martin Pitt (pitti) wrote :

Copied to gutsy-updates.

Changed in gthumb:
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2008-04-29
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers