GTG Notification Area plugin disables itself at every login to the system

Bug #617257 reported by lipstick
44
This bug affects 10 people
Affects Status Importance Assigned to Milestone
GTG
Fix Released
Low
Luca Invernizzi
gtg (Ubuntu)
Fix Released
Undecided
Luca Invernizzi

Bug Description

Binary package hint: gtg

Here what I do:

I start GTK, then open Edit > Preferences and enable Notification Area plugin, later I press X to minimize it to the notification area but I have to repeat it again to get the result which is another bug, anyway it goes to the top right corner of the screen.

When I restart the system, I realize that the Notification Area plugin is disabled again. I have to re-enable it everytime.

Thanks for your attention.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gtg 0.2.4-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-24.39-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
Architecture: i386
CheckboxSubmission: 09cdbd269b0dd3f2b0d2eb40cad6878d
CheckboxSystem: e3f7e64142c9de9cf92c77313821923d
Date: Fri Aug 13 10:56:09 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANG=tr_TR.utf8
 SHELL=/bin/bash
SourcePackage: gtg

Revision history for this message
lipstick (sinanaykut-gmail) wrote :
Revision history for this message
Izidor Matušov (izidor) wrote :

Hi, I have sometimes similar problems which disappears after few minutes of playing. It's weird. I assume when you open the about dialog of plugin (there is an "about" button in the dialog where you enable the plugin), there are a message like "Everything necessary to run this plugin is available". There might be an error one.

The second thing to try is to run gtg from gnome-terminal with as "gtg -d".

Do you found something unusual?

Revision history for this message
Luca Invernizzi (invernizzi) wrote :

To see what's the problem, please paste here the content of ~/.config/gtg/gtg.conf
You should find at the bottom of that file something like this:
...
[plugins]
disabled = ...
enabled = ..., notification_area, ...

If this problem is originated from the bug I'm thinking about, it should go away just by closing GTG manually (Tasks->Quit) before shutting the computer down. Please confirm if this fixes the problem.

Changed in gtg (Ubuntu):
status: New → In Progress
status: In Progress → Incomplete
Revision history for this message
lipstick (sinanaykut-gmail) wrote : Re: [Bug 617257] Re: GTG Notification Area plugin disables itself at every login to the system
  • debug Edit (29.9 KiB, application/octet-stream; name=debug)

- Yes, it gives the same message on the About window.

- I have added the debug output as an attachment

2010/8/13 Izidor Matušov <email address hidden>:
> Hi, I have sometimes similar problems which disappears after few minutes
> of playing. It's weird. I assume when you open the about dialog of
> plugin (there is an "about" button in the dialog where you enable the
> plugin), there are a message like "Everything necessary to run this
> plugin is available". There might be an error one.
>
> The second thing to try is to run gtg from gnome-terminal with as "gtg
> -d".
>
> Do you found something unusual?
>
> --
> GTG Notification Area plugin disables itself at every login to the system
> https://bugs.launchpad.net/bugs/617257
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gtg” package in Ubuntu: New
>
> Bug description:
> Binary package hint: gtg
>
> Here what I do:
>
> I start GTK, then open Edit > Preferences and enable Notification Area plugin, later I press X to minimize it to the notification area but I have to repeat it again to get the result which is another bug, anyway it goes to the top right corner of the screen.
>
> When I restart the system, I realize that the Notification Area plugin is disabled again. I have to re-enable it everytime.
>
> Thanks for your attention.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: gtg 0.2.4-1ubuntu1
> ProcVersionSignature: Ubuntu 2.6.32-24.39-generic 2.6.32.15+drm33.5
> Uname: Linux 2.6.32-24-generic i686
> Architecture: i386
> CheckboxSubmission: 09cdbd269b0dd3f2b0d2eb40cad6878d
> CheckboxSystem: e3f7e64142c9de9cf92c77313821923d
> Date: Fri Aug 13 10:56:09 2010
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
> PackageArchitecture: all
> ProcEnviron:
>  LANG=tr_TR.utf8
>  SHELL=/bin/bash
> SourcePackage: gtg
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/gtg/+bug/617257/+subscribe
>

--
twitter.com/sinan_aykut

Revision history for this message
Luca Invernizzi (invernizzi) wrote :

Could you paste also the ~/.config/gtg/gtg.conf file?

Changed in gtg:
status: New → Incomplete
milestone: none → 0.3
Revision history for this message
lipstick (sinanaykut-gmail) wrote :

Wov as you guessed, gtg and the plugin works when i restart the system.

And here is my .conf flie part:

[plugins]
disabled = tomboy, task_reaper, helloworld, send_email, bugzilla,
export, hamster, import_json, geolocalized_tasks, evolution_sync
enabled = notification_area, rtm_sync

2010/8/14 Luca Invernizzi <email address hidden>:
> Could you paste also the ~/.config/gtg/gtg.conf file?
>
> ** Changed in: gtg
>       Status: New => Incomplete
>
> ** Changed in: gtg
>    Milestone: None => 0.3
>
> --
> GTG Notification Area plugin disables itself at every login to the system
> https://bugs.launchpad.net/bugs/617257
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Getting Things GNOME!: Incomplete
> Status in “gtg” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: gtg
>
> Here what I do:
>
> I start GTK, then open Edit > Preferences and enable Notification Area plugin, later I press X to minimize it to the notification area but I have to repeat it again to get the result which is another bug, anyway it goes to the top right corner of the screen.
>
> When I restart the system, I realize that the Notification Area plugin is disabled again. I have to re-enable it everytime.
>
> Thanks for your attention.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: gtg 0.2.4-1ubuntu1
> ProcVersionSignature: Ubuntu 2.6.32-24.39-generic 2.6.32.15+drm33.5
> Uname: Linux 2.6.32-24-generic i686
> Architecture: i386
> CheckboxSubmission: 09cdbd269b0dd3f2b0d2eb40cad6878d
> CheckboxSystem: e3f7e64142c9de9cf92c77313821923d
> Date: Fri Aug 13 10:56:09 2010
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
> PackageArchitecture: all
> ProcEnviron:
>  LANG=tr_TR.utf8
>  SHELL=/bin/bash
> SourcePackage: gtg
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/gtg/+bug/617257/+subscribe
>

--
twitter.com/sinan_aykut

Revision history for this message
Luca Invernizzi (invernizzi) wrote :

Nice.
This is fixed in GTG trunk, marking as fix committed

Changed in gtg (Ubuntu):
status: Incomplete → Fix Committed
Changed in gtg:
status: Incomplete → Fix Committed
Changed in gtg (Ubuntu):
assignee: nobody → Luca Invernizzi (invernizzi)
Changed in gtg:
assignee: nobody → Luca Invernizzi (invernizzi)
importance: Undecided → Low
DeeZZel (deezzel-07)
Changed in gtg:
status: Fix Committed → New
status: New → In Progress
status: In Progress → Fix Committed
Revision history for this message
Dragonfly (mailboxcb-ubuntu) wrote :

Hi there,

I found the same trouble with gtg 0.2.4 on Ubuntu 10.10, Gnome 2.32.0. Getting Things Gnome icon don't stay one the notification area Ubuntu desktop after all restar operating system, the plugin's desactivated all time.

Thanks for your attention.

Revision history for this message
Dragonfly (mailboxcb-ubuntu) wrote :

This pluging seems to work well now. After to have activated this extention, I saw a new button option on the bottom: "Configure plugin" and I have activated the option: "start gtg minimized". Thanks for all team and congratulation for this nice work. But it's not finish, you can improve it with more "functionalities" '-)...

Revision history for this message
Ahmed Hosny (ahmed-hosny-badr) wrote :

I confirm this problem on Ubuntu 10.10 64bit, Using GTG 0.2.4
And haven't got any fixes till now ..

Revision history for this message
Luca Invernizzi (invernizzi) wrote :

"Fix committed" means that we have a working solution in our code base. When it turns to "Fix released", the fix will be released.

Changed in gtg (Ubuntu):
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed
Revision history for this message
tdeering (tomdeering7) wrote :

I hope this fix gets released soon, I experience this annoying bug as well. It is my only major annoyance with Getting Things Gnome.

Revision history for this message
dtfjgk (dtfjgk-deactivatedaccount) wrote :

Ubuntu 11.04 - the bug is still not fixed. :/

Revision history for this message
Olivier Van Helden (olivier-van-helden) wrote :

Ubuntu 10.04
Gnome 2.30.2
GTG 0.2.4

the bug is still not fixed. :/

Revision history for this message
lipstick (sinanaykut-gmail) wrote : LinkedIn'e bağlanma daveti

LinkedIn
------------

Bug,

Sizi LinkedIn'deki profesyonel profilime eklemek istiyorum.

- Sinan

Sinan Aykut
Şu okulda öğrenci: Afyon Kocatepe Üniversitesi
Türkiye

Sinan Aykut adlı kişiyi tanıdığınızı onaylayın
https://www.linkedin.com/e/-aq8jlk-gqm80lar-2l/isd/3670126682/iYi1mci1/

--
(c) 2011, LinkedIn Corporation

Changed in gtg:
milestone: 0.3 → 0.2.9
Izidor Matušov (izidor)
Changed in gtg:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtg - 0.2.9-1

---------------
gtg (0.2.9-1) unstable; urgency=low

  * New upstream release (Closes: #668096).
    - Implement a search text box (Closes: #650279).
    - Window title reflects active tasks (LP: #537096).
    - Fix misbehaviours of the indicator applet (LP: #548836, #676353).
    - Fix crash when selecting notification area plugin twice (LP: #550321).
    - Fix sorting of tasks by date (LP: #556159).
    - Fix excessive delays at startup (LP: #558600).
    - Fix crash with dates having unknown values (LP: #561449).
    - Fix crash issued when pressing delete key (LP: #583103).
    - Keep notification plugin enabled after logoff (LP: #617257).
    - Fix Hamster plugin to work with recent Hamster versions (LP: #620313).
    - No longer use non-unicode strings (LP: #680632).
    - New RTM sync mechanism (LP: #753327).
    - Fix crashes while handling XML storage file (LP: #916474, #917634).
  * debian/patches/*:
    - Drop all patches, they have been merged upstream.
  * debian/patches/shebang.patch:
    - Fix shebang line.
  * debian/patches/manpages.patch:
    - Fix some groff warnings in gtg_new_task man page
  * debian/compat:
    - Bump compatibility level to 9.
  * debian/control:
    - Bump X-Python-Version to >= 2.6.
    - Add python-liblarch and python-liblarch-gtk to Depends field.
    - Add python-cheetah, python-geoclue, python-gnomekeyring,
      python-launchpadlib and python-suds to Suggests field.
    - Bump Standards-Version to 3.9.3.
  * debian/copyright:
    - Refresh copyright information.
    - Format now points to copyright-format site.
  * debian/rules:
    - Make gtcli_bash_completion script executable.
  * debian/watch:
    - Update watch file.

 -- Luca Falavigna <email address hidden> Tue, 10 Apr 2012 23:08:21 +0200

Changed in gtg (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers