[SRU] Bugfix release 1.14.4

Bug #1829366 reported by Iain Lane on 2019-05-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gst-libav1.0 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane
gst-plugins-bad1.0 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane
gst-plugins-base1.0 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane
gst-plugins-good1.0 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane
gst-plugins-ugly1.0 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane
gst-python1.0 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane
gst-rtsp-server1.0 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane
gstreamer-editing-services1.0 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane
gstreamer-vaapi (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane
gstreamer1.0 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane

Bug Description

[ Description ]

We should keep up with GStreamer's bugfix releases in the 1.14 series that 18.04 shipped with.

[ QA and testing ]

Play a range of videos in Totem. Play a range of audio tracks in Rhythmbox. Try to stream audio and/or video. Try to install a missing codec.

In all cases, make sure that everything which worked before still works.

[ Regression potential ]

If one of the fixes is bad then it might break video or audio playback, or could crash any application that tries to use gstreamer.

CVE References

Iain Lane (laney) on 2019-05-16
Changed in gstreamer1.0 (Ubuntu):
status: New → Fix Released
Iain Lane (laney) on 2019-05-16
description: updated
Iain Lane (laney) on 2019-05-16
Changed in gst-libav1.0 (Ubuntu):
status: New → Fix Released
Changed in gst-plugins-bad1.0 (Ubuntu):
status: New → Fix Released
Changed in gst-plugins-base1.0 (Ubuntu):
status: New → Fix Released
Changed in gst-plugins-good1.0 (Ubuntu):
status: New → Fix Released
Changed in gst-plugins-ugly1.0 (Ubuntu):
status: New → Fix Released
Changed in gst-python1.0 (Ubuntu):
status: New → Fix Released
Changed in gst-rtsp-server1.0 (Ubuntu):
status: New → Fix Released
Changed in gstreamer-editing-services1.0 (Ubuntu):
status: New → Fix Released
Changed in gstreamer-vaapi (Ubuntu):
status: New → Fix Released
Changed in gst-libav1.0 (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
status: New → In Progress
Changed in gst-plugins-bad1.0 (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
status: New → In Progress
Changed in gst-plugins-base1.0 (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
status: New → In Progress
Changed in gst-plugins-good1.0 (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
status: New → In Progress
Changed in gst-plugins-ugly1.0 (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
status: New → In Progress
Changed in gst-python1.0 (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
status: New → In Progress
Changed in gst-rtsp-server1.0 (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
status: New → In Progress
Changed in gstreamer-editing-services1.0 (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
status: New → In Progress
Changed in gstreamer-vaapi (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
status: New → In Progress
Changed in gstreamer1.0 (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
status: New → In Progress
Amr Ibrahim (amribrahim1987) wrote :

There is some activity upstream on the 1.14 branches, so there might be a 1.14.5, but I'm not sure:
https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/merge_requests/223
https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/merge_requests/198

Should this SRU wait for a 1.14.5 release?

Iain Lane (laney) wrote :

We can pick that up if it happens. Feel free to ask.

Hello Iain, or anyone else affected,

Accepted gst-rtsp-server1.0 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gst-rtsp-server1.0/1.14.4-1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gst-rtsp-server1.0 (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Steve Langasek (vorlon) wrote :

Hello Iain, or anyone else affected,

Accepted gstreamer1.0 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gstreamer1.0/1.14.4-1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gstreamer1.0 (Ubuntu Bionic):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Iain, or anyone else affected,

Accepted gstreamer-vaapi into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gstreamer-vaapi/1.14.4-1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gstreamer-vaapi (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in gstreamer-editing-services1.0 (Ubuntu Bionic):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Iain, or anyone else affected,

Accepted gstreamer-editing-services1.0 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gstreamer-editing-services1.0/1.14.4-1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Łukasz Zemczak (sil2100) wrote :

Hello Iain, or anyone else affected,

Accepted gst-plugins-good1.0 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gst-plugins-good1.0/1.14.4-1ubuntu1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gst-plugins-good1.0 (Ubuntu Bionic):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Iain, or anyone else affected,

Accepted gst-plugins-bad1.0 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gst-plugins-bad1.0/1.14.4-1ubuntu1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gst-plugins-bad1.0 (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in gst-python1.0 (Ubuntu Bionic):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Iain, or anyone else affected,

Accepted gst-python1.0 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gst-python1.0/1.14.4-1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gst-libav1.0 (Ubuntu Bionic):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Iain, or anyone else affected,

Accepted gst-libav1.0 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gst-libav1.0/1.14.4-0ubuntu1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gst-plugins-ugly1.0 (Ubuntu Bionic):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Iain, or anyone else affected,

Accepted gst-plugins-ugly1.0 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gst-plugins-ugly1.0/1.14.4-1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Iain Lane (laney) wrote :

I've verified these as best as I can. I installed 1.14.4 and played a load of different filetypes:

  - mp3
  - ogg
  - flac
  - opus
  - mp4 (H.264)

with different codecs, e.g. mpg123, libav, ...

and different players - epiphany, totem, rhythmbox.

I didn't find any regressions.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gstreamer1.0 - 1.14.4-1~ubuntu18.04.1

---------------
gstreamer1.0 (1.14.4-1~ubuntu18.04.1) bionic; urgency=medium

  * No-change backport to bionic (LP: #1829366)

gstreamer1.0 (1.14.4-1) unstable; urgency=medium

  * New upstream bugfix release

gstreamer1.0 (1.14.3-1) unstable; urgency=medium

  [ Hugh McMaster ]
  * gir1.2-gstreamer-1.0: Install the typelibs into a multi-arch library
    directory (Closes: #904266).
  * debian/control.in:
    - Mark gir1.2-gstreamer-1.0 Multi-Arch: same.
    - Remove a duplicate ${gir:Depends} variable from gir1.2-gstreamer-1.0.
    - Mark libgstreamer1.0-dev Multi-Arch: same (Closes: #823307).
  * debian/dh_gstscancodecs:
    - Call gst-codec-info-1.0 from the package's libexecdir path.
  * libgstreamer1.0-dev:
    - Install the gst-codec-info-1.0 utility into the package's multi-arch
      program executables directory (libexecdir).

  [ Sebastian Dröge ]
  * New upstream bugfix release.

gstreamer1.0 (1.14.2-2) unstable; urgency=medium

  * debian/patches/0002-gstconfig.h.in-initial-RISC-V-support.patch:
    + Add support for RISC-V (Closes: #895711).
  * debian/control.in:
    + Build-depend on libgmp-dev | libgmp3-dev (Closes: #862257).

gstreamer1.0 (1.14.2-1) unstable; urgency=medium

  * New upstream bugfix release

gstreamer1.0 (1.14.1-1) unstable; urgency=medium

  * New upstream bugfix release.

 -- Iain Lane <email address hidden> Thu, 16 May 2019 13:13:52 +0100

Changed in gstreamer1.0 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gstreamer1.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gstreamer-vaapi - 1.14.4-1~ubuntu18.04.1

---------------
gstreamer-vaapi (1.14.4-1~ubuntu18.04.1) bionic; urgency=medium

  * No-change backport to bionic (LP: #1829366)

gstreamer-vaapi (1.14.4-1) unstable; urgency=medium

  * New upstream bugfix release

gstreamer-vaapi (1.14.3-1) unstable; urgency=medium

  * New upstream bugfix release.

gstreamer-vaapi (1.14.2-1) unstable; urgency=medium

  * New upstream bugfix release

gstreamer-vaapi (1.14.1-1) unstable; urgency=medium

  * New upstream bugfix release

 -- Iain Lane <email address hidden> Thu, 16 May 2019 13:39:10 +0100

Changed in gstreamer-vaapi (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gstreamer-editing-services1.0 - 1.14.4-1~ubuntu18.04.1

---------------
gstreamer-editing-services1.0 (1.14.4-1~ubuntu18.04.1) bionic; urgency=medium

  * No-change backport to bionic (LP: #1829366)

gstreamer-editing-services1.0 (1.14.4-1) unstable; urgency=medium

  * New upstream bugfix release

gstreamer-editing-services1.0 (1.14.3-1) unstable; urgency=medium

  * New upstream bugfix release.
  * debian/control,
    debian/gir1.2-ges-1.0.install:
    + Various multi-arch fixes.

gstreamer-editing-services1.0 (1.14.2-1) unstable; urgency=medium

  * New upstream bugfix release

gstreamer-editing-services1.0 (1.14.1-1) unstable; urgency=medium

  * New upstream bugfix release

 -- Iain Lane <email address hidden> Thu, 16 May 2019 13:43:34 +0100

Changed in gstreamer-editing-services1.0 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-rtsp-server1.0 - 1.14.4-1~ubuntu18.04.1

---------------
gst-rtsp-server1.0 (1.14.4-1~ubuntu18.04.1) bionic; urgency=medium

  * No-change backport to bionic (LP: #1829366)

gst-rtsp-server1.0 (1.14.4-1) unstable; urgency=medium

  * New upstream bugfix release

gst-rtsp-server1.0 (1.14.3-1) unstable; urgency=medium

  * New upstream bugfix release.
  * debian/control,
    debian/gir1.2-gst-rtsp-server-1.0.install:
    + Various multi-arch fixes.

gst-rtsp-server1.0 (1.14.2-1) unstable; urgency=medium

  * New upstream bugfix release

gst-rtsp-server1.0 (1.14.1-1) unstable; urgency=medium

  * New upstream bugfix release

 -- Iain Lane <email address hidden> Thu, 16 May 2019 13:43:55 +0100

Changed in gst-rtsp-server1.0 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-python1.0 - 1.14.4-1~ubuntu18.04.1

---------------
gst-python1.0 (1.14.4-1~ubuntu18.04.1) bionic; urgency=medium

  * No-change backport to bionic (LP: #1829366)

gst-python1.0 (1.14.4-1) unstable; urgency=medium

  * New upstream bugfix release

gst-python1.0 (1.14.3-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-python1.0 (1.14.2-1) unstable; urgency=medium

  * New upstream bugfix release

gst-python1.0 (1.14.1-1) unstable; urgency=medium

  * New upstream bugfix release

 -- Iain Lane <email address hidden> Thu, 16 May 2019 13:42:44 +0100

Changed in gst-python1.0 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-ugly1.0 - 1.14.4-1~ubuntu18.04.1

---------------
gst-plugins-ugly1.0 (1.14.4-1~ubuntu18.04.1) bionic; urgency=medium

  * No-change backport to bionic (LP: #1829366)

gst-plugins-ugly1.0 (1.14.4-1) unstable; urgency=medium

  * New upstream bugfix release

gst-plugins-ugly1.0 (1.14.3-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-plugins-ugly1.0 (1.14.2-1) unstable; urgency=medium

  * New upstream bugfix release

gst-plugins-ugly1.0 (1.14.1-1) unstable; urgency=medium

  * New upstream bugfix release

 -- Iain Lane <email address hidden> Thu, 16 May 2019 13:19:31 +0100

Changed in gst-plugins-ugly1.0 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.1 KiB)

This bug was fixed in the package gst-plugins-good1.0 - 1.14.4-1ubuntu1~ubuntu18.04.1

---------------
gst-plugins-good1.0 (1.14.4-1ubuntu1~ubuntu18.04.1) bionic; urgency=medium

  * No-change backport to bionic (LP: #1829366)

gst-plugins-good1.0 (1.14.4-1ubuntu1) cosmic; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    + Import plugins from -bad that are needed for main applications.
      - jpegformat
      - camerabin (+ basecamerabinsrc + photography)
    + Break and Replace -bad versions which contained these plugins.
    + Add a library package containing the shared library and a -dev package for
      compiling against it. Add Breaks and Replaces against the plugins packages
      which formerly contained files shipped here.
    + Add 'pluginsdir' variable to our added pcfile for compatibility with
      some external software
    + debian/control{,.in}: Update Vcs-* for Ubuntu

gst-plugins-good1.0 (1.14.4-1) unstable; urgency=medium

  * New upstream bugfix release

gst-plugins-good1.0 (1.14.3-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-plugins-good1.0 (1.14.2-1ubuntu3) cosmic; urgency=medium

  * Add some information on previous patch about the new upstream issue:
    https://bugzilla.gnome.org/show_bug.cgi?id=796879

gst-plugins-good1.0 (1.14.2-1ubuntu2) cosmic; urgency=medium

  * debian/patches/b03df1abf828514b0966db058388bf974ed0cf4f.patch:
    revert upstream b03df1abf828514b0966db058388bf974ed0cf4f making
    the package FTBFS on arm* / Ubuntu

gst-plugins-good1.0 (1.14.2-1ubuntu1) cosmic; urgency=low

  * Merge from Debian unstable. Remaining changes:
    + Import plugins from -bad that are needed for main applications.
      - jpegformat
      - camerabin (+ basecamerabinsrc + photography)
    + Break and Replace -bad versions which contained these plugins.
    + Add a library package containing the shared library and a -dev package for
      compiling against it. Add Breaks and Replaces against the plugins packages
      which formerly contained files shipped here.
    + Add 'pluginsdir' variable to our added pcfile for compatibility with
      some external software
    + debian/control{,.in}: Update Vcs-* for Ubuntu

gst-plugins-good1.0 (1.14.2-1) unstable; urgency=medium

  * New upstream bugfix release

gst-plugins-good1.0 (1.14.1-1ubuntu1) cosmic; urgency=medium

  * Merge with Debian unstable (LP: #1772898); remaining changes:
    + Import plugins from -bad that are needed for main applications.
      - jpegformat
      - camerabin (+ basecamerabinsrc + photography)
    + Break and Replace -bad versions which contained these plugins.
    + Add a library package containing the shared library and a -dev package for
      compiling against it. Add Breaks and Replaces against the plugins packages
      which formerly contained files shipped here.
    + Add 'pluginsdir' variable to our added pcfile for compatibility with
      some external software
    + debian/control{,.in}: Update Vcs-* for Ubuntu
  * Revert 1.14.0-{2,3,4}. We've worked around this issue in -base instead, so
    we don't need to disable Qt5 here.

 -- Iain Lane <email address hidden> Thu, 16 May 2019 13...

Read more...

Changed in gst-plugins-good1.0 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-base1.0 - 1.14.4-1ubuntu1.1~ubuntu18.04.1

---------------
gst-plugins-base1.0 (1.14.4-1ubuntu1.1~ubuntu18.04.1) bionic; urgency=medium

  * No-change backport to bionic (LP: #1829366)

gst-plugins-base1.0 (1.14.4-1ubuntu1.1) cosmic-security; urgency=medium

  * SECURITY UPDATE: heap overflow in RTSP parser
    - debian/patches/CVE-2019-9928.patch: limit length in
      gst-libs/gst/rtsp/gstrtspconnection.c.
    - CVE-2019-9928

gst-plugins-base1.0 (1.14.4-1ubuntu1) cosmic; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    + debian/rules: Build for GLES only on arm. We build OpenGL support, which
      conflicts with Qt's OpenGL support - used in gst-good - if built for a
      different implementation. This fixes an FTBFS of gst-plugins-good1.0 due
      to conflicting typedefs being dragged in by gst and Qt. This might be a
      bug in mesa - if the headers are supposed to be includable simultaneously.
      See FDO #105328 for that.

gst-plugins-base1.0 (1.14.4-1) unstable; urgency=medium

  * New upstream bugfix release

gst-plugins-base1.0 (1.14.3-2) unstable; urgency=medium

  [ Hugh McMaster ]
  * debian/control.in:
    - Mark gir1.2-gst-plugins-base-1.0 Multi-Arch: same.

  [ Sebastian Dröge ]
  * Upload to unstable.

gst-plugins-base1.0 (1.14.3-1) unstable; urgency=medium

  [ Hugh McMaster ]
  * gir1.2-gst-plugins-base-1.0: Install the typelibs into a multi-arch library
    directory (Closes: #907808).
  * debian/control.in:
    - Mark libgstreamer-plugins-base1.0-dev Multi-Arch: same (Closes: #862119).

  [ Sebastian Dröge ]
  * New upstream bugfix release.

gst-plugins-base1.0 (1.14.2-1ubuntu1) cosmic; urgency=low

  * Merge from Debian unstable. Remaining changes:
    + debian/rules: Build for GLES only on arm. We build OpenGL support, which
      conflicts with Qt's OpenGL support - used in gst-good - if built for a
      different implementation. This fixes an FTBFS of gst-plugins-good1.0 due
      to conflicting typedefs being dragged in by gst and Qt. This might be a
      bug in mesa - if the headers are supposed to be includable simultaneously.
      See FDO #105328 for that.

gst-plugins-base1.0 (1.14.2-1) unstable; urgency=medium

  * New upstream bugfix release

gst-plugins-base1.0 (1.14.1-1ubuntu1) cosmic; urgency=medium

  * Merge with Debian (LP: #1772898). Remaining change:
    + debian/rules: Build for GLES only on arm. We build OpenGL support, which
      conflicts with Qt's OpenGL support - used in gst-good - if built for a
      different implementation. This fixes an FTBFS of gst-plugins-good1.0 due
      to conflicting typedefs being dragged in by gst and Qt. This might be a
      bug in mesa - if the headers are supposed to be includable simultaneously.
      See FDO #105328 for that.

 -- Iain Lane <email address hidden> Thu, 16 May 2019 13:18:37 +0100

Changed in gst-plugins-base1.0 (Ubuntu Bionic):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-bad1.0 - 1.14.4-1ubuntu1~ubuntu18.04.1

---------------
gst-plugins-bad1.0 (1.14.4-1ubuntu1~ubuntu18.04.1) bionic; urgency=medium

  * No-change backport to bionic (LP: #1829366)

gst-plugins-bad1.0 (1.14.4-1ubuntu1) cosmic; urgency=medium

  * Merge with Debian unstable; remaining changes:
    + Stop installing camerabin2 basecamerabin jpegformat - plugins which have
      moved to -good.
    + Provide gstreamer-plugins-bad-1.0.pc with Requires on
      gstreamer-plugins-good-1.0 - the package we've moved the referenced
      library to. This maintains compatibility with upstream software and
      other distributions.
    + debian/control{,.in}: Update Vcs-* for Ubuntu
  * debian/gbp.conf: Set the debian-branch to ubuntu

gst-plugins-bad1.0 (1.14.4-1) unstable; urgency=medium

  * New upstream bugfix release

gst-plugins-bad1.0 (1.14.3-1) unstable; urgency=medium

  [ Hugh McMaster ]
  * gir1.2-gst-plugins-bad-1.0: Install the typelibs into a multi-arch
    library directory.
  * debian/control.in:
    - Mark gir1.2-gst-plugins-bad-1.0 Multi-Arch: same.
    - Remove a duplicate ${gir:Depends} from gir1.2-gst-plugins-bad-1.0.
    - Mark libgstreamer-plugins-bad1.0-dev Multi-Arch: same.

  [ Sebastian Dröge ]
  * New upstream bugfix release.

gst-plugins-bad1.0 (1.14.2-1ubuntu1) cosmic; urgency=low

  * Merge from Debian unstable. Remaining changes:
    + Stop installing camerabin2 basecamerabin jpegformat - plugins which have
      moved to -good.
    + Provide gstreamer-plugins-bad-1.0.pc with Requires on
      gstreamer-plugins-good-1.0 - the package we've moved the referenced
      library to. This maintains compatibility with upstream software and
      other distributions.
    + debian/control{,.in}: Update Vcs-* for Ubuntu

gst-plugins-bad1.0 (1.14.2-1) unstable; urgency=medium

  * New upstream bugfix release

gst-plugins-bad1.0 (1.14.1-1ubuntu2) cosmic; urgency=medium

  * No-change rebuild for x265 soname change.

gst-plugins-bad1.0 (1.14.1-1ubuntu1) cosmic; urgency=medium

  * Merge with Debian unstable (LP: #1772898); remaining changes:
    + Stop installing camerabin2 basecamerabin jpegformat - plugins which have
      moved to -good.
    + Provide gstreamer-plugins-bad-1.0.pc with Requires on
      gstreamer-plugins-good-1.0 - the package we've moved the referenced
      library to. This maintains compatibility with upstream software and
      other distributions.
    + debian/control{,.in}: Update Vcs-* for Ubuntu

 -- Iain Lane <email address hidden> Thu, 16 May 2019 13:19:09 +0100

Changed in gst-plugins-bad1.0 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-libav1.0 - 1.14.4-0ubuntu1~ubuntu18.04.1

---------------
gst-libav1.0 (1.14.4-0ubuntu1~ubuntu18.04.1) bionic; urgency=medium

  * New upstream bugfix release (LP: #1829366)

 -- Iain Lane <email address hidden> Thu, 16 May 2019 13:23:37 +0100

Changed in gst-libav1.0 (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.