[16.04] latest gstreamer1.0 update broke WMA support for some audio & video players

Bug #1661799 reported by jay
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gstreamer1.0 (Ubuntu)
High
Unassigned

Bug Description

Noise won't play any .wma files after Elementary OS update. It displays a message saying it needs the .wma plugin to work (even though it has always worked on .wma files). Asks if I want to download the plugin but then can't find the plugin.

Revision history for this message
Vlad Orlov (monsta) wrote :

Same happens in xplayer (a fork of Totem). When trying to play a .wmv file, it shows an error dialog about no support for Windows Media Audio. In the terminal it shows this message:

** Message: Missing plugin: gstreamer|1.0|xplayer|Windows Media Audio 9 decoder|decoder-audio/x-wma, wmaversion=(int)3, bitrate=(int)128040 (Windows Media Audio 9 decoder)

This regression started yesterday with the simultaneous upgrade of the following source packages:

- gstreamer1.0: 1.8.2-1~ubuntu1 -> 1.8.3-1~ubuntu0.1
- gst-plugins-base1.0: 1.8.2-1ubuntu0.2 -> 1.8.3-1ubuntu0.1
- gst-plugins-good1.0: 1.8.2-1ubuntu0.3 -> 1.8.3-1ubuntu0.3
- gst-plugins-bad1.0: 1.8.2-1ubuntu0.2 -> 1.8.3-1ubuntu0.2
- gst-plugins-ugly1.0: 1.8.2-1ubuntu0.1 -> 1.8.3-1ubuntu0.1
- gst-libav1.0: 1.8.2-1~ubuntu1 -> 1.8.3-1ubuntu0.1

I have no idea which of them broke things, but the bug needs to be reassigned, so let it be gstreamer1.0.

affects: noise → gstreamer1.0
affects: gstreamer1.0 → gstreamer1.0 (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gstreamer1.0 (Ubuntu):
status: New → Confirmed
Revision history for this message
Vlad Orlov (monsta) wrote :

Forgot to mention that it's in 16.04. Got it from xenial-updates repo, and the changelog hints that it was a backport from 16.10.

tags: added: regression-update xenial
Vlad Orlov (monsta)
summary: - Noise won't play any WMA files after recent Elementary OS upgrade
+ [16.04] latest gstreamer1.0 update broke WMA support for some audio &
+ video players
Changed in gstreamer1.0 (Ubuntu):
importance: Undecided → High
Revision history for this message
David (david-9ei9nyjpwdex) wrote :

Parole will no longer play .wmv files in Ubuntu 16.04.2 LTS since the recent point update.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers