Totem can't play H264 on fresh 16.04 beta install

Bug #1562875 reported by Hangman on 2016-03-28
102
This bug affects 21 people
Affects Status Importance Assigned to Milestone
gstreamer1.0 (Ubuntu)
High
Unassigned

Bug Description

Totem can't play neither find the correct codec to play H264 *.mp4 video in last 16.04 beta.

Terminal says :

** Message: Missing plugin: gstreamer|1.0|totem|H.264 (Main Profile) decoder|decoder-video/x-h264, stream-format=(string)avc, alignment=(string)au, level=(string)4, profile=(string)main, max-input-size=(int)51696, parsed=(boolean)true (H.264 (Main Profile) decoder)

Totem tries to find the correct codec but fails, see attachment

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: libgstreamer1.0-0 1.8.0-1
ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
Uname: Linux 4.4.0-15-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Mar 28 15:51:47 2016
InstallationDate: Installed on 2016-03-26 (2 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
LogAlsaMixer: Error: command ['/usr/bin/amixer'] failed with exit code 1: amixer: Mixer attach default error: No such file or directory
ProcEnviron:
 LANGUAGE=fr_FR
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: gstreamer1.0
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Hangman (hangman-hotmail) wrote :
Revision history for this message
Hangman (hangman-hotmail) wrote :

In fact I can't play any other videos...

"Impossible de trouver le greffon requis

Vidéos nécessite d'installer un greffon pour lire les fichiers multimédias du type suivant : DivX MPEG-4 Version 5 decoder"

Revision history for this message
mnoveli (mnoveli) wrote :

I have some problem Totem can't play H264 on fresh 16.04 beta install
solution ?

Revision history for this message
mnoveli (mnoveli) wrote :

my ubuntu 16.04 betaa toten black screen video .mp4

Revision history for this message
Bruce Arnold (barnold) wrote :

I have some problem Totem can't play H264 on fresh 16.04 beta install.
Required plugin could not be found. Mp4 audio works fine. Here's the error message:
"Videos requires to install plugins to play media files of the following type: H.264 (High Profile) decoder."
These solutions ran without errors but made no improvement:
  sudo apt-get install libdvd-pkg
  sudo dpkg-reconfigure libdvd-pkg
Solution ?

Revision history for this message
Hangman (hangman-hotmail) wrote :

Temporary solution is to use VLC instead....

information type: Public → Public Security
information type: Public Security → Private Security
information type: Private Security → Public
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gstreamer1.0 (Ubuntu):
status: New → Confirmed
Revision history for this message
Michael Kofler (michael-kofler) wrote :

In my tests, Totem plus ubuntu-restricted-extras works on various test systems. The only exception is a PC with an AMD graphics card (Radeon HD 7700). Could this be the cause? On the same PC, VLC works fine.

Revision history for this message
Bruce Arnold (barnold) wrote :

Ubuntu-restricted-extras version 65 is already installed but to no avail. System is Intel MB with GMA x4500 built in graphics. System has all updates through today. After installation of VLC, there is no change in the error message on Totem, however, VLC plays the video fine. This is probable a good clue.

Changed in gstreamer1.0 (Ubuntu):
importance: Undecided → High
Revision history for this message
darkenergy (darkenergy) wrote :

I can confirm this...

Revision history for this message
ike (ikeahloe) wrote :

can confirm Bruce Arnold's latest statement. VLC plays fine. Totem will not play videos even though all ubuntu restricted extras are installed

Revision history for this message
dino99 (9d9) wrote :
Revision history for this message
emptythevoid (emptythevoid) wrote :

Mine broke on upgrade from 14.04 -> 15.10 -> 16.04 64 bit. I removed the multiverse repository, reloaded, added it back in, reloaded, then from the command line, reinstalled ubuntu-restricted-extras. For some reason, Synaptic wasn't installing anything. It just blinked and said all was well. I had to use apt-get to get it to do anything. May not be related to this bug, but I'm sharing just in case.

Revision history for this message
Hamidreza Hanafi (hrh0001) wrote :

Is it only in beta install? or anyone with fresh release install have same issue?
Anyone wants to do anything? many embedded applications which plays video are failing and it's sad!

Revision history for this message
snerge (snerge) wrote :

@Hamidreza,

I upgraded from 15.10 to 16.04 and I now have the issue. The audio plays in Totem but no video. VLC does work but is pretty laggy when I scroll.

Revision history for this message
snerge (snerge) wrote :

@Hamidreze,

I have just tested it with a new user account and Totem was working fine. I digged a little and deleted the folder "gstreamer-1.0" in the ".cache" folder in my home and it's now working again in my other account

Revision history for this message
Alex_K (alex-keusch) wrote :

I had the same issue after a beta install, and upgrade to final.

Removing the ~/.cache/gestreamer-1.0 folder, as proposed by snerge, also solved the problem on my machine.

Revision history for this message
Hamidreza Hanafi (hrh0001) wrote :

@Snerge
Thanks. Now everything is working. please set it as solved.

Revision history for this message
snerge (snerge) wrote :

glad it worked for you both as it did for me !

Revision history for this message
Andreas Kern (kerna) wrote :

I was affected too, here the code i used inside a terminal to remove the folder

```
rm -r ~/.cache/gstreamer-1.0
```

Revision history for this message
Orkerom (orkerom) wrote :

Same for me. Black screen With all video players VLC , Totem . Actual I use firefox to play my videos

Revision history for this message
corrado venturini (corradoventu) wrote :

I have a similar problem in Ubuntu 17.10 with last totem release and also with the preceding one (Installed: 3.25.90.1-0ubuntu1)
corrado@corrado-HP-aa-p5:~$ apt policy totem
totem:
  Installed: 3.25.90.1-0ubuntu2
  Candidate: 3.25.90.1-0ubuntu2
  Version table:
 *** 3.25.90.1-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu artful/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-HP-aa-p5:~$

see my bug: https://bugs.launchpad.net/ubuntu/+source/gstreamer1.0/+bug/1711067

removing the cash folder had no effect.

Revision history for this message
corrado venturini (corradoventu) wrote :

trying to play an .mp4 I have a message:
corrado@corrado-HP-aa-p5:~/Videos$ totem vid.mp4
** Message: Missing plugin: gstreamer|1.0|totem|MPEG-4 AAC decoder|decoder-audio/mpeg, mpegversion=(int)4, level=(string)1, base-profile=(string)lc, profile=(string)lc (MPEG-4 AAC decoder)
** Message: Missing plugin: gstreamer|1.0|totem|H.264 (Constrained Baseline Profile) decoder|decoder-video/x-h264, level=(string)3, profile=(string)constrained-baseline (H.264 (Constrained Baseline Profile) decoder)
(totem:2812): Totem-WARNING **: Failed to reset the playback rate to 1.0
corrado@corrado-HP-aa-p5:~/Videos$
and a box proposing a button 'find in software' I click on this button but nothing happens.

Revision history for this message
corrado venturini (corradoventu) wrote :

My problem disappeared on new installation from Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170903) with new totem:
corrado@corrado-HP-aa-p6:~$ apt policy totem
totem:
  Installed: 3.25.90.1-0ubuntu3
  Candidate: 3.25.90.1-0ubuntu3
  Version table:
 *** 3.25.90.1-0ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu artful/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-HP-aa-p6:~$

Changed in gstreamer1.0 (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Hồng Quân (ng-hong-quan) wrote :

It appears again on Ubuntu 17.10

Totem message:

** Message: Missing plugin: gstreamer|1.0|totem|H.264 (High Profile) decoder|decoder-video/x-h264, level=(string)3.1, profile=(string)high, interlace-mode=(string)progressive (H.264 (High Profile) decoder)

And I already install gstreamer1.0-plugins-ugly

$ apt policy gstreamer1.0-plugins-ugly
gstreamer1.0-plugins-ugly:
  Installed: 1.12.3-1
  Candidate: 1.12.3-1
  Version table:
 *** 1.12.3-1 500
        500 http://opensource.xtdv.net/ubuntu artful/universe amd64 Packages
        100 /var/lib/dpkg/status

Revision history for this message
Roger (r-j-m-jeurissen-1) wrote :

In ubuntu 17.10, this issue disappeared after I installed gstreamer1.0-libav.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers