Update to 1.6.3

Bug #1538524 reported by Iain Lane on 2016-01-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gst-libav1.0 (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
gst-plugins-bad1.0 (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
gst-plugins-base1.0 (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
gst-plugins-good1.0 (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
gst-plugins-ugly1.0 (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
gstreamer1.0 (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned

Bug Description

[ Description ]

We should stick with upstream's stable bugfix releases in 15.10

[ Test plan & QA ]

Play a range of videos in Totem. Play a range of audio tracks in Rhythmbox. Try to stream audio and/or video. Try to install a missing codec.

In all cases, make sure that everything which worked before still works.

[ Regression potential ]

This is a pure bugfix release, but there is always a chance that one of the fixes could be wrong.

[ Development release ]

Xenial is on a different 1.7 series and will be on 1.8 by release. All commits to the stable branch should come from the master branches that 1.7 releases are made from, although there might be slight differences in release timing that means one is released before the other.

Iain Lane (laney) on 2016-01-27
Changed in gst-libav1.0 (Ubuntu):
status: New → Fix Released
Changed in gst-plugins-bad1.0 (Ubuntu):
status: New → Fix Released
Changed in gst-plugins-base1.0 (Ubuntu):
status: New → Fix Released
Changed in gst-plugins-good1.0 (Ubuntu):
status: New → Fix Released
Changed in gst-plugins-ugly1.0 (Ubuntu):
status: New → Fix Released
Changed in gstreamer1.0 (Ubuntu):
status: New → Fix Released

Hello Iain, or anyone else affected,

Accepted gst-libav1.0 into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gst-libav1.0/1.6.3-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gst-libav1.0 (Ubuntu Wily):
status: New → Fix Committed
tags: added: verification-needed
Changed in gst-plugins-bad1.0 (Ubuntu Wily):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Iain, or anyone else affected,

Accepted gst-plugins-bad1.0 into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gst-plugins-bad1.0/1.6.3-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gst-plugins-base1.0 (Ubuntu Wily):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Iain, or anyone else affected,

Accepted gst-plugins-base1.0 into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gst-plugins-base1.0/1.6.3-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Iain, or anyone else affected,

Accepted gst-plugins-good1.0 into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gst-plugins-good1.0/1.6.3-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gst-plugins-good1.0 (Ubuntu Wily):
status: New → Fix Committed
Changed in gst-plugins-ugly1.0 (Ubuntu Wily):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Iain, or anyone else affected,

Accepted gst-plugins-ugly1.0 into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gst-plugins-ugly1.0/1.6.3-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gstreamer1.0 (Ubuntu Wily):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Iain, or anyone else affected,

Accepted gstreamer1.0 into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gstreamer1.0/1.6.3-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: upgrade-software-version
Iain Lane (laney) wrote :

Someone gave a +1 on the other bug - if that's good enough, please release.

tags: added: verification-done-wily
removed: verification-needed wily

Tested all of these packages on Wily (Kubuntu). Absolutely no problems at all.. Thanks.

tags: added: verification-done wily
removed: verification-done-wily
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-libav1.0 - 1.6.3-1ubuntu1

---------------
gst-libav1.0 (1.6.3-1ubuntu1) wily; urgency=medium

  * No-change upload from Debian to Wily for SRU. (LP: #1538524)

gst-libav1.0 (1.6.3-1) unstable; urgency=medium

  * New upstream bugfix release.
  * debian/patches/0001-avdeinterlace-Port-non-deprecated-AVFilter-API.patch,
    debian/patches/0002-libav-Remove-usage-of-deprecated-API.patch,
    debian/patches/0003-libav-Bitrate-field-changed-from-int-to-int64_t-fix-.patch,
    debian/patches/0004-avdeinterlace-Chain-up-to-parent-class-dispose.patch:
    + Prepare for ffmpeg 2.9 by removing usage of some deprecated API.

gst-libav1.0 (1.6.2-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-libav1.0 (1.6.1-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-libav1.0 (1.6.0-2) unstable; urgency=medium

  * debian/patches/0001-avviddec-fix-memory-leak.patch,
    debian/patches/0002-avviddec-only-free-config-when-pool-doesn-t-take-own.patch:
    + Fix some memory leaks.
  * debian/patches/0005-avvidenc-Pass-the-correct-user_data-to-gst_buffer_ne.patch,
    debian/patches/0006-avcodecmap-Don-t-allocate-dummy-codec-data-anymore-i.patch:
    + Fix crashes in the video encoders (Closes: #800779).

 -- Iain Lane <email address hidden> Wed, 27 Jan 2016 12:58:59 +0000

Changed in gst-libav1.0 (Ubuntu Wily):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gst-libav1.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-base1.0 - 1.6.3-1ubuntu1

---------------
gst-plugins-base1.0 (1.6.3-1ubuntu1) wily; urgency=medium

  * Merge from Debian unstable for wily SRU (LP: #1538524, #1529445).
    Remaining changes:
    + 0001-riff-Add-input-buffer-size-to-GstCaps.patch: Take patch from
      Alfonso Sanchez-Beato on upstream bug #737599 to add a field in the
      GstCaps containing the suggested buffer size for this stream.
    + Update Vcs-* for Ubuntu

gst-plugins-base1.0 (1.6.3-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-plugins-base1.0 (1.6.2-1ubuntu1) xenial; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    + 0001-riff-Add-input-buffer-size-to-GstCaps.patch: Take patch from
      Alfonso Sanchez-Beato on upstream bug #737599 to add a field in the
      GstCaps containing the suggested buffer size for this stream.
    + Update Vcs-* for Ubuntu

gst-plugins-base1.0 (1.6.2-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-plugins-base1.0 (1.6.1-1ubuntu1) xenial; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    + 0001-riff-Add-input-buffer-size-to-GstCaps.patch: Take patch from
      Alfonso Sanchez-Beato on upstream bug #737599 to add a field in the
      GstCaps containing the suggested buffer size for this stream.
    + Update Vcs-* for Ubuntu

gst-plugins-base1.0 (1.6.1-1) unstable; urgency=medium

  * debian/control.in:
    + Remove Recommends on alsa-base, it's a useless dummy package
      and not needed anyway (Closes: #785268).
  * New upstream bugfix release.

 -- Iain Lane <email address hidden> Wed, 27 Jan 2016 12:48:06 +0000

Changed in gst-plugins-base1.0 (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-good1.0 - 1.6.3-1ubuntu1

---------------
gst-plugins-good1.0 (1.6.3-1ubuntu1) wily; urgency=medium

  * Merge with Debian unstable for Wily (LP: #1538524); remaining changes:
    + Import plugins from -bad that are needed for main applications.
      - jpegformat
      - camerabin2 (+ basecamerabinsrc + photography)
    + Break and Replace -bad versions which contained these plugins.
    + Add a library package containing the shared library and a -dev package for
      compiling against it. Add Breaks and Replaces against the plugins packages
      which formerly contained files shipped here.
    + Add 'pluginsdir' variable to our added pcfile for compatibility with
      some external software
    + debian/control{,.in}: Update Vcs-* for Ubuntu

gst-plugins-good1.0 (1.6.3-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-plugins-good1.0 (1.6.2-1ubuntu1) xenial; urgency=medium

  * Merge with Debian unstable; remaining changes:
    + Import plugins from -bad that are needed for main applications.
      - jpegformat
      - camerabin2 (+ basecamerabinsrc + photography)
    + Break and Replace -bad versions which contained these plugins.
    + Add a library package containing the shared library and a -dev package for
      compiling against it. Add Breaks and Replaces against the plugins packages
      which formerly contained files shipped here.
    + Add 'pluginsdir' variable to our added pcfile for compatibility with
      some external software
    + debian/control{,.in}: Update Vcs-* for Ubuntu

gst-plugins-good1.0 (1.6.2-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-plugins-good1.0 (1.6.1-1ubuntu1) xenial; urgency=medium

  * Merge with Debian unstable; remaining changes:
    + Import plugins from -bad that are needed for main applications.
      - jpegformat
      - camerabin2 (+ basecamerabinsrc + photography)
    + Break and Replace -bad versions which contained these plugins.
    + Add a library package containing the shared library and a -dev package for
      compiling against it. Add Breaks and Replaces against the plugins packages
      which formerly contained files shipped here.
    + Add 'pluginsdir' variable to our added pcfile for compatibility with
      some external software
    + debian/control{,.in}: Update Vcs-* for Ubuntu

gst-plugins-good1.0 (1.6.1-1) unstable; urgency=medium

  * New upstream bugfix release.

 -- Iain Lane <email address hidden> Wed, 27 Jan 2016 13:03:22 +0000

Changed in gst-plugins-good1.0 (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package gst-plugins-bad1.0 - 1.6.3-1ubuntu1

---------------
gst-plugins-bad1.0 (1.6.3-1ubuntu1) wily; urgency=medium

  * Merge with Debian experimental for wily (LP: #1538524); remaining changes:
    + Stop installing camerabin2 basecamerabin jpegformat - plugins which have
    moved to -good.
    + Provide gstreamer-plugins-bad-1.0.pc with Requires on
      gstreamer-plugins-good-1.0 - the package we've moved the referenced
      library to. This maintains compatibility with upstream software and
      other distributions.
    + debian/patches/adding-mirsink-and-android-media-over-hybris-support.patch:
      - Adding mirsink and Android media over hybris support, for hardware
        accelerated decode using libstagefright and the hybris compat layer.
    + debian/control.in:
      - Making the hybris plugin as part of a separated package, and i386 and
        armhf only (can only work with android compatible archs)
    + debian/build-deps.in:
      - Adding mirsink/android decoder specific build dependencies for i386 and
        armhf (libplatform-api1-dev and libmedia-dev)
    + Split videoparsers and faad out into their own packages.
    + Disable gl and glx on armhf as it's not useful there.
    + debian/control{,.in}: Update Vcs-* for Ubuntu
    + debian/watch: Update Vcs-* for new URL scheme

gst-plugins-bad1.0 (1.6.3-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-plugins-bad1.0 (1.6.2-1ubuntu1) xenial; urgency=medium

  * Merge with Debian experimental; remaining changes:
    + Stop installing camerabin2 basecamerabin jpegformat - plugins which have
    moved to -good.
    + Provide gstreamer-plugins-bad-1.0.pc with Requires on
      gstreamer-plugins-good-1.0 - the package we've moved the referenced
      library to. This maintains compatibility with upstream software and
      other distributions.
    + debian/patches/adding-mirsink-and-android-media-over-hybris-support.patch:
      - Adding mirsink and Android media over hybris support, for hardware
        accelerated decode using libstagefright and the hybris compat layer.
    + debian/control.in:
      - Making the hybris plugin as part of a separated package, and i386 and
        armhf only (can only work with android compatible archs)
    + debian/build-deps.in:
      - Adding mirsink/android decoder specific build dependencies for i386 and
        armhf (libplatform-api1-dev and libmedia-dev)
    + Split videoparsers and faad out into their own packages.
    + Disable gl and glx on armhf as it's not useful there.
    + debian/control{,.in}: Update Vcs-* for Ubuntu
    + debian/watch: Update Vcs-* for new URL scheme

gst-plugins-bad1.0 (1.6.2-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-plugins-bad1.0 (1.6.1-1ubuntu1) xenial; urgency=medium

  * Merge with Debian experimental; remaining changes:
    + Stop installing camerabin2 basecamerabin jpegformat - plugins which have
    moved to -good.
    + Provide gstreamer-plugins-bad-1.0.pc with Requires on
      gstreamer-plugins-good-1.0 - the package we've moved the referenced
      library to. This maintains compatibility with upstream software and
      other...

Read more...

Changed in gst-plugins-bad1.0 (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-ugly1.0 - 1.6.3-1ubuntu1

---------------
gst-plugins-ugly1.0 (1.6.3-1ubuntu1) wily; urgency=medium

  * Merge with Debian for wily (LP: #1538524). Remaining changes:
    + Split AMR out into a gstreamer1.0-plugins-ugly-amr package.
    + Run dh_install with --fail-missing to error out if files aren't
      installed.
    + debian/control{,.in}: Update Vcs-* for Ubuntu

gst-plugins-ugly1.0 (1.6.3-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-plugins-ugly1.0 (1.6.2-1ubuntu1) xenial; urgency=medium

  * Merge with Debian. Remaining changes:
    + Split AMR out into a gstreamer1.0-plugins-ugly-amr package.
    + Run dh_install with --fail-missing to error out if files aren't
      installed.
    + debian/control{,.in}: Update Vcs-* for Ubuntu

gst-plugins-ugly1.0 (1.6.2-1) unstable; urgency=medium

  * New upstream bugfix release.

gst-plugins-ugly1.0 (1.6.1-1ubuntu1) xenial; urgency=medium

  * Merge with Debian. Remaining changes:
    + Split AMR out into a gstreamer1.0-plugins-ugly-amr package.
    + Run dh_install with --fail-missing to error out if files aren't
      installed.
    + debian/control{,.in}: Update Vcs-* for Ubuntu

gst-plugins-ugly1.0 (1.6.1-1) unstable; urgency=medium

  * New upstream bugfix release.

 -- Iain Lane <email address hidden> Wed, 27 Jan 2016 13:15:23 +0000

Changed in gst-plugins-ugly1.0 (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gstreamer1.0 - 1.6.3-1ubuntu1

---------------
gstreamer1.0 (1.6.3-1ubuntu1) wily; urgency=medium

  * Upload from Debian unstable to wily. (LP: #1538524, #1529445)

gstreamer1.0 (1.6.3-1) unstable; urgency=medium

  * debian/control.in:
    + Build-depend on libgsl-dev | libgsl0-dev instead of just the latter.
  * New upstream bugfix release.

gstreamer1.0 (1.6.2-1) unstable; urgency=medium

  * New upstream bugfix release.

gstreamer1.0 (1.6.1-1) unstable; urgency=medium

  * New upstream bugfix release.

 -- Iain Lane <email address hidden> Wed, 27 Jan 2016 12:24:32 +0000

Changed in gstreamer1.0 (Ubuntu Wily):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers