Ubuntu

MP3s skipping with GStreamer 0.8.8

Reported by JonathanTurner on 2005-03-09
10
Affects Status Importance Assigned to Milestone
gstreamer0.8 (Ubuntu)
Medium
Sebastien Bacher

Bug Description

While Muine worked perfectly with GStreamer 0.8.7, seemingly now when Muine
plays a song for the first time with GStreamer 0.8.8 after the first second the
song will hiccup. This is repeatable, and only seems to affect Muine and not
Rhythmbox (which plays as expected). The type of file in question is mp3.

This is in Hoary using the 2.6.10 kernel, ALSA, and Intel sound card.

I can confirm this happens with Totem as well as with Muine. Adjusting summary
accordingly, as this is probably a GStreamer bug.

Sebastien Bacher (seb128) wrote :

that's weird that you don't get the issue rhythmbox if that's a gstreamer issue.
Does it happens with ogg files too ? Could you change the audiosink in gstreamer
properties to alsasink or osssink to see if that's better ?

JonathanTurner (probata) wrote :

(In reply to comment #2)
> that's weird that you don't get the issue rhythmbox if that's a gstreamer issue.
> Does it happens with ogg files too ? Could you change the audiosink in gstreamer
> properties to alsasink or osssink to see if that's better ?

esdsink, alsasink, and osssink all skip at the exact same spot for the exact
same length of skip. Could it be something muine had been working around that
has gotten fixed in 0.8.8?

This only occurs with mp3s and not ogg files. Also, I've only noticed it with
Muine and not Rhythmbox or Totem.

Brandon Hale (brandon) wrote :

Guys, its not odd that you dont see this in rhythmbox.
Mhttp://bugzilla.gnome.org/show_bug.cgi?id=169073uine uses a different
playback mechanism, playbin. Totem I believe uses it to, so it is somewhat odd
that we
arent seeing it there.

Fix in upstream CVS:
http://bugzilla.gnome.org/show_bug.cgi?id=159676

Fix the fix (double locking bug)
http://bugzilla.gnome.org/show_bug.cgi?id=169073

I'm building a test package here as we speak, will post a link for reporters to
confirm fixage.

Brandon Hale (brandon) wrote :

Backported gstqueue changes from CVS at revision 1.118
This fixes the following bugs, including the two posted in my previous comment:

http://bugzilla.gnome.org/show_bug.cgi?id=159676
http://bugzilla.gnome.org/show_bug.cgi?id=169073

unrelated but trivial fix, worth having:
http://bugzilla.gnome.org/show_bug.cgi?id=166250

Brandon Hale (brandon) wrote :

Created an attachment (id=1605)
gstqueue backport from cvs

Sebastien Bacher (seb128) wrote :

thanks, this uploads fixes the bug:

 gstreamer0.8 (0.8.9-1ubuntu2) hoary; urgency=low
 .
   * debian/patches/gstqueue-fix.diff:
     - backport from the CVS to fix some mp3 playing issue in muine/totem, patch
       by Brandon Hale <email address hidden> (Hoary: #7359).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.