capplets: gnome-settings-daemon dies repeatedly with SIGILL

Bug #13069 reported by Debian Bug Importer on 2005-02-18
8
Affects Status Importance Assigned to Milestone
gstreamer0.8 (Debian)
Fix Released
Unknown
gstreamer0.8 (Ubuntu)
Medium
Sebastien Bacher

reassign 289362 libgstreamer0.8-0
thanks

As the bug seems to be caused by the libgstreamer, I'm reassigning the
bug

Arnaud

forwarded 289362 http://bugzilla.gnome.org/show_bug.cgi?id=166696
thanks

        Hi,

 This is a followup for Debian bug <http://bugs.debian.org/289362>.

Richard Mortimer <email address hidden> - Sat, Jan 08, 2005:

> I have just loaded Debian/testing on an old Cyrix P133+ based machine
> and when I attempted to start control-center I found that
> gnome-settings-daemon was continually crashing with a SIGILL. I got a
> backtrace from GDB which shows it was running libgstreamer-0.8.so.1 code
> and had executed a cpuid instruction. I'm presuming that this is either
> privileged or not-implemented on the cpu.

 I've reported your bug upstream and you might want to subscribe to the
 upstream discussion at:
    <http://bugzilla.gnome.org/show_bug.cgi?id=166696>

 The solution isn't easy, and support for Cyrix or 386 CPUs is not on
 upstream's priorities, hence your problem might take a while to be
 fixed.

   Regards,

--
Loïc Minier <email address hidden>
"Neutral President: I have no strong feelings one way or the other."

severity 289362 serious
thanks

 Discussing this with the release team, it seems #289362 is RC.

--
Loïc Minier <email address hidden>
"Neutral President: I have no strong feelings one way or the other."

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #289362 http://bugs.debian.org/289362

Debian Bug Importer (debzilla) wrote :
Download full text (7.7 KiB)

Message-Id: <email address hidden>
Date: Sat, 08 Jan 2005 18:07:39 +0000
From: Richard Mortimer <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: capplets: gnome-settings-daemon dies repeatedly with SIGILL

Package: capplets
Version: 1:2.8.1-3
Severity: important

I have just loaded Debian/testing on an old Cyrix P133+ based machine
and when I attempted to start control-center I found that
gnome-settings-daemon was continually crashing with a SIGILL. I got a
backtrace from GDB which shows it was running libgstreamer-0.8.so.1 code
and had executed a cpuid instruction. I'm presuming that this is either
privileged or not-implemented on the cpu.

(gdb) cont
Continuing.

Program received signal SIGILL, Illegal instruction.
0x40078a7e in _gst_cpu_initialize_none () from
/usr/lib/libgstreamer-0.8.so.1
(gdb) where
#0 0x40078a7e in _gst_cpu_initialize_none ()
   from /usr/lib/libgstreamer-0.8.so.1
#1 0x40078b1e in _gst_cpu_initialize_i386 ()
   from /usr/lib/libgstreamer-0.8.so.1
#2 0x400789b8 in _gst_cpu_initialize () from
   /usr/lib/libgstreamer-0.8.so.1
#3 0x4006cb6d in gst_init_check_with_popt_table ()
   from /usr/lib/libgstreamer-0.8.so.1
#4 0x400c7846 in ?? () from /usr/lib/libgstreamer-0.8.so.1
#5 0x4006c500 in gst_init_check_with_popt_table ()
   from /usr/lib/libgstreamer-0.8.so.1
#6 0x00000245 in ?? ()
#7 0x00000000 in ?? ()
#8 0x400c8020 in ?? () from /usr/lib/libgstreamer-0.8.so.1
#9 0x400c7991 in ?? () from /usr/lib/libgstreamer-0.8.so.1
#10 0x4017238c in ?? () from /usr/lib/libgstreamer-0.8.so.1
#11 0xbffff414 in ?? ()
#12 0xbffff578 in ?? ()
#13 0x4006c4d1 in gst_init_check_with_popt_table ()
   from /usr/lib/libgstreamer-0.8.so.1
#14 0x40c8cae3 in realloc () from /lib/tls/libc.so.6
Previous frame inner to this frame (corrupt stack?)
(gdb) disassemble 0x40078a7e
Dump of assembler code for function _gst_cpu_initialize_none:
0x40078a60 <_gst_cpu_initialize_none+0>: push %ebp
0x40078a61 <_gst_cpu_initialize_none+1>: xor %eax,%eax
0x40078a63 <_gst_cpu_initialize_none+3>: mov %esp,%ebp
0x40078a65 <_gst_cpu_initialize_none+5>: pop %ebp
0x40078a66 <_gst_cpu_initialize_none+6>: ret
0x40078a67 <_gst_cpu_initialize_none+7>: mov %esi,%esi
0x40078a69 <_gst_cpu_initialize_none+9>: lea 0x0(%edi),%edi
0x40078a70 <_gst_cpu_initialize_none+16>: push %ebp
0x40078a71 <_gst_cpu_initialize_none+17>: mov %esp,%ebp
0x40078a73 <_gst_cpu_initialize_none+19>: sub $0x18,%esp
0x40078a76 <_gst_cpu_initialize_none+22>: mov
%esi,0xfffffffc(%ebp)
0x40078a79 <_gst_cpu_initialize_none+25>: mov 0x8(%ebp),%eax
0x40078a7c <_gst_cpu_initialize_none+28>: mov %ebx,%esi
0x40078a7e <_gst_cpu_initialize_none+30>: cpuid
0x40078a80 <_gst_cpu_initialize_none+32>: mov
%eax,0xffffffe8(%ebp)
0x40078a83 <_gst_cpu_initialize_none+35>: mov
%ebx,0xffffffec(%ebp)
0x40078a86 <_gst_cpu_initialize_none+38>: mov
%ecx,0xfffffff0(%ebp)
0x40078a89 <_gst_cpu_initialize_none+41>: mov
%edx,0xfffffff4(%ebp)
0x40078a8c <_gst_cpu_initialize_none+44>: mov %esi,%ebx
0x40078a8e <_gst_...

Read more...

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 09 Jan 2005 23:49:10 +0100
From: Arnaud Patard <email address hidden>
To: <email address hidden>
Subject: reassign bug

reassign 289362 libgstreamer0.8-0
thanks

As the bug seems to be caused by the libgstreamer, I'm reassigning the
bug

Arnaud

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Tue, 8 Feb 2005 18:46:41 +0100
From: =?iso-8859-1?Q?Lo=EFc?= Minier <email address hidden>
To: Richard Mortimer <email address hidden>, <email address hidden>,
 <email address hidden>
Subject: Re: capplets: gnome-settings-daemon dies repeatedly with SIGILL

forwarded 289362 http://bugzilla.gnome.org/show_bug.cgi?id=3D166696
thanks

        Hi,

 This is a followup for Debian bug <http://bugs.debian.org/289362>.

Richard Mortimer <email address hidden> - Sat, Jan 08, 2005:

> I have just loaded Debian/testing on an old Cyrix P133+ based machine
> and when I attempted to start control-center I found that
> gnome-settings-daemon was continually crashing with a SIGILL. I got a
> backtrace from GDB which shows it was running libgstreamer-0.8.so.1 cod=
e
> and had executed a cpuid instruction. I'm presuming that this is either
> privileged or not-implemented on the cpu.

 I've reported your bug upstream and you might want to subscribe to the
 upstream discussion at:
    <http://bugzilla.gnome.org/show_bug.cgi?id=3D166696>

 The solution isn't easy, and support for Cyrix or 386 CPUs is not on
 upstream's priorities, hence your problem might take a while to be
 fixed.

   Regards,

--=20
Lo=EFc Minier <email address hidden>
"Neutral President: I have no strong feelings one way or the other."

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Fri, 18 Feb 2005 14:30:50 +0100
From: =?iso-8859-1?Q?Lo=EFc?= Minier <email address hidden>
To: <email address hidden>, <email address hidden>
Subject: #289362 is RC

severity 289362 serious
thanks

 Discussing this with the release team, it seems #289362 is RC.

--=20
Lo=EFc Minier <email address hidden>
"Neutral President: I have no strong feelings one way or the other."

Matt Zimmerman (mdz) wrote :

Sebastien, is this a major issue for Ubuntu?

Sebastien Bacher (seb128) wrote :

I don't think so, we have no bug about it for the moment.

Source: gstreamer0.8
Source-Version: 0.8.9-2

We believe that the bug you reported is fixed in the latest version of
gstreamer0.8, which is due to be installed in the Debian FTP archive:

gstreamer0.8-doc_0.8.9-2_all.deb
  to pool/main/g/gstreamer0.8/gstreamer0.8-doc_0.8.9-2_all.deb
gstreamer0.8-tools_0.8.9-2_i386.deb
  to pool/main/g/gstreamer0.8/gstreamer0.8-tools_0.8.9-2_i386.deb
gstreamer0.8_0.8.9-2.diff.gz
  to pool/main/g/gstreamer0.8/gstreamer0.8_0.8.9-2.diff.gz
gstreamer0.8_0.8.9-2.dsc
  to pool/main/g/gstreamer0.8/gstreamer0.8_0.8.9-2.dsc
libgstreamer0.8-0_0.8.9-2_i386.deb
  to pool/main/g/gstreamer0.8/libgstreamer0.8-0_0.8.9-2_i386.deb
libgstreamer0.8-dev_0.8.9-2_i386.deb
  to pool/main/g/gstreamer0.8/libgstreamer0.8-dev_0.8.9-2_i386.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
David I. Lehn <email address hidden> (supplier of updated gstreamer0.8 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Wed, 16 Mar 2005 01:17:29 -0500
Source: gstreamer0.8
Binary: gstreamer0.8-doc gstreamer0.8-tools libgstreamer0.8-dev libgstreamer0.8-0
Architecture: source i386 all
Version: 0.8.9-2
Distribution: unstable
Urgency: low
Maintainer: David I. Lehn <email address hidden>
Changed-By: David I. Lehn <email address hidden>
Description:
 gstreamer0.8-doc - GStreamer documentation
 gstreamer0.8-tools - Tools for use with GStreamer
 libgstreamer0.8-0 - Core GStreamer libraries, plugins, and utilities
 libgstreamer0.8-dev - GStreamer development libraries and headers
Closes: 289362
Changes:
 gstreamer0.8 (0.8.9-2) unstable; urgency=low
 .
   * debian/patches/cpuid.patch:
     * Patch from upstream to check for cpuid support (Closes: #289362)
   * debian/watch:
     * Watch for gstreamer not gst-plugins
Files:
 0e098bd826d723407f11ab24b1fa09d1 1075 libs optional gstreamer0.8_0.8.9-2.dsc
 0329be6acc9a98edab9c5e50975463c9 40233 libs optional gstreamer0.8_0.8.9-2.diff.gz
 52be8a9e84245c0e730d1d94841ab6f7 1763600 doc optional gstreamer0.8-doc_0.8.9-2_all.deb
 9f7147e0e0febe2280fb1b85bf538634 754448 libs optional libgstreamer0.8-0_0.8.9-2_i386.deb
 aaff756ae3add35b143e526f25c60175 578750 libdevel optional libgstreamer0.8-dev_0.8.9-2_i386.deb
 24a46bafb2d97a3e4d743148254f0d96 129930 utils optional gstreamer0.8-tools_0.8.9-2_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)

iD8DBQFCOIYrPIQIWBo7SN4RAoR2AJ96UQ98+FX2LReO/S75NY0U+t0DjwCfdS+A
q/MvjcCUN67PEf/NUhvJMXU=
=IKuS
-----END PGP SIGNATURE-----

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Wed, 16 Mar 2005 14:33:04 -0500
From: <email address hidden> (David I. Lehn)
To: <email address hidden>
Subject: Bug#289362: fixed in gstreamer0.8 0.8.9-2

Source: gstreamer0.8
Source-Version: 0.8.9-2

We believe that the bug you reported is fixed in the latest version of
gstreamer0.8, which is due to be installed in the Debian FTP archive:

gstreamer0.8-doc_0.8.9-2_all.deb
  to pool/main/g/gstreamer0.8/gstreamer0.8-doc_0.8.9-2_all.deb
gstreamer0.8-tools_0.8.9-2_i386.deb
  to pool/main/g/gstreamer0.8/gstreamer0.8-tools_0.8.9-2_i386.deb
gstreamer0.8_0.8.9-2.diff.gz
  to pool/main/g/gstreamer0.8/gstreamer0.8_0.8.9-2.diff.gz
gstreamer0.8_0.8.9-2.dsc
  to pool/main/g/gstreamer0.8/gstreamer0.8_0.8.9-2.dsc
libgstreamer0.8-0_0.8.9-2_i386.deb
  to pool/main/g/gstreamer0.8/libgstreamer0.8-0_0.8.9-2_i386.deb
libgstreamer0.8-dev_0.8.9-2_i386.deb
  to pool/main/g/gstreamer0.8/libgstreamer0.8-dev_0.8.9-2_i386.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
David I. Lehn <email address hidden> (supplier of updated gstreamer0.8 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Wed, 16 Mar 2005 01:17:29 -0500
Source: gstreamer0.8
Binary: gstreamer0.8-doc gstreamer0.8-tools libgstreamer0.8-dev libgstreamer0.8-0
Architecture: source i386 all
Version: 0.8.9-2
Distribution: unstable
Urgency: low
Maintainer: David I. Lehn <email address hidden>
Changed-By: David I. Lehn <email address hidden>
Description:
 gstreamer0.8-doc - GStreamer documentation
 gstreamer0.8-tools - Tools for use with GStreamer
 libgstreamer0.8-0 - Core GStreamer libraries, plugins, and utilities
 libgstreamer0.8-dev - GStreamer development libraries and headers
Closes: 289362
Changes:
 gstreamer0.8 (0.8.9-2) unstable; urgency=low
 .
   * debian/patches/cpuid.patch:
     * Patch from upstream to check for cpuid support (Closes: #289362)
   * debian/watch:
     * Watch for gstreamer not gst-plugins
Files:
 0e098bd826d723407f11ab24b1fa09d1 1075 libs optional gstreamer0.8_0.8.9-2.dsc
 0329be6acc9a98edab9c5e50975463c9 40233 libs optional gstreamer0.8_0.8.9-2.diff.gz
 52be8a9e84245c0e730d1d94841ab6f7 1763600 doc optional gstreamer0.8-doc_0.8.9-2_all.deb
 9f7147e0e0febe2280fb1b85bf538634 754448 libs optional libgstreamer0.8-0_0.8.9-2_i386.deb
 aaff756ae3add35b143e526f25c60175 578750 libdevel optional libgstreamer0.8-dev_0.8.9-2_i386.deb
 24a46bafb2d97a3e4d743148254f0d96 129930 utils optional gstreamer0.8-tools_0.8.9-2_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)

iD8DBQFCOIYrPIQIWBo7SN4RAoR2AJ96UQ98+FX2LReO/S75NY0U+t0DjwCfdS+A
q/MvjcCUN67PEf/NUhvJMXU=
=IKuS
-----END PGP SIGNATURE-----

Sebastien Bacher (seb128) wrote :

 gstreamer0.8 (0.8.9-1ubuntu3) hoary; urgency=low
 .
   * Sync with Debian.
   * debian/patches/cpuid.patch:
     - patch from upstream to check for cpuid support (Hoary: #6714).

        Hi,

On mer, mar 16, 2005, David I. Lehn wrote:
> * debian/patches/cpuid.patch:
> * Patch from upstream to check for cpuid support (Closes: #289362)

 Upstream said the initial patch was crap (see
 <http://bugzilla.gnome.org/show_bug.cgi?id=166696>), could you backport
 a newer patch from CVS?

   Bye,

--
Loïc Minier <email address hidden>
"Neutral President: I have no strong feelings one way or the other."

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 26 Mar 2005 09:44:56 +0100
From: =?iso-8859-1?Q?Lo=EFc?= Minier <email address hidden>
To: "David I. Lehn" <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#289362: fixed in gstreamer0.8 0.8.9-2

        Hi,

On mer, mar 16, 2005, David I. Lehn wrote:
> * debian/patches/cpuid.patch:
> * Patch from upstream to check for cpuid support (Closes: #289362)

 Upstream said the initial patch was crap (see
 <http://bugzilla.gnome.org/show_bug.cgi?id=3D166696>), could you backpor=
t
 a newer patch from CVS?

   Bye,

--=20
Lo=EFc Minier <email address hidden>
"Neutral President: I have no strong feelings one way or the other."

Changed in gstreamer0.8:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.