Ubuntu

Assertion fails in subtitleeditor when opening video

Reported by Henrik Heino on 2012-04-29
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
subtitleeditor
Fix Released
Unknown
gstreamer0.10 (Ubuntu)
Undecided
Unassigned
subtitleeditor (Ubuntu)
Undecided
Philip Rinn

Bug Description

First I opened Subtitleeditor with no subs or video.
Then I opened subtitle file and everything went nicely.
Then I opened video file and program crashed.

Here is backtrace:

#0 0x00007ffff4203445 in __GI_raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1 0x00007ffff4206bab in __GI_abort () at abort.c:91
#2 0x00007ffff424abed in __malloc_assert (assertion=<optimized out>, file=<optimized out>, line=<optimized out>, function=<optimized out>) at malloc.c:300
#3 0x00007ffff424dedd in _int_malloc (av=0x7ffff4583720, bytes=24) at malloc.c:3795
#4 0x00007ffff424fa45 in __GI___libc_malloc (bytes=24) at malloc.c:2924
#5 0x00007ffff5004a39 in g_malloc () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6 0x00007ffff501929e in g_strdup () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7 0x00007ffff753142a in gst_element_class_set_details_simple () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#8 0x00007ffff54df419 in g_type_class_ref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#9 0x00007ffff54c7cac in g_object_newv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#10 0x00007ffff54c81ec in g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#11 0x00007fffe50c8c3c in ?? () from /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstplaybin.so
#12 0x00007ffff54e1908 in g_type_create_instance () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#13 0x00007ffff54c60b9 in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#14 0x00007ffff54c76e4 in g_object_newv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#15 0x00007ffff574984a in Glib::Object::Object(Glib::ConstructParams const&) () from /usr/lib/x86_64-linux-gnu/libglibmm-2.4.so.1
#16 0x00007ffff78efbd5 in Gst::Object::Object(Glib::ConstructParams const&) () from /usr/lib/libgstreamermm-0.10.so.2
#17 0x00007ffff78df4bd in Gst::Element::Element(Glib::ConstructParams const&) () from /usr/lib/libgstreamermm-0.10.so.2
#18 0x00007ffff78d4c75 in Gst::Bin::Bin(Glib::ConstructParams const&) () from /usr/lib/libgstreamermm-0.10.so.2
#19 0x00007ffff78f462d in Gst::Pipeline::Pipeline(Glib::ConstructParams const&) () from /usr/lib/libgstreamermm-0.10.so.2
#20 0x00007ffff7926b7b in Gst::PlayBin2::PlayBin2(Glib::ustring const&) () from /usr/lib/libgstreamermm-0.10.so.2
#21 0x00007ffff79273f1 in Gst::PlayBin2::create(Glib::ustring const&) () from /usr/lib/libgstreamermm-0.10.so.2
#22 0x0000000000423e8a in ?? ()
#23 0x0000000000424459 in ?? ()
#24 0x00007fffda160995 in VideoPlayerManagement::on_open() () from /usr/lib/subtitleeditor/plugins/actions/libvideoplayermanagement.so
#25 0x00007ffff574ae08 in Glib::SignalProxyNormal::slot0_void_callback(_GObject*, void*) () from /usr/lib/x86_64-linux-gnu/libglibmm-2.4.so.1
#26 0x00007ffff54c0ca2 in g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#27 0x00007ffff54d1fdd in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#28 0x00007ffff54da099 in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#29 0x00007ffff54da242 in g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#30 0x00007ffff5eb3193 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#31 0x00007ffff54c0ca2 in g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#32 0x00007ffff54d2179 in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#33 0x00007ffff54da099 in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#34 0x00007ffff54da242 in g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#35 0x00007ffff608e38e in gtk_widget_activate () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#36 0x00007ffff5f890fd in gtk_menu_shell_activate_item () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#37 0x00007ffff5f89495 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#38 0x00007ffff5f74dd8 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#39 0x00007ffff54c0ca2 in g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#40 0x00007ffff54d2339 in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#41 0x00007ffff54d9d7e in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#42 0x00007ffff54da242 in g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#43 0x00007ffff608f191 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#44 0x00007ffff5f72f63 in gtk_propagate_event () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#45 0x00007ffff5f732c3 in gtk_main_do_event () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#46 0x00007ffff59c3cac in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0
#47 0x00007ffff4ffec9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#48 0x00007ffff4fff060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#49 0x00007ffff4fff45a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#50 0x00007ffff5f722f7 in gtk_main () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#51 0x00007ffff6dfa326 in Gtk::Main::run(Gtk::Window&) () from /usr/lib/x86_64-linux-gnu/libgtkmm-2.4.so.1
#52 0x0000000000415212 in ?? ()
#53 0x00007ffff41ee76d in __libc_start_main (main=0x414f70, argc=1, ubp_av=0x7fffffffe748, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffffffe738) at libc-start.c:226
#54 0x0000000000415ac5 in ?? ()
#55 0x00007fffffffe738 in ?? ()
#56 0x000000000000001c in ?? ()
#57 0x0000000000000001 in ?? ()
#58 0x00007fffffffe9ee in ?? ()
#59 0x0000000000000000 in ?? ()

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: subtitleeditor 0.39.0-2
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Sun Apr 29 17:05:42 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
SourcePackage: subtitleeditor
UpgradeStatus: Upgraded to precise on 2012-04-05 (23 days ago)

Henrik Heino (henu) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in subtitleeditor (Ubuntu):
status: New → Confirmed
Changed in subtitleeditor:
importance: Unknown → Medium
status: Unknown → New
Philip Rinn (rinni) wrote :

It's not a specific problem of subtitleeditor but of libgstreamermm-0.10-2 or libgstreamer0.10-0. So I close the bug for subtitleeditor.

Changed in gstreamer0.10 (Ubuntu):
status: New → Confirmed
Changed in subtitleeditor (Ubuntu):
assignee: nobody → Philip Rinn (rinni)
status: Confirmed → Invalid
Changed in gstreamermm (Debian):
status: Unknown → New
Ramaddan (ramaddan) wrote :

Same problem.

Anything happening on this front?

This bug has been there since my upgrade to precise.

Frederic Beister (azamir) wrote :

Just to add some info: I installed two machines in parallel (work and home), both with Ubuntu 12.04, one 32bit and one 64bit. I installed mostly the same packages (just restoring my default list). This bug only occurs on the 64bit machine.

Changed in subtitleeditor:
status: New → Confirmed
Changed in subtitleeditor:
status: Confirmed → Expired
TomasHnyk (sup) wrote :

This has been fixed (or workaround - gsteamer developers are looking into it) in trunk subtitleeditor. Meanwhile, the patch is attached to this comment. Change directory to the root directory of subtitleeditor source and apply with
patch -p0 < /path/to/fix-playbin.patch

Hope it helps someone!

The attachment "fix-playbin.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
TomasHnyk (sup) wrote :

BTW: look on the upstream gnome bug - the underlying problem in gstreamer binding was fixedover a year and a half ago:

"For more of a reference see the following thread:

https://mail.gnome.org/archives/gtkmm-list/2012-December/msg00024.html

The problem was corrected in gstreamermm-0.10.9.1 and upwards (I just checked
to make sure). Maybe ubuntu and debian could use a later version than 0.10.9?
As I said in the above mentioned thread, that would fix the problem. I'm sorry

For the curious, this is the commit that fixed this inadvertently quite some
time ago:
http://git.gnome.org/browse/gstreamermm/commit/?id=9678d4173cc17677bcc70891861d0f4cd46e48f9

And here's the related one (the one that is referred to in the commit that
fixes this):
http://git.gnome.org/browse/gstreamermm/commit/?id=d1a6deab637e2d7331cf9eeefee28876688932a2 "

Changed in subtitleeditor:
status: Expired → Confirmed
Philip Rinn (rinni) wrote :

I'd prefere to close this bug as it's fixed in Ubuntu now.
It was a gstreamermm bug which was fixed in 0.10.9.1. Ubuntu now has 0.10.11.

Changed in subtitleeditor:
importance: Medium → Unknown
status: Confirmed → Unknown
TomasHnyk (sup) wrote :

Yep, that sound plausible!

Philip Rinn (rinni) wrote :

It's not a bug in gstreamer but in gstreamermm.

Changed in gstreamer0.10 (Ubuntu):
status: Confirmed → Invalid
no longer affects: gstreamermm (Debian)
Philip Rinn (rinni) wrote :

Subtitleeditor 0.40.0-1 has a workaround for this bug (which is fixed in Ubuntu anyway).

Changed in subtitleeditor (Ubuntu):
status: Invalid → Fix Released
Changed in subtitleeditor:
status: Unknown → Fix Released
Ramaddan (ramaddan) wrote :

Hi,

It still crashes with me in Quantal.

When it is said that the fix has already been released, in which version exactly?

Because I need to know if it is supposed to be fixed in Quantal as well, or else I have a different priblem.

Thanks

Hi,

it's fixed in version 0.40.0-1 so you need to take the version from Raring.

Regards

Am 30.01.2013 18:12, schrieb Ramaddan:
> Hi,
>
> It still crashes with me in Quantal.
>
> When it is said that the fix has already been released, in which version
> exactly?
>
> Because I need to know if it is supposed to be fixed in Quantal as well,
> or else I have a different priblem.
>
> Thanks
>

Ramaddan (ramaddan) wrote :

Hi,

I tried running the subtitle Editor packages from raring on quantal, and they installed without any problem.

However, it does not run, giving me the following error:

undefined symbol: _ZN3Gst12MILLI_SECONDE

I am assuming that this symbol is supposed to be defined by some package somewhere, and I am assuming that is has something to do with a gstream pakage, due to the "gst" part in the message, but I could be wrong, and I wish the message was more meaningful to me.

Thanks

TomasHnyk (sup) wrote :

You may try to compile the version for quantal with the patch attached here compiled in, that should work (that is what I do).

Ramaddan (ramaddan) wrote :

Hi,

I downloaded the source from raring, and it already contained the patches, and compiled it in Quantal, and all went well.

Working now, thanks :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.